ModellIT User Guide

<Virtual Environment> 6.3
# Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>ModellIT User Guide</td>
<td>1</td>
</tr>
<tr>
<td>&lt;Virtual Environment&gt; 6.0</td>
<td>1</td>
</tr>
<tr>
<td>1. Introduction</td>
<td>6</td>
</tr>
<tr>
<td>1.1. What is ModellIT?</td>
<td>6</td>
</tr>
<tr>
<td>1.2. Using This Guide</td>
<td>6</td>
</tr>
<tr>
<td>2. Fundamentals</td>
<td>7</td>
</tr>
<tr>
<td>2.1. Projects</td>
<td>7</td>
</tr>
<tr>
<td>2.2. The ModellIT Workspace</td>
<td>7</td>
</tr>
<tr>
<td>2.2.1. Pull-down Menu Bar</td>
<td>8</td>
</tr>
<tr>
<td>2.2.2. Model Toolbar</td>
<td>8</td>
</tr>
<tr>
<td>2.2.3. Edit Toolbar</td>
<td>8</td>
</tr>
<tr>
<td>2.3. Model Browser</td>
<td>8</td>
</tr>
<tr>
<td>2.3.1. Viewport</td>
<td>9</td>
</tr>
<tr>
<td>2.3.2. View Toolbar</td>
<td>10</td>
</tr>
<tr>
<td>2.4. Object Bar</td>
<td>10</td>
</tr>
<tr>
<td>2.5. Status Bar</td>
<td>11</td>
</tr>
<tr>
<td>2.6. Levels of Decomposition</td>
<td>12</td>
</tr>
<tr>
<td>2.7. Toolbars</td>
<td>13</td>
</tr>
<tr>
<td>2.7.1. Model Toolbar</td>
<td>13</td>
</tr>
<tr>
<td>2.7.2. Edit Toolbar</td>
<td>14</td>
</tr>
<tr>
<td>2.7.3. Generic View Toolbar</td>
<td>15</td>
</tr>
<tr>
<td>2.8. Object Bar</td>
<td>15</td>
</tr>
<tr>
<td>3. Model Browser Functions</td>
<td>16</td>
</tr>
<tr>
<td>3.1. Room Groups</td>
<td>16</td>
</tr>
<tr>
<td>3.1.1. Edit Room Groups</td>
<td>17</td>
</tr>
<tr>
<td>3.1.2. Add Selected Rooms to Room Groups</td>
<td>18</td>
</tr>
<tr>
<td>3.1.3. Group Scheme Drop-down List</td>
<td>18</td>
</tr>
<tr>
<td>3.2. Space List</td>
<td>18</td>
</tr>
<tr>
<td>3.2.1. Properties</td>
<td>20</td>
</tr>
<tr>
<td>3.2.2. Sort</td>
<td>20</td>
</tr>
<tr>
<td>3.2.2.1. Alphabetically</td>
<td>20</td>
</tr>
<tr>
<td>3.2.2.2. By Room Group</td>
<td>20</td>
</tr>
<tr>
<td>3.2.2.3. By Layer</td>
<td>21</td>
</tr>
<tr>
<td>3.2.2.4. Advanced</td>
<td>21</td>
</tr>
<tr>
<td>3.2.3. Select</td>
<td>22</td>
</tr>
<tr>
<td>3.2.4. Delete</td>
<td>22</td>
</tr>
<tr>
<td>4. Model Functions</td>
<td>23</td>
</tr>
<tr>
<td>4.1. Colour</td>
<td>23</td>
</tr>
<tr>
<td>4.2. Layers</td>
<td>24</td>
</tr>
<tr>
<td>4.3. Grid Settings</td>
<td>25</td>
</tr>
<tr>
<td>4.4. Grid Origin</td>
<td>25</td>
</tr>
<tr>
<td>4.5. Locks</td>
<td>26</td>
</tr>
<tr>
<td>4.5.1. Grid</td>
<td>26</td>
</tr>
<tr>
<td>4.5.2. Axis</td>
<td>27</td>
</tr>
<tr>
<td>4.5.3. Endpoint</td>
<td>27</td>
</tr>
</tbody>
</table>
4.5.4. Midpoint..........................................................................................27
4.5.5. Nearest Point..................................................................................27
4.5.6. Perpendicular ..............................................................................27
4.5.7. Parallel ..........................................................................................27
4.5.8. Drawing Guides ............................................................................27
4.5.9. Angular Lock ................................................................................27
4.5.10. Drag Face Lock ...........................................................................27
4.5.11. Face Snapping .............................................................................28
4.6. Draw Arc ............................................................................................28
4.7. Draw Extruded Shape .......................................................................29
4.8. Draw Prism .......................................................................................30
4.9. Draw Pyramid ..................................................................................31
4.10. Draw Sphere ...................................................................................32
4.11. Draw Hemisphere ...........................................................................33
4.12. Draw Cylinder ................................................................................34
4.13. Draw Partition .................................................................................35
4.15. Remove All Construction Lines ......................................................36
4.16. Add Door .........................................................................................36
4.17. Add Window ....................................................................................38
4.18. Add Hole ..........................................................................................38
4.19. Import gbXML File .........................................................................39
4.20. Import GEM File .............................................................................39
4.21. Construct DXF ................................................................................39
4.22. Create Slice ....................................................................................39

5. Model Viewer ...................................................................................41
5.1. Icons ..................................................................................................41
5.2. Mousecam controls .........................................................................42
5.3. Display Settings ...............................................................................44
5.4. Set Camera Path .............................................................................45

6. APIlocate .........................................................................................48

7. Edit Functions .................................................................................49
7.1. Key-in Field .....................................................................................49
7.2. Undo ..................................................................................................50
7.3. Redo ..................................................................................................50
7.4. Select Object ....................................................................................50
7.5. Measure Length ...............................................................................51
7.6. Measure Angle ................................................................................51
7.7. Query Co-ordinates .........................................................................51
7.8. Copy ..................................................................................................52
7.9. Move ..................................................................................................52
7.10. Scale ................................................................................................53
7.11. Rotate ..............................................................................................54
7.12. Mirror .............................................................................................54
7.13. Drag Face ........................................................................................55
7.14. Connect Spaces ...............................................................................55
7.15. Edit Attributes ..............................................................................56
8. **View Functions** ................................................................. 67
   8.1. Fit View ................................................................. 67
   8.2. Zoom Window .......................................................... 68
   8.3. Zoom In ................................................................. 69
   8.4. Zoom Out .............................................................. 69
   8.5. Pan ...................................................................... 69
   8.6. Zoom Previous ........................................................ 69
   8.7. Zoom Next ............................................................ 69
   8.8. View Selection ....................................................... 70
   8.9. Set Axonometric Rotation .......................................... 71
   8.10. Rotate View .......................................................... 71
   8.11. Mode Selection ..................................................... 71
   8.12. Storey Level Selection ........................................... 72
   8.13. Move Up One Level ............................................... 72
   8.14. Move Down One Level ........................................... 72
   8.15. Object List .......................................................... 73
   8.16. North Indicator ..................................................... 74
   8.17. Co-ordinate Location ............................................. 74

9. **ModelIT Menu Functions** ............................................... 75
   9.1. Attach DXF File ..................................................... 75
   9.2. Detach DXF File .................................................... 76
   9.3. Active DXF Layers ................................................ 76
   9.4. Move DXF File ....................................................... 76
   9.5. Attach Obstructions File ........................................ 76
   9.6. Detach Obstructions File ........................................ 76
   9.7. Import GEM File .................................................... 77
   9.8. Export GEM File .................................................... 78
   9.9. Import gbXML File ................................................ 78
   9.10. Export STL File .................................................... 83
   9.11. Export DXF File ................................................... 83
   9.12. Attach/Detach Bitmap File ..................................... 84
   9.13. Merge Model Data ................................................ 84

10. **Settings Menu / Model** ............................................... 86
    10.1. Adjacency Separation Distance .............................. 86
    10.2. Vertical-Horizontal element transition angle ............. 86
    10.3. Rebuild ............................................................ 86
    10.4. Geometry - Check Options .................................... 87
10.5. Visibility ........................................................................................................................... 90
10.6. Room Types/Obstructions ................................................................................................. 91
1. Introduction

1.1. What is ModelIT?

ModelIT is the model building component of the <Virtual Environment>. ModelIT allows the user to create the 3D models required by other components within the <Virtual Environment>. ModelIT is designed to enable appropriate levels of complexity to be incorporated within a model across the entire design spectrum.

At the sketch design or feasibility stage, basic models may be generated from scratch using a variety of simple modelling tools, in order to conduct preliminary performance appraisals or comparative studies.

Similarly, at the other end of the design process, fully worked DXF files may be attached to ModelIT and using the tools provided, three-dimensional building spaces may be generated rapidly by tracing over the DXF outlines. Moreover, in the case of the optional Construct/DXF module, a complete model including doors and windows may be generated from a DXF file entirely automatically.

1.2. Using This Guide

This guide introduces the terminology used to describe ModelIT and includes a description of all the ModelIT features i.e. toolbars, pull-down menu items and pop-up windows.
2. Fundamentals

2.1. Projects

When the <Virtual Environment> is started up a blank project is initialised and the “ModelIT” workspace is activated. For more details of creating/opening/saving projects please refer to general help topics Section 3, "File" menu for more information.

The Model space window default background colour is white, with the grid in black. This can be altered to the user’s choice. Please refer to general help topics, Section 5.7.2 System colours for more information.

2.2. The ModelIT Workspace

The sub-window you are now looking at is the ModelIT workspace, with the Model Browser on the left.

The workspace is divided as follows:
2.2.1. Pull-down Menu Bar

This provides an alternative method of accessing the functions available on the various toolbars.

2.2.2. Model Toolbar

This contains functions mainly associated with creating models.

2.2.3. Edit Toolbar

This contains functions mainly associated with editing models.

2.3. Model Browser
2.3.1. Viewport

Hovering with the mouse pointer over rooms or surfaces will highlight the one in focus. The highlight colour can be changed or this function can be turned off in the Tools>Preference dialog. (Please refer to section 5.7.1 general help topics for more information)

The viewport window can also be used to show two or four viewports:
### 2.3.2. View Toolbar

This contains functions mainly associated with viewing models.

### 2.4. Object Bar

<table>
<thead>
<tr>
<th>Number</th>
<th>Room Name</th>
<th>Room ID</th>
<th>Volume (m³)</th>
<th>Floor area (m²)</th>
<th>External wall area</th>
<th>External opening area</th>
<th>Colour</th>
<th>Layer</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>Left Office</td>
<td>103008</td>
<td>60,000</td>
<td>230,000</td>
<td>147,208</td>
<td>12,000</td>
<td>Blue</td>
<td>Layer 1</td>
</tr>
</tbody>
</table>

This contains information associated with the current object(s):

- Zone number (in order of the space list)
- Room name
- Room ID
- Volume (total volume for a multiple selection)
- Floor area (total area for a multiple selection)
- External wall area
- External opening area
- Colour
- Layer

When more than one zone is selected the sum of the quantities is shown (e.g. room groups).

The "Object Bar" and toolbars can be switched on/off and the viewport options selected from the "View" pull-down menu. For more information see general help topics user guide-section 4-View options)
2.5. Status Bar

This displays the coordinates in the active model space.
2.6. Levels of Decomposition

In order to simplify modelling processes, ModelIT uses a hierarchical approach referred to as "levels of decomposition", whereby a model is considered to comprise a series of spaces, and a space comprises a series of surfaces, resulting in three levels of decomposition:

Model
Space
Surface

At each level there are various options available to the user, there is detailed information on modifying the model later in this guide.

When you start ModelIT or open a new project, the initial level of decomposition is always Model. The "Mode Selection" field shows which level is active (see section 6.11 for more details). At this level of decomposition you can create or modify room data.

In order to move down a level of decomposition from Model, you must first select a single space. You will notice that the "Move Down One Level" button on the View toolbar is now activated. When this is activated the display will change to fit the selected space into the view window, and the "Mode Selection" field changes from "Model" to "Surface". You will notice that the "Mode selection" drop-down list in the View toolbar is now active, allowing you to switch modes. At the Space level of decomposition, there are two modes, "Surface" and "Edit".

"Surface" mode is used to review or modify surface data. "Edit" mode is used to divide single spaces into multiple composite spaces, to separate composite spaces into individual spaces, and to edit the vertex positions of spaces (see section 6.11 for more details).

In "Surface" mode you can now move down another level of decomposition to the Surface level by using the "Move Down One Level" button again. The "Mode Selection" field changes from "Surface" to "Opening". At this level there are two modes, "Opening" and "Adjacency".

"Opening" mode is used for creating or modifying windows and doors. "Adjacency" mode is used to review or modify adjacency data, where an adjacency is an area of a surface which is either adjacent to the exterior or another space.

To move up a level of decomposition use the "Move Up One Level" tool button.
Note if you have more than one viewport open, and the level of decomposition in one of the viewports is below Model level, you will not be able to select any other space in any of the other viewport until the level of decomposition is restored to Model in all viewports.

2.7. Toolbars

The toolbars save you time by enabling you to select some of the most frequently used commands, without having to select them from the pull-down menus at the top of the ModelIT window. Each toolbar is described below from left to right.

2.7.1. Model Toolbar

- Colour/Colour table
- Layer/Layer properties
- Grid Settings
- Grid origin
- Locks
- Draw Arc
- Draw Extruded Shape
- Draw Prism
- Draw Pyramid
- Draw Sphere
- Draw Hemisphere
- Draw Cylinder
- Draw Partition
- Construction Lines
- Remove All Construction Lines
- Add Door
- Add Window
- Add Hole Between Adjacent Zones
2.7.2. Edit Toolbar

To activate the edit toolbar first select a volume. Refer to section 7 for more information on the edit commands.

Key-in Field

- Undo
- Redo
- Select Object
- Measure length
- Measure angle
- Query Coordinates
- Copy Selection Set (Click and hold left mouse button to utilise)
- Move Selection Set (Click and hold left mouse button to utilise)
- Scale Selection Set
- Rotate Selection Set
- Mirror Selection Set (Click and hold left mouse button to utilise)
- Drag Face (works best in axonometric view – when you hover over a face to drag it will highlight in yellow)
- Resize Opening

This option activates in edit mode when at a surface level only. When at surface level, select the opening to edit. Then select the vertices of the opening to edit by dragging a window. Click and hold the right mouse button and drag it in the direction to utilise.
2.7.3. Generic View Toolbar

For more information on this toolbar please refer to General help topics user guide section 2.3.4.

2.8. Object Bar

At the Model level the object bar displays details of the first object that was selected:

<table>
<thead>
<tr>
<th>Room Name</th>
<th>Room ID</th>
<th>Volume (m³)</th>
<th>Floor Area (m²)</th>
<th>Colour</th>
<th>Layer</th>
</tr>
</thead>
<tbody>
<tr>
<td>zone A</td>
<td>ZN_0000</td>
<td>103.87</td>
<td>28.88</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

The "Room Name", "Colour" and "Layer" can all be edited by double clicking on the field. The other fields are read-only.

At the Surface level the object bar displays details of the selected surface:

<table>
<thead>
<tr>
<th>Surface Area (m²)</th>
<th>Surface Orientation (°)</th>
<th>Surface T (°C)</th>
</tr>
</thead>
<tbody>
<tr>
<td>8.50</td>
<td>60.00</td>
<td>29.00</td>
</tr>
</tbody>
</table>

At the Opening level the object bar displays details of the selected opening:

<table>
<thead>
<tr>
<th>Opening Type</th>
<th>Opening Area (m²)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Window</td>
<td>1.51</td>
</tr>
</tbody>
</table>

At the Adjacency level the object bar displays adjacency details of the selected surface:

<table>
<thead>
<tr>
<th>Adjacency Area (m²)</th>
<th>Adjacent Room Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>25.86</td>
<td>EXTERIOR</td>
</tr>
</tbody>
</table>
3. Model Browser Functions

This section looks at functions associated with the Model Browser. There are 2 sections:

- Room groups
- Space list

3.1. Room Groups

The room groups mechanism allows the user to specify a grouping scheme and then room groups within this grouping scheme. For example, a grouping scheme called ‘Floors’ would then have room groups called ‘Ground Floor’, ‘First Floor’, etc. The room groups consist of zones from the space list. A zone can be placed within more than 1 room group and more than 1 grouping scheme. The room group’s controls are contained within the following display at the top of the space list/model browser.
3.1.1. Edit Room Groups

This icon allows the user to bring up the Edit Room Groups window. The user can then create their grouping schemes and the room groups within these.
3.1.2. Add Selected Rooms to Room Groups

Selecting this icon brings up the Assign Room Group window. The user can then select the desired Room Group that the previously selected rooms will be added to. The user must be in the desired grouping scheme in order to bring up the required room groups in the list.

3.1.3. Group Scheme Drop-down List

This displays the Group Schemes currently available. Selecting a group scheme will switch the space list to display the room groups within this scheme.

3.2. Space List

The space list is where all the rooms or room groups are displayed dependent on which grouping scheme the user has currently selected. The space list can be used to select a room or room group for the user’s purpose.

Here the space list is displaying all rooms with surface details displayed for 1:
Here the space list is displaying all room groups within the ‘Floors’ grouping scheme:

By right clicking on a room, selection of rooms or room group the following options will appear:
3.2.1. Properties

This allows the user to rename a zone and also allows them to alter the room type to either:

- Room
- Adjacent Building
- Topographical Shade
- Local Shade

3.2.2. Sort

There are 5 options within the sort list:

Alphabetically
By Room Group
By All Room Groups
By Layer
Advanced

3.2.2.1. Alphabetically

Sorts rooms based on their alphabetical order.

3.2.2.2. By Room Group

The rooms will be sorted by the grouping scheme which is first in the grouping schemes order; then by the second grouping scheme within each occurrence of the first grouping scheme; etc. The following tree breakdown display explains this:
Grouping Scheme 1
- Group 0
  - Grouping Scheme 2
    - Group 0
      - Grouping Scheme 3
        - Group 0
  - Group 1
    - Grouping Scheme 2
      - Group 0
        - Grouping Scheme 3
          - Group 0
  - Group 2
    - Grouping Scheme 2
      - Group 0
        - Grouping Scheme 3
          - Group 0

3.2.2.3. By Layer
Sorts rooms based on the layer number they are positioned on.

3.2.2.4. Advanced

![Sort Rooms Window](image)

Allows the user to select one or more fields by which to sort rooms. The rooms will be sorted by the first field; then by the second field within each occurrence of the first field; etc. The order can be ascending or descending. Included in the sort field options are all grouping schemes along with:

- Room name
- Colour
- Layer
- Heating Zone
- Cooling Zone
3.2.3. Select

Allows the user to select room groups across grouping schemes. There are 2 options:

- All rooms in all chosen groups
- Only rooms common to the chosen groups

3.2.4. Delete

Allows user to delete room/rooms or rooms within a room group.
4. Model Functions

This section looks at functions associated with the Model toolbar.

4.1. Colour

ModelIT uses colours for highlighting, indicating inactive layers, displaying DXF elements and distinguishing one layer from another. ModelIT uses a Colour Table to store up to sixty-four user defined colours, which will be stored with a project.

The Colour box displays the active object colour and colour number. Any new object placed will be assigned this object colour. If you click on the button to the right the following window is opened:

To modify a colour move the mouse so that the cursor is over the required colour and double-click or click on the "Change Colour" button. The common Windows colour dialogue box opens allowing you to define a colour. Define a colour and then click "OK" to keep it. On return to the colour table dialogue box, click "OK" to retain the modified Colour Table.

Note that you can choose to display objects in the model either by their object colour or by their layer colour, by selecting "Colour" from the View pull-down menu. The default is to display objects by their layer colour.
4.2. Layers

(“Settings” ⇒ “Layer” or the layer properties button on the model toolbar)

This option enables the Layers dialogue box which has the tab – “Properties” (the "Active" tab has been removed). One of the main purposes of layers is that it allows you to make parts of your model inactive. The “Properties” tab now allows the user to switch layers ON/OFF or to select a single layer and "Edit" the properties. The “active” layer is highlighted in the pinkish colour and cannot be switched OFF. The Shift key may be used to multi-select.

The two properties are name and colour:

When parts of your model are inactive they will be grey in colour and you will be unable to edit them for modelling purposes or include them in simulations for thermal purposes.
4.3. Grid Settings

(“Settings” ⇒ “Grid”)

Pops-up the following window:

![Grid Settings Dialogue Box]

The grid is used as an aid in model creation (provided the appropriate Lock is active). The Grid Settings dialogue box may be left open throughout the drawing process or may be closed and re-opened at any time. The user can set the drawing grid spacing in the X and Y directions, determined by the values entered in the X and Y Spacing fields.

Note that if the spacing is too small for the view in the ModelIT window (i.e. if the grid mesh is too fine), the grid will not be displayed. You may display/hide the grid by clicking in the Display box. The Grid and Axis locks will function even if the grid is not displayed.

4.4. Grid Origin

(“Edit” ⇒ “Set Grid Origin”)

This option allows you to position an intersection of the X and Y drawing grid lines at a location determined by a mouse click. This placement will be determined by the Locks settings (see 4.5). The default location is at the model origin (the model origin is not modified by this option).
4.5. Locks

(“Settings” ⇒ “Locks”)

Pops-up the following window:

![Locks Window]

Locks are used to force points placed during drawing operations to fall precisely at positions determined by the lock. The Locks dialogue box may be left open throughout the drawing process or may be closed and re-opened at any time.

4.5.1. Grid

Checking this box causes the origin of a line or other element to be fixed at the nearest grid line intersection (See Endpoint below) to a point on the view determined by a mouse click.
4.5.2. **Axis**

Checking this box enables a line to be drawn orthogonally with regard to the grid. The position of the mouse pointer with regard to the origin of the line determines which grid line the drawn line follows.

4.5.3. **Endpoint**

Selecting this option enables you to snap on the nearest end point of an existing line. If the Grid is locked on, the new line/element will snap to the nearest grid unless the Endpoint is nearer.

4.5.4. **Midpoint**

Selecting this option enables you to snap on the nearest middle point of an existing line. If the Grid is locked on, the new line/element will snap to the nearest grid unless the Midpoint is nearer.

4.5.5. **Nearest Point**

Selecting this option enables you to snap to a point anywhere along a surface.

4.5.6. **Perpendicular**

When using draw extruded shape, the line being drawn will display light blue if it is 90 degrees to the previously drawn line.

4.5.7. **Parallel**

Selecting this option enables you to draw a surface parallel to that of another zone. Using the draw extruded shape, move the cursor near the surface which you want to draw parallel to and press shift. Then when you go to draw your surface you will see the line is displayed yellow indicating it is parallel.

4.5.8. **Drawing Guides**

Selecting this option enables you to draw a line to a snap point in line with another surface either on the X or Y axis. Drawing guides are not designed to be used in conjunction with grid snap.

4.5.9. **Angular Lock**

Selecting this option enables you to draw a line with draw extruded shape with an angular setting. The user finds their desired angle and can then type in the length of the surface and press <enter>. The surface has then been drawn and the user can move on to the next point.

4.5.10. **Drag Face Lock**

This lock option allows you to control the distance that you adjust a volume size by when you are using the Drag face tool.
4.5.11. **Face Snapping**

This lock option allows you to drag the face of a room that you are editing to match up with another existing room face without having to type in any dimension information.

4.6. **Draw Arc**

(“Draw” ⇒ “Arc”)

If you want to incorporate an arc within the perimeter of an extruded shape or pyramid base, use this option. This button becomes active after you have placed the first point of an extruded shape or pyramid perimeter. It allows you to define a curve that originates from the last vertex you have placed. The “Arc Settings” dialogue box opens -

![Arc Settings](image)

The "Sweep" setting is used to define the sweep angle (in degrees) of the arc, a positive value for a clockwise sweep and negative for an anti-clockwise sweep. The "Segments" setting is used to define the number of straight-line segments used to create the arc. The accuracy of the arc may be improved by increasing the number of segments. However, the greater the number of segments, the longer the processing times will be. When you move the cursor back into the model window, you will see a small circle attached to the cursor. This circle is used to define the centre of the arc. When the arc is placed, you may place another arc, or press the right mouse button to continue drawing the extruded shape or 'unwind' the arc segment by segment by repeatedly pressing the right mouse button.
4.7. Draw Extruded Shape

(“Draw” ⇒ “Extruded Shape”)

Pops-up the following window:

![Shape Settings Window](image)

Selecting this command allows you to create an extruded shape as a series of straight-line segments. Select each point of the shape in turn, in either clockwise or anti-clockwise order. To close the shape, click on the “Close Shape” button which is active while you are drawing the shape. If you make a mistake and need to undo a point, click on the right mouse button. The current lock settings will apply and key-in values can also be used. The extruded shape will be created with the defined Plane (m) and Depth (m) values as currently set in the Shape Settings dialogue box. An extruded shape can be created along any axis.

Note that you cannot cross a segment with another segment and you cannot place a perimeter point on an existing perimeter point unless it is the first point in which case this will close the shape.

The relevant key-ins for the extruded shape are:

\[ x = <x, y> \]
\[ dx = <dx, dy> \]
\[ p = <length, angle>. \]
4.8. Draw Prism

(“Draw” ⇒ “Prism”)

Pops-up the following window:

Selecting this command allows you to create a prism shape. Select the point where one corner of the prism is to be located, then select the point that is at the opposite corner of the prism. A new prism will then be created with the defined Plane (m) and Depth (m) values as currently set in the Shape Settings dialogue box. A prism can be created along any axis.

The relevant key-ins for the prism are:

\[ x = \langle x, y \rangle \]
\[ dx = \langle dx, dy \rangle \]
\[ p = \langle \text{length, angle} \rangle. \]
4.9. Draw Pyramid

(“Draw” ⇒ “Pyramid”)

Pyramids are created in a very similar way to extruded shapes except that after completing the perimeter, you will enter a point to define the apex of the pyramid.

Pops-up the following window:

![Shape Settings dialog box](image)

Selecting this command allows you to create a pyramid shape. To create pyramids, you must first define the shape of the base of the pyramid and then position the top of the pyramid. To define the pyramid base, select each point on the perimeter of the base in turn, in either clockwise or anti-clockwise order. To close the shape, click on the "Close Shape" button on the Shape Settings dialogue box which is active while you are drawing the shape. Next, select the position of the top of the pyramid. A new pyramid will be created with the base at the defined Plane (m) value as currently set, and the top point at the Plane + Depth (m) values as currently set. A pyramid can be created along any axis.

The relevant key-ins for the pyramid are:

- \( x=x, y \)
- \( dx=dx, dy \)
- \( p=\text{length, angle} \).
4.10. Draw Sphere

(“Draw” ⇒ “Sphere”)

Pops-up the following window:

Selecting this command allows you to create a spherical shape. To create a sphere, first select the centre of the sphere and then select a point which defines the radius of the sphere. A new sphere will be created with its centre at the defined Plane (m) level that is currently set in the Shape Settings dialogue box which is active while you are drawing the shape. The number of chord segments which make up the sphere is defined in the Shape Settings dialogue box. A sphere can be created along any axis.

The relevant key-ins for the sphere are:

\[ x=<x, y> \]
\[ dx=<dx, dy> \]
\[ p=<\text{length, angle}>. \]
4.11. Draw Hemisphere

(“Draw” ⇒ “Hemisphere”)

Hemispheres are created in exactly the same way as spheres.

Pops-up the following window:

Selecting this command allows you to create a hemispherical shape. To create a hemisphere, first select the centre of the hemisphere and then select a point which defines the radius of the hemisphere. A new hemisphere will be created with its base at the defined Plane (m) level that is currently set in the Shape Settings dialogue box which is active while you are drawing the shape. The number of chord segments which make up the hemisphere is defined in the Shape Settings dialogue box. A hemisphere can be created along any axis.

The relevant key-ins for the hemisphere are:

\[ x=x, \ y= \]  
\[ dx=dx, \ dy= \]  
\[ p=\text{length, angle}. \]
4.12. Draw Cylinder

(“Draw” ⇒ “Cylinder”)

Cylinders are created in a similar way to spheres and hemispheres.

Pops-up the following window:

Selecting this command allows you to create a cylindrical shape. To create a cylinder, first select the centre of the cylinder and then select a point that defines the radius of the cylinder. A new object will be created with the defined Plane (m) and Height/Depth (m) at the values currently set in the Shape Settings dialogue box which is active while you are drawing the shape. The number of chord segments which make up the cylinder is defined in the Shape Settings dialogue box. A cylinder can be created along any axis.

The relevant key-ins for the cylinder are:

\[ x = \langle x, y \rangle \]
\[ dx = \langle dx, dy \rangle \]
\[ p = \langle \text{length, angle} \rangle . \]
4.13. Draw Partition

(“Draw” ⇒ “Construction Line”)
Draw partitions of any shape into existing zones to generate sub zones or separate zones. The Partitioning dialog gives various options for representation of the new space in the model.


(“Draw” ⇒ “Construction Line”)
Selecting this command allows you to draw a construction line which can be used to trace along and/or snap to a point. Construction lines follow the same process of drawing as extruded shape except the user does not have to return the start point as this is not a space.
4.15. Remove All Construction Lines

(“Edit” ⇒ “Remove All Construction Lines”)

This command only becomes active when a construction line has been drawn.

4.16. Add Door

(“Edit” ⇒ “Add Opening” ⇒ “Door”)

Doors can be placed at any level of decomposition.

At model level when Add Door is selected the Add Opening dialog pops up:

This has pre-built openings that can be used to place any type of opening on any surface by entering Base Height, Width and Height then selecting the location on the surface where the opening is desired.

These openings are based on components within the CompLib component Modeller. Any new or existing component given the category Opening can be used as an opening in ModelIT.

When the level of decomposition is at the Surface level there are 3 modes available, “Rectangular”, “Polygonal” or “100%”.
The default setting is to place rectangular doors. Place a door by entering a data point for one corner of the door and then drag a box to the diagonally opposite corner of the door. However, you can also place polygonal shaped doors by clicking on the small arrow button next to the “Add Door” button and selecting the “Polygonal” option. Complete the door by pressing the ’C’ key on your keyboard. This command remains active allowing you to add multiple doors onto the same surface. For 100%, select the 100% opening option and click on the surface.

Note at the Surface level of decomposition, you are always looking from the inside of a space outwards.

Select the space at Model level and move down to the Space level. Select the surface to which you want to add a door and move down to the Surface level.

Key-In: In “Rectangular” mode: dx=<dx, dy> to select first and/or second corner (relative to the bottom left corner of the surface). In “Polygonal” mode: dx=<dx, dy> after first co-ordinate has been selected manually.
4.17. Add Window

(“Edit” ⇒ “Add Opening” ⇒ “Window”)

This option operates identically to the “Add Door” option (see section 4.15).

Windows can be placed at any level of decomposition.

At model level when Add Window is selected the Add Opening dialog pops up (see section 4.15).

When the level of decomposition is at the Surface level there are 3 modes available, “Rectangular”, “Polygonal” or “100%” (see section 4.15).

The default setting is to place rectangular windows. Place a window by entering a data point for one corner of the window and then drag a box to the diagonally opposite corner of the window. However, you can also place polygonal shaped windows by clicking on the small arrow button next to the "Add Window" tool button and selecting the "Polygonal" option. Complete the window by pressing the ‘C’ key on your keyboard.

Key-In: As for "Add Door" see section 4.15.

4.18. Add Hole

(“Edit” ⇒ “Add Opening” ⇒ “Hole”)

This option operates identically to the "Add Door" option (see section 4.15).

Holes can be placed at any level of decomposition.

At model level when Add Hole is selected the Add Opening dialog pops up (see section 4.15).

When the level of decomposition is at the Surface level there are 3 modes available, “Rectangular”, "Polygonal" or “100%” (see section 4.15).

This has the effect of retaining two separate spaces, but there is a hole (sometimes referred to as a superfices) in the connecting partition.

Key-In: As for "Add Door" see section 4.15.
4.19. Import gbXML File

(“File” ⇒ “Import gbXML File”)

See Section 7.8 for details.

4.20. Import GEM File

(“File” ⇒ “Import GEM File”)

See Section 7.6 for details.

4.21. Construct DXF

See the Construct DXF User Guide for details.

4.22. Create Slice

This option allows a user to create a 2D dxf file by a slice through a selection of rooms. The following window indicates the display.
A cutting plane is selected and ‘Create Slice’ selected. The user will then be prompted to save the dxf file.
5. Model Viewer

Clicking one either of these two icons opens the following window:

![Model Viewer Window](image)

5.1. Icons

The Pan, Orbit and Zoom functions are controlled by the mouse buttons.

The following icons are available:

- **Print**
- **Copy image to clipboard**
- **Save**: Saves as a .bmp file.
- **Create avi**: The user can orbit, zoom and pan in when making their own movie of the model.
Camera Path (See P44 for more information)

X-Ray Effect
Wireframe display
Hidden Line Removal display
Shaded display
Open Display Settings Dialog
Textured display
Display ground plane.
Mousecam – Standard camera controls.
Flycam – Fly-through camera.
Walkcam – Walk-through camera.
Recover – Reverts views to default.
Goto Room
Toggle between dialog window and docked window

5.2. Mousecam controls

<table>
<thead>
<tr>
<th>Control</th>
<th>Action</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Left mouse button</td>
<td>Click and drag</td>
<td>Orbit</td>
</tr>
<tr>
<td>Right mouse button</td>
<td>Click and drag</td>
<td>Pan</td>
</tr>
<tr>
<td>Middle mouse button (wheel)</td>
<td>Click and drag</td>
<td>Pan</td>
</tr>
<tr>
<td>Middle mouse wheel</td>
<td>Scroll</td>
<td>Zoom</td>
</tr>
</tbody>
</table>

An alternative to scrolling with a middle mouse wheel is to hold the Ctrl button on your keyboard and click and drag the left mouse button to zoom in or out.

Flycam (and Walkcam) controls:
<table>
<thead>
<tr>
<th>Key</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>W</td>
<td>Move forward</td>
</tr>
<tr>
<td>S</td>
<td>Move backwards</td>
</tr>
<tr>
<td>A</td>
<td>Strafe / sidestep left</td>
</tr>
<tr>
<td>D</td>
<td>Strafe / sidestep right</td>
</tr>
<tr>
<td>E</td>
<td>Raise eye level</td>
</tr>
<tr>
<td>C</td>
<td>Lower eye level</td>
</tr>
</tbody>
</table>

Click and drag the left mouse button to look around in Walk-through and Fly-through modes to control direction of motion (Walk-through movement will be restricted to be parallel to the ground plane).

To speed up scroll the middle mouse wheel forward, scrolling backwards will slow down. Alternatively, press Ctrl and left click drag forwards and backwards to control speed.

Recover will revert all views back to the original defaults when ModelViewer was opened.

The *Goto Room* feature takes the user directly into the room selected in the Model browser. Simply select the room and click on the *Goto Room* button and the view position will be changed to inside the room.

Display Controls Overlay:
In any view the controls can be displayed in the bottom right corner of the Model Viewer by pressing F2.
5.3. Display Settings

A sketch like style of displaying the model is now available. View settings can be adjusted with the Display Settings dialog. Extension shows architectural extension of lines, end points shows dotted end points and jitter shows sketchy rendering style.

Model viewer shows textures assigned to surfaces in ModelIT. Settings can be changed for improved rendering in the User Preferences dialog. Bump mapping – depth, specular mapping – shininess

By default, controls are displayed each time the Model Viewer is opened. This feature can be switched off in the Model Viewer Settings dialog (Tools > Preferences > Model Viewer Settings tab. For more information please refer to General help topics user guide section 5.7.3.).
5.4. Set Camera Path

This allows the user to record a camera path while moving around the building or even go inside by adding view positions and directions using the Camera Path dialog. These locations can be edited at any time and the camera path will be visualized in model viewer if the option Show path is active. An animation can be created based on the created camera path. (This option can be switched off for final recordings.)

Creating an AVI with the camera path tool

First open up the model viewer, select the Fly through first person camera and click on the camera path tool. Next manoeuvre the camera to the position you would like the AVI to start at.

Now click the right hand Add> arrow to add your first camera position.

Next move your view to the next point where you would like your AVI to stop or change direction and click the Add> button again. Follow this same process to make your full camera path.

Once you have created your path you click the Build button to create the AVI.
You can then click play to view your AVI, use the Back and Forward to go through the AVI frame by frame or use the fader bar to manually scroll through.

If you are happy with the AVI on the first take then you can click the record button to make your AVI file. Once the software has recorded the camera path the user will be given the option of where to save the AVI. Once a suitable location has been selected the Make the video button can be clicked.

Other Options such as the Show path and frames per second can be altered. The camera path can also be saved to be opened and used again at a later date.

When the save option is used a new modelviewer folder is created within the project folder.
Once you have created your path you have a few options that allow you to edit your camera path.

The Prev and Next buttons can be used to jump to the main camera positions and using the remove option can erase any hold positions.

If you want to <Add a camera into a sequence use the <Add button or if you want to Add> an additional camera hold position onto the end of a sequence then used the Add> button. If you do add or remove any additional cameras remember to perform another build of the AVI.

You can also manually edit the camera hold positions, time transitions between points, view orientation and direction. Again use the Prev and Next buttons to cycle through to the position you wish to edit and then click edit.

When you do this you will see the all these options mentioned will no longer be greyed out allowing them to be edited.

These variables can be altered and the steps described on the previous pages followed to create the new AVI and as before the new edited path can be saved for future use.
6. APlocate

This button activates the APlocate application which allows the user to edit data related to the site location of the model.

For more information please refer to the APlocate User Guide.
7. Edit Functions

This section looks at functions associated with the Edit toolbar.

7.1. Key-in Field

This allows you to enter commands or positional information using key-ins instead of the mouse. You must press the Enter key after typing a key-in.

The Key-in field is the hatched area shown above, although any text keyed in the ViewPort will be moved here. If the focus is in this area and ESC is pressed then a menu with some of the simpler key-ins is shown.

A document which lists all the key-ins is available.
7.2. Undo

(“Edit” ⇒ "Undo")

Use this command to reverse the last action.

7.3. Redo

(“Edit” ⇒ "Redo")

Use this command to reverse an "Undo" action.

7.4. Select Object

(“View” ⇒ "Select Object")

Various controls require object selection before they can be used, e.g. copying or rotating spaces. ModelIT supports both multiple and single object selection. To select a single object, click on the "Select Object" button in the Edit toolbar, move the mouse so that the cursor is over the object to be selected and then click the left mouse button (without dragging the cursor).

Another method of space selection is to use the Model Browser. By default the Model Browser is to the left of the ModelIT workspace, although it can be moved or hidden (see the Virtual Environment Framework document for more details). Single zones can be selected by clicking on the zone to highlight it. There are two methods of multiple selections. The first method involves holding down the <CTRL> key on your keyboard while repeatedly selecting single objects in the model view or in the Model Browser. The second method is similar to single object selection except that after pressing the mouse button to select an object, you keep the mouse button pressed and drag the cursor across the objects to be selected.

You will also notice that various buttons on the Edit toolbar, which were formerly inactive, become active. This is because the controls associated with these tool buttons require space selection before they can be used.

In order to de-select objects, choose the “Select Object” button. Move the mouse so the cursor is in the active model window and click the right mouse button.
7.5. **Measure Length**

(“Edit” ⇒ “Measure” ⇒ “Length”)

This command allows you to measure the distance between two points. The distance in metres will be shown in the "Key-in" field in the edit toolbar.

7.6. **Measure Angle**

(“Edit” ⇒ “Measure” ⇒ “Angle”)

This command allows you to measure the angle between two points. The angle will be shown in the "Key-in" field in the edit toolbar.

7.7. **Query Co-ordinates**

(“Edit” ⇒ “Query”)

This button is only active at the Model level; it highlights the point nearest to the cursor and displays the x, y, z co-ordinates in the "Co-ordinate" field in the view toolbar. In this mode the dynamic display of the cursor location is switched off.
7.8. Copy

("Edit" ⇒ "Selection Set" ⇒ “Copy")

Use this command to copy the selected objects in any 2D view. Once the object(s) are selected, click and hold the left mouse button and drag the object(s) to the new position in the active view. The copy will then be completed, provided there are no intersection errors. Absolute and relative coordinates may be keyed in to copy spaces.

Note if you want to use a vertex as the handle point for copying a group, you must press the mouse button when the cursor is close to the vertex (zoom in if necessary). Otherwise the handle point will be the actual model space point selected, even if there is no object at that point.

A new feature is to use two clicks rather than drag – if the first click hasn’t moved position, then this position is used as the “handle” point and the second click is used as the “placement” position – this allows the Viewport to be manipulated between clicks.

Key-In: dx=<dx, dy>

7.9. Move

("Edit" ⇒ "Selection Set" ⇒ “Move")

Use this command to move the selected objects in any 2D view. Once the object(s) are selected, click and hold the left mouse button to drag the object(s) to the new position in the active view. The move will then be completed, provided there are no intersection errors.

A new feature is to use two clicks rather than drag – if the first click hasn’t moved position, then this position is used as the “handle” point and the second click is used as the “placement” position – this allows the Viewport to be manipulated between clicks.

Key-In: dx=<dx, dy>
7.10. Scale

(“Edit” ⇒ “Selection Set” ⇒ “Scale”)

Use this command to scale the selected objects in any 2D view. The "Scale Object" dialogue box will appear, in which you can enter the scale factors for the x, y and z axes.

The "Lock Axes" check box is used to lock all three axes to the same scale factor. Next, click on one of the handle points of the selected objects to carry out the scaling operation.

The scaling limits are set at 0.0001 to 9999.9; any values entered out with this range will give the following warning:
7.11. Rotate

(“Edit” ⇒ “Selection Set” ⇒ “Rotate”)

Use this command to rotate the selected objects in any 2D view. The "Rotate Object" dialogue box will appear. Enter the angular increments by which you wish to rotate the selected objects.

Now as you move the cursor around the defined axis point, you will see the objects rotating by increments dictated by the "Angular Increment" setting in the "Rotate Object" dialogue box. Click the left mouse button when you have the required rotation, and the rotation will be completed.

7.12. Mirror

(“Edit” ⇒ “Selection Set” ⇒ “Mirror”)

Use this command to create a mirror copy of the selected objects in any 2D view. The "Mirror Object" dialogue box will appear, in which you select the mirror axis – "Horizontal axis" or "Vertical axis".

Move the cursor so that it is close to a space vertex that you want to use as the handle point and then press the left mouse button. Keeping the button pressed, drag the mirror copy of selected spaces to the required location, and then release the mouse button. The mirror copy will then be completed.
7.13. Drag Face

(“Edit” ⇒ “Selection Set” ⇒ “Drag Face”)

Drag a selected face a desired amount. Use the lock menu to adjust default settings.

7.14. Connect Spaces

(“Edit”)

If you wish to model a space with a complex shape (e.g. a room with a dome shaped rooflight), and you wish to treat this space as one zone, you must first draw the two shapes separately, and then connect them using the "Connect Spaces" option. This will create a single composite space.

Select one of the spaces and then select the "Connect Spaces" option, the following dialogue box will appear:
Select the space you wish to connect to by selecting it in the view or the Model Browser. The name of this second space will appear in the "Add Spaces" section of the dialogue box.

Before you connect the spaces you can decide if you wish the partitions between them to be removed or retained after connection, by selecting the required option from the drop down list in the Connect Spaces dialogue box. To connect the two spaces (i.e. to create a single composite space) click the "Connect" button. Note, spaces that are "connected" can be separated using the “Separate Composite Space” option.

Two new options are now available – the “Merge” option will join two spaces into a single space and the “Subtract” option will cut one space from the other. For both these options the two zones have to be bounded with each other, i.e. share some common surfaces. Also note these are different from the “connect” option in that they cannot be reversed using the “Separate Composite Space” option (although you can still use the “Undo” option while it is still active). Before using the “Subtract” option you must first create the space to be subtracted inside the other space; this requires the “intersection=off” mode to be active.

### 7.15. Edit Attributes

Use this command to edit the "Colour" and/or "Layer" of the selected space. Pops-up the following window:
7.16. Edit Glazing

(“Edit” ⇒ ”Selection Set” ⇒ “Glazing”)

Use this option to place, replace or remove glazing in selected rooms. Pops-up the following window:

There are four options:

"Add by Percentage Area"
"Add by Percentage Area /Heights"
"Add by Height/Width/Spacing"
"Remove"

Each tab has a different set of items to set:

You can set the minimum and maximum azimuth in the first two columns and the minimum and maximum tilt in the third and fourth columns. For this tab the only other value to set is the "% Area".

At MODEL level - select a set of zones - key in "g=50" (or "G=50") - this will create 50% glazing on external surfaces.
"Min. Azimuth", "Max Azimuth", "Min Tilt" and "Max Tilt" defined as above. The other values to set in this tab are the lower sill (Y-Offset) of the window, Height and "% Area".

The next tab allows a more complex arrangement to be defined:

<table>
<thead>
<tr>
<th>Add by Percentage Area</th>
<th>Add by Percentage Area/Heights</th>
<th>Add by Height/Width/Spacing</th>
<th>Remove</th>
</tr>
</thead>
<tbody>
<tr>
<td>Min Azimuth</td>
<td>Max Azimuth</td>
<td>Min Tilt</td>
<td>Max Tilt</td>
</tr>
<tr>
<td>0.00</td>
<td>360.00</td>
<td>90.00</td>
<td>90.00</td>
</tr>
</tbody>
</table>

"Min. Azimuth", "Max Azimuth", "Min Tilt" and "Max Tilt" defined as above. The distance from the edge of the wall is defined, "X-Offset", and from the bottom of the wall, "Y-Offset". The size of each window is defined by "Height" and "Width". The distance between each window is defined by "X-Spacing" and "Y-Spacing". The default is for the number of rows and columns to be automatically created by the numbers that fit, "-", but if required these may be constrained to a specific number.

<table>
<thead>
<tr>
<th>Add by Percentage Area</th>
<th>Add by Percentage Area/Heights</th>
<th>Add by Height/Width/Spacing</th>
<th>Remove</th>
</tr>
</thead>
<tbody>
<tr>
<td>Min Azimuth</td>
<td>Max Azimuth</td>
<td>Min Tilt</td>
<td>Max Tilt</td>
</tr>
<tr>
<td>0.00</td>
<td>360.00</td>
<td>90.00</td>
<td>90.00</td>
</tr>
</tbody>
</table>

Click on "Apply" to apply the settings to the selected room(s).

Note: when entering azimuth or tilt angles, if you enter a minimum value that is greater than a maximum value or vice versa, the value that you last entered will reset itself.

7.17. Edit Opening size and shape

When in Surface level (see Model Decomposition), this function becomes active. This feature allows to resized and reshape existing openings. Just left select a vertice and use the right mouse button to drag it to a new location. An arrow will show the vertex shift.

7.18. Edit Element Heights

("Edit" ⇒ "Selection Set" ⇒ "Element Heights")
Use this command to modify ceiling, floor and opening heights for the selected objects. Pops-up the following window:

From the top list, select the element type you wish to modify - “Floors/Ceilings”, “Windows”, “Doors”. The list box displays a list of selected element heights throughout the set of selected spaces. Notice that as you select each height in the list, the edges of all elements at this height are highlighted and a bounding frame is displayed around the highlighted edges. Select the height you wish to modify from the “Heights” list, enter the new height in the “Change To” box, and click on the “Change” button.

If “Dependent” Mode is used in the case of ceilings and floors (the mode selection is disabled when modifying window or door heights), the spaces above will shift up or down accordingly (i.e. the total height of the building will change). If “Independent” Mode is used, the location of the adjacent spaces above will remain static, and so the adjacent spaces above will shrink or grow in height (i.e. the total height of the building will remain static).

It is usually easier to see the various element heights if you select an Axonometric view in the active model window before using the "Set Element Heights".
7.19. Create Roof

Pops-up the following window:

![Generate Roofs window](image)

- **Slope (°):** 30
- **Overlap (in):** 0.250

Creates a pitched roof over the selected space(s) with the defined characteristics i.e. "Slope" and "Overlap", provided other conditions are met e.g. non-interpenetration.

7.20. Assign textures

Assign textures to external and internal surface for an improved visual representation of the model with the Assign Texture function. Select a texture from the list and click the Replace button to assign the new texture.

![Assign Surface Textures window](image)

Applied changes can immediately be seen in Model Viewer.
7.21. Refresh Display

In order to cut down on the time spent refreshing the display, particularly as models get larger and more complex; ModelIT has a minimal approach to refreshing the display. This button provides the user with this function.

7.22. Delete

("Edit" ⇒ "Delete")

Use this command to delete the selected objects. If you delete an object by mistake, use the "Undo" option to retrieve the object(s).
7.23. Divide Space

This is the first tab option in the "Edit Space" window.

First select the zone you would like to divide and go down to the space level using the level arrows as shown previously.

Next select edit from the drop down menu.
The edit space dialogue box (image below) will appear along with the cutting plane in the modelling window.

You can select the orientation of the plane:

- Click on the tool at the top of the box to get locator co-ordinates from space vertex tool.
- Then click and drag (holding the left mouse button) the three corner points of the cutting plane in the model space to position it as shown in the diagram on the next page.

You can either manually type in the co-ordinates of the cutting plane or click on the tool at the top of the box to get locator co-ordinates from space vertex tool then click and drag (holding the left mouse button) the three corner points of the cutting plane in the model space to position it as shown in the diagram on the next page.
Click the generate cutting plane button and a yellow indicator will appear giving you a preview of the cut.

Finally you select whether or not you would like to retain the partitions and click the divide space button.
7.24. Separate Composite Space

This is the second tab option in the "Edit Space" window.

![Edit Space Window]

This gives the user the option of creating separate spaces from the composite space. So if the user has used the Divide Space tool they must use the Separate Composite space tool to make the Rooms complete separate entities. The other scenario where this tab would be utilised is when the user has connect two (or more) spaces and wish them to be separated again.
7.25. Edit Vertices

This is the third tab option in the "Edit Space" window.

The user selects vertices, which are highlighted in the view. Multiple selections can be made by using the <CTRL> key. When the "Move Vertices" button is pressed the defined shift in x, y and z is applied.

When the user is in a 2D view the button becomes active, which allows the user to drag the selected vertices in the graphics window.

If after making the defined modifications to the space, a surface is warped, then the following pop-up warning is issued and the user can either resume editing the vertices or restore the original space.
8. View Functions

This section looks at functions associated with the View toolbar.

8.1. Fit View

(“View” ⇒ “Zoom” ⇒ “Fit”)

Use this command to fit the whole model into the active view.
8.2. Zoom Window

(“View” ⇒ “Zoom” ⇒ “Window”)

Use this command to define a window area to view a particular part of the model. Click in a point in the view to define a corner of your desired window, and keeping the mouse button depressed, move the cursor to the opposite corner, then release the mouse button.
8.3. Zoom In

(“View” ⇒ “Zoom” ⇒ “In”)

Performs an incremental zoom into the view.

8.4. Zoom Out

(“View” ⇒ “Zoom” ⇒ “Out”)

Performs an incremental zoom out from the view.

8.5. Pan

(“View” ⇒ “Zoom” ⇒ “Pan”) or use middle mouse button

Selecting this option activates allows you to pan round the model view. Click in the view, and keeping the mouse button pressed, pan the window to the desired location, and then release the mouse button. The view will be updated with the contents of the panned window. Direct access to the pan function gives the middle mouse button (scroll wheel), keep it pressed while moving the mouse to pan the window to the desired location, and then release the button.

8.6. Zoom Previous

(“View” ⇒ “Zoom” ⇒ “Zoom Previous”) or use Mouse Scroll Wheel

Change the view window to the last view before the current view.

8.7. Zoom Next

(“View” ⇒ “Zoom” ⇒ “Zoom Next”)

Change the view window to the next view in the sequence, assuming the “Zoom previous” has been invoked.
8.8. View Selection

(“View” ⇒ “Rotation”)

Allows the user to view the model from different aspects:

- Plan  (“View” ⇒ “Rotation” ⇒ “Plan View [X-Y]”)
- Back  (“View” ⇒ “Rotation” ⇒ “Back View [X-Z]”)
- Front (“View” ⇒ “Rotation” ⇒ “Front View [X-Z]”)
- Right (“View” ⇒ “Rotation” ⇒ “Right View [Y-Z]”)
- Left  (“View” ⇒ “Rotation” ⇒ “Left View [Y-Z]”)
- Axon. (“View” ⇒ “Rotation” ⇒ “Axonometric View”)

For example, axonometric view:

Front view:
8.9. Set Axonometric Rotation

(“View” ⇒ “Rotation” ⇒ “Set Axonometric Rotation”)

This command allows you to define the altitude and azimuth for the axonometric view. This can be done dynamically in the model space using the mouse. When you have the desired rotation click once on the right mouse button to set.

8.10. Rotate View

(“View” ⇒ “Rotation” ⇒ “Rotate View”)

Pops-up the following window:

![Rotate Projection dialog box](image)

From the drop down list in this box you may choose to rotate any 2D view by either "Rotate using two points" within the view (the view will be rotated to the angle between the two points), or by "Rotating by angle" (and entering a rotation angle in the box provided below). You may return the view to its pre-rotated state by choosing the "Unrotate View" option from the drop down list.

8.11. Mode Selection

Model

This is linked to the level of decomposition (see section 2.5).

Initially the mode is MODEL - Model. When a space is selected and the user moves down to the SPACE level the mode changes to Surface. In this mode various functions will become active and others inactive. An
option at this level is to invoke the option, which pops-up the “Edit Space” window. The alternative is to go down another level to the SURFACE level. At this level there is the option to invoke the option.

8.12. Storey Level Selection

The whole model can be viewed or each floor (storey) can be selected individually.

8.13. Move Up One Level

Moves from a lower to a higher level of decomposition. See section “2.5 Levels of decomposition” for more details.

8.14. Move Down One Level

Moves from a higher to a lower level of decomposition. See section “2.5 Levels of decomposition” for more details.
8.15. Object List

When the edit option is invoked the following window is popped-up:

![Edit space window]

This activates the three edit options:

"Divide Space"
"Separate Composite Space"
"Edit Vertices"

These three edit options are described in more detail in sections 7.23, 7.24 and 7.25.

If this window closes whilst you are still in the edit mode you can click on the icon on the generic tool bar and open it again.
8.16. North Indicator

This shows the orientation of the model to North, the default being that North is in the direction of the positive Y-axis.

To edit this value, go to the "Settings" pull-down menu and select the "Site Rotation" option, which pops-up the following window:

A positive angle rotates North anti-clockwise from the +ve Y-axis.

North orientation will be indicated in Model Viewer through an arrow pointing north.

8.17. Co-ordinate Location

In "Query Co-ordinate" mode the location of the selected point is displayed in the coordinate status tool bar at the bottom of the screen, otherwise the cursor location is displayed when it moves across the view window.
9. ModelIT Menu Functions

9.1. Attach DXF File

Use this command to attach a DXF format drawing file to the project. You may only attach one DXF file to the project at any time.

The "Attach DXF File" dialogue box is as follows:

![Attach DXF File Dialogue Box]

The "Scale Factor" is used to specify the DXF file units. You can either opt for one of the set units (metres, inches, etc.) or define your own factor. ModelIT will translate all working units to SI units, which is the adopted IES design software convention.

The "Plane" value refers to the height in the ModelIT Z-plane at which the DXF file is attached. The attachment plane has particular significance when using the optional Construct/DXF module because spaces will be automatically extruded from this plane.
When you attach a DXF file, ModelIT will convert all arcs and curves into series of straight lines or vectors which you will see in the ModelIT view. The arc-chord distance is the maximum distance between the resulting vectors and the actual line, define this value in the "Maximum Arc-Chord Distance" field. A very small arc-chord distance will result in a very accurate representation of the arc or curve but will result in a longer processing time and conversely a large arc-chord distance will produce a less accurate model but much faster processing times.

Select the DXF file and click on "Open" to attach the DXF file. You will then see the DXF file in the ModelIT window.

9.2. Detach DXF File
Use this option to detach a DXF file from the project.

9.3. Active DXF Layers
This option activates the "DXF Layers" dialogue box, which displays the levels (or layers) with which the DXF file was constructed when it was drawn. Clicking the On or Off buttons shows or hides levels of the DXF drawing which may contain information you do not wish to view while building a model, or which you do not wish ModelIT to interrogate during the optional Construct/DXF process, such as furniture, dimensions etc.

Click on "Close" to accept the changes.

9.4. Move DXF File
This allows the user to manipulate the position of the DXF file once it is attached in the VE model space.

9.5. Attach Obstructions File
Opens a MIT file which is to be used as an obstructions file.

9.6. Detach Obstructions File
Use this option to detach an obstructions file from the project.
9.7. Import GEM File

Imports a geometry file in the GEM (geometry) file format into ModelIT. The following window is displayed.

Click Import to bring up the following window. Browse for the desired GEM file and click Open.
The GEM file will be imported for preview as in the following window. Templates can then be applied for:

- Room attributes
- Constructions
- Macroflo opening types
- Thermal conditions
- Electric lighting
- Radiance surface properties

Click OK to confirm the geometry import.

**9.8. Export GEM File**

This option exports the geometry created by ModelIT, to the GEM file format.

**9.9. Import gbXML File**

This function is found in the file drop down menu. It allows for the import of geometry in the gbXML file format into ModelIT. The following window is displayed.
Before clicking Import there are a few surfaces and check options to select from.

You can then select import to bring up the following window. Browse for the desired gbXML file and click Open.
The gbXML file will be imported for preview as in the following window.
Templates can then be applied for:

- Room attributes
- Constructions
- Macroflo opening types
- Thermal conditions
- Electric lighting
- Radiance surface properties

Click OK to confirm the geometry import.

If the source of the gbXML file is Autodesk Revit, then a Heating and Cooling Loads dialog will open:
This window allows the imported model to be viewed with the modelviewer controls. Template data can be set to rooms or the building as desired.

**Building Tab** – Data that can be applied to the entire model.

Building Type can be used to apply thermal template data including Heating and Cooling Set Points, Internal Gains and Air Exchanges.

Building Constructions apply constructions from the Constructions Database to surfaces and openings in the building.

Building Service can be used to select a Service for the building.

Place and Location allows the building geographical position to be set.

**Rooms Tab** – Data can be set for individual rooms.

Level – Can be used to display the rooms that have their z-base on each floor individually.
**Select button**

This causes the model viewer control to show all rooms in normal colours except the selected room(s), which will be shown in red “highlight” colours.

**Isolate Button**

This causes the model viewer control to hide all rooms except the selected room(s).

Room Type, Room Construction and Room Service can be used to apply data to the selected room(s).
9.10. Export STL File

This option saves the selected zone(s) in the "STL" (stereolithography) format. This is an ASCII file where surfaces are broken down into triangular polygons.

The following window is popped-up -

![Export STL Window]

The user has options to include Components and/or Openings in the exported file.

9.11. Export DXF File

This option exports the geometry created by ModelIT, to a 3D dxf file format. The surface representation can be switched between:

- Polyline
- Polyface mesh

Openings (windows, doors, etc.) can be included or not.

![Export DXF File Window]
9.12. Attach/Detach Bitmap File...

This function allows the user to attach bitmap images into the VE model space to create models from an alternative template source.

9.13. Merge Model Data

This will update the current model (the "New" model) with Room Attribute and Template data by matching zones to an existing model (the "Old" model). The following window is popped-up -

Initially this shows the list of zones in the "New" model - the assigned templates are shown when zones are selected, and can be modified by clicking the "Apply changes to Zone" button. This dialog can be used to check and update the model without going into the full "Model Merge".

The next step is to select a "Merge Zones By" option, if you haven’t made a selection and click the “Browse” button first you will get the following pop-up -
When you use the "Browse" button to select the "Old" model, you will get the following pop-up warning:

![Model Merge]

This will overwrite your Templates and current assignments.
Do you want to continue?

Yes  No

When you have selected the "Old" model it replaces any templates you have in your "New" model and replaces the assignments to zones it has "matched" between the two models. The dialog is updated to show this:

![Model Merge]

Zones that have failed to find a match will show "<no match>" and these can be updated by selecting a zone from the "Old" model and using the "Copy to New Model" button.
10. **Settings Menu / Model...**

![Model Settings window]

10.1. **Adjacency Separation Distance**

When a model is created by placing zones side by side (or on top) the relationship between adjacent (or overlapping) surfaces is detected. The "Adjacency Separation distance" is the threshold at which the detection occurs, i.e. if the surfaces are closer than this distance they are flagged as adjacent otherwise not. This value can be changed in the "Model Settings" pop-up window ("Settings"->"Model" menu). After this value has been changed the "rebuild" command should be invoked.

10.2. **Vertical-Horizontal element transition angle**

This is the angle at which a sloping wall becomes a roof/ceiling. In normal zones walls are vertical and roofs/ceilings are horizontal, however if we create complex zones which surfaces at non-vertical and/or non-horizontal surfaces we have to decide whether these are treated as walls or roof/ceiling. This angle is the slope at which this transition occurs.

10.3. **Rebuild**

The "Rebuild" button performs exactly as the "rebuild" key-in option does. This goes through the model and recreates the adjacencies and constructions based on the above two values. This command has to be called after either of the above values has changed.
10.4. Geometry - Check Options

The check options allow the user to run a quick quality check on the geometry they have created. The most common options to use when creating geometry are the intersection and surfaces checks.

If the model geometry has no issues then a report like above will be generated. If there are issues with the geometry the report generated will look like the one below.
The main issues that have to be addressed are Intersections, Non-planar surface and external holes with the latter two issues being of upper most importance. If your model has issue with non-planer surfaces or external holes then you must address these to avoid simulation errors.

To quickly locate a room that you have found issues with follow the steps below:
1: Set the grouping option to rooms in the model browser on the left of the screen.

2: From the model check report there are two unique identifiers. The room number and the room ID. When you cycle through the rooms in the model browser (they are numbered 0; 1; 2 etc) the object bar at the bottom

**Scanning Model for Non-Planar surfaces**

2: [L00S0000] L00: store Surface 1 - non-planar

Scanning Model for Non-Planar surfaces complete

<table>
<thead>
<tr>
<th>Number</th>
<th>Room Name</th>
<th>Room ID</th>
<th>Volume</th>
</tr>
</thead>
<tbody>
<tr>
<td>2</td>
<td>L00: store</td>
<td>L00S0000</td>
<td>53.5</td>
</tr>
</tbody>
</table>

The same process is followed for finding external holes on surfaces. (like rooms, surfaces of a room are numbered 0; 1; 2 etc)
10.5. Visibility

This option allows the user to turn the visibility of rooms off by six different options.

- All rooms
- Selected rooms
- Room
- Adjacent Building
- Topographical Shade
- Local Shade

These visibility controls give the user more options and are similar to the room group ticks in the model browser and the stories options which also allow the user to turn the visibility of rooms on and off.
10.6. Room Types/Obstructions

The way that you set up your models with regards to solar shading devices and obstructions has changed in VE 6. You now have the option when you are creating a room to choose what type of room it is going to be from the following:

Room (1)
Adjacent Building (2)
Topographical Shading (3)
Local Shade (4)

If you forget to set this up when you are creating your model you can change the properties of a room(s) in the model browser at a later point. Please refer to section 3.2 for more information on how to do this.