## CONTENTS

**MODELIT: MODEL BUILDER** .................................................................................................................. 1

1. **INTRODUCTION** ................................................................................................................................. 5
   1.1. WHAT IS MODELIT? ............................................................................................................................ 5
   1.2. USING THIS GUIDE ........................................................................................................................... 5

2. **FUNDAMENTALS** ................................................................................................................................. 6
   2.1. PROJECTS ........................................................................................................................................ 6
   2.2. THE MODELIT WORKSPACE ........................................................................................................ 6
   2.3. MODEL BROWSER ............................................................................................................................. 7
   2.4. OBJECT BAR ................................................................................................................................... 8
   2.5. STATUS BAR ..................................................................................................................................... 9
   2.6. LEVELS OF DECOMPOSITION ........................................................................................................ 10
   2.7. TOOLBARS ....................................................................................................................................... 10
   2.8. OBJECT BAR .................................................................................................................................. 13

3. **MODEL BROWSER FUNCTIONS** ....................................................................................................... 14
   3.1. ROOM GROUPS .............................................................................................................................. 14
   3.2. SPACE LIST .................................................................................................................................... 17

4. **MODEL FUNCTIONS** ........................................................................................................................... 21
   4.1. COLOUR ........................................................................................................................................ 21
   4.2. LAYERS .......................................................................................................................................... 21
   4.3. GRID SETTINGS ............................................................................................................................... 22
   4.4. GRID ALIGNMENT .......................................................................................................................... 22
   4.5. LOCKS ............................................................................................................................................ 23
   4.6. DRAW ARC ..................................................................................................................................... 25
   4.7. DRAW EXTRUDED SHAPE .............................................................................................................. 26
   4.8. DRAW PRISM .................................................................................................................................. 26
   4.9. DRAW PYRAMID ............................................................................................................................. 28
   4.10. DRAW SPHERE ............................................................................................................................... 29
   4.11. DRAW HEMISPHERE ....................................................................................................................... 30
   4.12. DRAW CYLINDER .......................................................................................................................... 31
   4.13. DRAW PARTITION .......................................................................................................................... 32
   4.14. CONSTRUCTION LINES .................................................................................................................. 33
   4.15. REMOVE ALL CONSTRUCTION LINES ............................................................................................ 33
   4.16. ADD DOOR .................................................................................................................................... 34
   4.17. ADD WINDOW ............................................................................................................................... 36
   4.18. ADD HOLE ..................................................................................................................................... 37
   4.19. IMPORT gbXML FILE ..................................................................................................................... 38
   4.20. IMPORT GEM FILE ......................................................................................................................... 38
   4.21. CONSTRUCT DXF ........................................................................................................................... 38
   4.22. CREATE SLICE ............................................................................................................................... 39
   4.23. SCALE SELECTED OPENINGS ......................................................................................................... 40
   4.24. EXTRUDE ALONG A PATH ............................................................................................................... 42
   4.25. OPENING STAMP TOOL ................................................................................................................ 43
   4.26. DRAW SIMPLE OPENINGS IN PLAN VIEW .................................................................................... 44
   4.27. CREATE STOREYS .......................................................................................................................... 45
   4.28. ADD VOIDS AND/OR STRATIFY .................................................................................................... 47
   4.29. MODEL CONSISTENCY REPORT ................................................................................................... 50
   4.30. RENAME ROOMS ........................................................................................................................... 53
5. MODEL VIEWER ............................................................................................................ 54
  5.1. ICONS ......................................................................................................................... 54
  5.2. MOUSECAM CONTROLS ......................................................................................... 55
  5.3. DISPLAY SETTINGS ................................................................................................. 56
  5.4. SET CAMERA PATH ............................................................................................... 57
6. APLocate ..................................................................................................................... 60
7. EDIT FUNCTIONS ......................................................................................................... 61
  7.1. KEY-IN FIELD ......................................................................................................... 61
  7.2. UNDO ....................................................................................................................... 62
  7.3. REDO ....................................................................................................................... 62
  7.4. SELECT OBJECT ..................................................................................................... 62
  7.5. MEASURE LENGTH ............................................................................................... 63
  7.6. MEASURE ANGLE ................................................................................................. 63
  7.7. QUERY CO-ORDINATES ....................................................................................... 63
  7.8. COPY ....................................................................................................................... 63
  7.9. MOVE ...................................................................................................................... 63
  7.10. SCALE ..................................................................................................................... 64
  7.11. ROTATE .................................................................................................................. 64
  7.12. MIRROR ................................................................................................................ 65
  7.13. DRAG FACE .......................................................................................................... 66
  7.14. CONNECT SPACES ............................................................................................... 67
  7.15. EDIT ATTRIBUTES ............................................................................................... 68
  7.16. EDIT GLAZING, DOORS AND LOUVRES ............................................................. 69
  7.17. EDIT OPENING SIZE AND SHAPE ....................................................................... 71
  7.18. EDIT ELEMENT HEIGHTS .................................................................................... 72
  7.19. CREATE ROOF ..................................................................................................... 73
  7.20. ASSIGN TEXTURES ............................................................................................. 74
  7.21. REFRESH DISPLAY .............................................................................................. 74
  7.22. DELETE ................................................................................................................ 74
  7.23. DIVIDE SPACE .................................................................................................... 75
  7.24. SEPARATE COMPOSITE SPACE ........................................................................ 78
  7.25. EDIT VERTICES ................................................................................................... 79
8. VIEW FUNCTIONS ........................................................................................................ 80
  8.1. FIT VIEW ................................................................................................................ 80
  8.2. ZOOM WINDOW .................................................................................................... 81
  8.3. ZOOM IN ............................................................................................................... 82
  8.4. ZOOM OUT ............................................................................................................ 82
  8.5. PAN ........................................................................................................................ 82
  8.6. ZOOM PREVIOUS ................................................................................................ 82
  8.7. ZOOM NEXT ......................................................................................................... 82
  8.8. VIEW SELECTION ............................................................................................... 83
  8.9. SET AXONOMETRIC ROTATION .......................................................................... 83
  8.10. ROTATE VIEW .................................................................................................... 84
  8.11. MODE SELECTION .............................................................................................. 86
  8.12. STOREY LEVEL SELECTION ............................................................................... 86
  8.13. MOVE UP ONE LEVEL ....................................................................................... 86
  8.14. MOVE DOWN ONE LEVEL ................................................................................. 86
  8.15. OBJECT LIST ...................................................................................................... 87
  8.16. NORTH INDICATOR ............................................................................................ 88
  8.17. CO-ORDINATE LOCATION ............................................................................... 88
9. MODELIT MENU FUNCTIONS ..................................................................................... 89
  9.1. ATTACH DXF FILE ............................................................................................... 89
9.2. DETACH DXF FILE ........................................................................................................... 90
9.3. ACTIVE DXF LAYERS ..................................................................................................... 90
9.4. MOVE DXF FILE ........................................................................................................... 90
9.5. ATTACH OBSTRUCTIONS FILE .................................................................................... 90
9.6. DETACH OBSTRUCTIONS FILE ................................................................................... 90
9.7. IMPORT GEM FILE ....................................................................................................... 91
9.8. EXPORT GEM FILE ....................................................................................................... 92
9.9. IMPORT gbXML FILE .................................................................................................... 93
9.10. EXPORT STL FILE ........................................................................................................ 96
9.11. EXPORT DXF FILE ....................................................................................................... 96
9.12. ATTACH/DETACH BITMAP FILE ................................................................................ 96
9.13. MERGE MODEL DATA ................................................................................................. 97

10. SETTINGS MENU / MODEL .......................................................................................... 99

10.1. ADJACENCY SEPARATION DISTANCE ......................................................................... 99
10.2. VERTICAL-HORIZONTAL ELEMENT TRANSITION ANGLE ........................................... 99
10.3. REBUILD MODEL ADJACENCIES ................................................................................ 99
10.4. MODEL REPORT OPTIONS ......................................................................................... 100
10.5. VISIBILITY .................................................................................................................. 100
10.6. ROOM TYPES/OBSTRUCTIONS .................................................................................... 100

11. CONSTRUCTDXF .......................................................................................................... 101

11.1. WHAT IS CONSTRUCTDXF? ....................................................................................... 101
11.2. HOW CONSTRUCTDXF WORKS ............................................................................... 102
11.3. PREPARATION OF THE DXF DRAWING .................................................................... 102
11.4. SETTING UP ROOM TEMPLATES USING THE BTM .................................................... 107
11.5. STARTING CONSTRUCTDXF ...................................................................................... 108
11.6. SETTINGS .................................................................................................................. 109
11.7. EXTRACT .................................................................................................................... 116
11.8. MODIFYING THE 3D MODEL .................................................................................... 117
11.9. A QUICK GUIDE TO GENERATING A CONSTRUCTDXF MODEL ............................... 118

12. GEOMETRY NAVIGATORS ............................................................................................. 119

12.1. SETTINGS .................................................................................................................. 119
12.2. DRAW SPACES .......................................................................................................... 119
12.3. DRAW FROM DXF ....................................................................................................... 119
12.4. IMPORT BIM .............................................................................................................. 119
12.5. DRAW FEATURES & SHADES .................................................................................... 119
12.6. ROOM GROUPING (NAME/TYP£) .............................................................................. 119
12.7. TOOLS ...................................................................................................................... 120

13. KEY-INS ....................................................................................................................... 122
1. Introduction

1.1. What is ModelIT?
ModelIT is the model building component of the <Virtual Environment>. ModelIT allows the user to create the 3D models required by other components within the <Virtual Environment>. ModelIT is designed to enable appropriate levels of complexity to be incorporated within a model across the entire design spectrum.

At the sketch design or feasibility stage, basic models may be generated from scratch using a variety of simple modelling tools, in order to conduct preliminary performance appraisals or comparative studies.

Similarly, at the other end of the design process, fully worked DXF files may be attached to ModelIT and using the tools provided, three-dimensional building spaces may be generated rapidly by tracing over the DXF outlines. Moreover, in the case of the optional Construct/DXF module, a complete model including doors and windows may be generated from a DXF file entirely automatically.

1.2. Using This Guide
This guide introduces the terminology used to describe ModelIT and includes a description of all the ModelIT features i.e. toolbars, pull-down menu items and pop-up windows.
2. Fundamentals

2.1. Projects

When the <Virtual Environment> is started up a blank project is initialised and the “ModelIT” workspace is activated. For more details of creating/opening/saving projects please refer to general help topics Section 3, “File” menu for more information.

The Model space window default background colour is white, with the grid in black. This can be altered to the user’s choice. Please refer to general help topics, Section 5.7.2 System colours for more information.

2.2. The ModelIT Workspace

The sub-window you are now looking at is the ModelIT workspace, with the Model Browser on the left.

The workspace is divided as follows:

2.2.1. Pull-down Menu Bar

This provides an alternative method of accessing the functions available on the
various toolbars.

2.2.2. Model Toolbar

This contains functions mainly associated with creating models.

2.2.3. Edit Toolbar

This contains functions mainly associated with editing models.

2.3. Model Browser

2.3.1. Viewport

Hovering with the mouse pointer over rooms or surfaces will highlight the one in focus. The highlight colour can be changed or this function can be turned off in the Tools>Preference dialog. (Please refer to section 5.7.1 general help topics for more information)
The viewport window can also be used to show two or four viewports:

2.3.2. View Toolbar

This contains functions mainly associated with viewing models.

2.4. Object Bar

This contains information associated with the current object(s):

- Zone number (in order of the space list)
- Room name
- Room ID
- Volume (total volume for a multiple selection)
- Floor area (total area for a multiple selection)
External wall area
External opening area
Colour
Layer

When more than one zone is selected the sum of the quantities is shown (e.g. room groups).

The “Object Bar” and toolbars can be switched on/off and the viewport options selected from the “View” pull-down menu for more information see general help topics user guide-section 4-View options)

### 2.5. Status Bar

This displays the current location, coordinates in the active model space and the alert notification.
2.6. Levels of Decomposition

In order to simplify modelling processes, ModellIT uses a hierarchical approach referred to as "levels of decomposition", whereby a model is considered to comprise a series of spaces, and a space comprises a series of surfaces, resulting in three levels of decomposition:

- Model
- Space
- Surface

At each level there are various options available to the user, there is detailed information on modifying the model later in this guide.

When you start ModellIT or open a new project, the initial level of decomposition is always Model. The "Mode Selection" field shows which level is active (see section 6.11 for more details). At this level of decomposition you can create or modify room data.

In order to move down a level of decomposition from Model, you must first select a single space. You will notice that the "Move Down One Level" button on the View toolbar is now activated. When this is activated the display will change to fit the selected space into the view window, and the "Mode Selection" field changes from "Model" to "Surface". You will notice that the "Mode selection" drop-down list in the View toolbar is now active, allowing you to switch modes. At the Space level of decomposition, there are two modes, "Surface" and "Edit".

"Surface" mode is used to review or modify surface data. "Edit" mode is used to divide single spaces into multiple composite spaces, to separate composite spaces into individual spaces, and to edit the vertex positions of spaces (see section 6.11 for more details).

In "Surface" mode you can now move down another level of decomposition to the Surface level by using the "Move Down One Level" button again. The "Mode Selection" field changes from "Surface" to "Opening". At this level there are two modes, "Opening" and "Adjacency".

"Opening" mode is used for creating or modifying windows and doors. "Adjacency" mode is used to review or modify adjacency data, where an adjacency is an area of a surface which is either adjacent to the exterior or another space.

To move up a level of decomposition use the "Move Up One Level" tool button.

Note if you have more than one viewport open, and the level of decomposition in one of the viewports is below Model level, you will not be able to select any other space in any of the other viewport until the level of decomposition is restored to Model in all viewports.

2.7. Toolbars

The toolbars save you time by enabling you to select some of the most frequently used commands, without having to select them from the pull-down menus at the top of the ModellIT window. Each toolbar is described below from left to right.
2.7.1. Model Toolbar

- Colour/Colour table
- Layer/Layer properties
- Grid Settings
- Grid origin
- Locks
- Draw Arc
- Draw Extruded Shape
- Draw Prism
- Draw Pyramid
- Draw Sphere
- Draw Hemisphere
- Draw Cylinder
- Draw Partition
- Construction Lines
- Remove All Construction Lines
- Add Door
- Add Window
- Add Hole Between Adjacent Zones
- Import gbXML File
- Import GEM File
- Construct DXF
- Create Slice
- Model Viewer
- APIlocate
2.7.2. Edit Toolbar

To activate the edit toolbar first select a volume. Refer to section 7 for more information on the edit commands.

Key-in Field

- Undo
- Redo
- Select Object
- Measure length
- Measure angle
- Query Coordinates
- Copy Selection Set (Click and hold left mouse button to utilise)
- Move Selection Set (Click and hold left mouse button to utilise)
- Scale Selection Set
- Rotate Selection Set
- Mirror Selection Set (Click and hold left mouse button to utilise)
- Drag Face (works best in axonometric view – when you hover over a face to drag it will highlight in yellow)
- Resize Opening
  
  This option activates in edit mode when at a surface level only. When at surface level, select the opening to edit. Then select the vertices of the opening to edit by dragging a window. Click and hold the right mouse button and drag it in the direction to utilise.

Connect Spaces
- Edit Attributes
- Edit Glazing
- Edit Element Heights
- Create Roof
- Assign Texture
- Refresh Display
- Delete
2.7.3. Generic View Toolbar

For more information on this toolbar please refer to General help topics user guide section 2.3.4.

2.8. Object Bar

At the Model level the object bar displays details of the first object that was selected:

<table>
<thead>
<tr>
<th>Room Name</th>
<th>Room ID</th>
<th>Volume (ft³)</th>
<th>Floor Area (ft²)</th>
<th>Colour</th>
<th>Layer</th>
</tr>
</thead>
<tbody>
<tr>
<td>zone A</td>
<td>ZV_0000</td>
<td>103.67</td>
<td>25.68</td>
<td>Colour 01</td>
<td>Layer 01</td>
</tr>
</tbody>
</table>

The "Room Name", "Colour" and "Layer" can all be edited by double clicking on the field. The other fields are read-only.

At the Surface level the object bar displays details of the selected surface:

<table>
<thead>
<tr>
<th>Surface Area (ft²)</th>
<th>Surface Orientation (°)</th>
<th>Surface Tilt (°)</th>
</tr>
</thead>
<tbody>
<tr>
<td>9.00</td>
<td>90.00</td>
<td>30.00</td>
</tr>
</tbody>
</table>

At the Opening level the object bar displays details of the selected opening:

<table>
<thead>
<tr>
<th>Opening Type</th>
<th>Opening Area (ft²)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Window</td>
<td>1.51</td>
</tr>
</tbody>
</table>

At the Adjacency level the object bar displays adjacency details of the selected surface:

<table>
<thead>
<tr>
<th>Adjacency Area (ft²)</th>
<th>Adjacency Room Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>29.00</td>
<td>EXTERIOR</td>
</tr>
</tbody>
</table>
3. Model Browser Functions

This section looks at functions associated with the Model Browser.

3.1. Room Groups

The room groups mechanism allows the user to specify a grouping scheme and then room groups within this grouping scheme. For example, a grouping scheme called ‘Floors’ would then have room groups called ‘Ground Floor’, ‘First Floor’, etc. The room groups consist of zones from the space list. A zone can be placed within more than 1 room group and more than 1 grouping scheme. The room group’s controls are contained within the following display at the top of the space list/model browser.
3.1.1. Edit Room Groups

This icon allows the user to bring up the Edit Room Groups window. The user can then create their grouping schemes and the room groups within these.

3.1.2. Add Selected Rooms to Room Groups

Selecting this icon brings up the Assign Room Group window. The user can then select the desired Room Group that the previously selected rooms will be added to. The user must be in the desired grouping scheme in order to bring up the required room groups in the list.
3.1.3. Group Scheme Drop-down List

This displays the Group Schemes currently available. Selecting a group scheme will switch the space list to display the room groups within this scheme.
3.2. **Space List**

The space list is where all the rooms or room groups are displayed dependent on which grouping scheme the user has currently selected. The space list can be used to select a room or room group for the user’s purpose.

![Space List Diagram]

Here the space list is displaying all room groups within the ‘Floors’ grouping scheme:

![Space List with Floor Groups]

3.2.1. **Space list context menu**

By right clicking on a room, selection of rooms or room group the space list context menu will be displayed.

![Space List Context Menu]

3.2.1.1. Properties
This allows the user to rename a zone and also allows them to alter the room type to either:

- Room
- Adjacent Building
- Topographical Shade
- Local Shade

3.2.1.2. Sort
There are 5 options within the sort list:

I. Alphabetically
   Sorts rooms based on their alphabetical order.

II. By Room Group
   The rooms will be sorted by the grouping scheme which is first in the grouping schemes order; then by the second grouping scheme within each occurrence of the first grouping scheme; etc. The following tree breakdown display explains this:

   Grouping Scheme 1
   - Group 0
     - Grouping Scheme 2
       - Group 0
         - Grouping Scheme 3
           - Group 0
   - Group 1
     - Grouping Scheme 2
       - Group 0
         - Grouping Scheme 3
           - Group 0
   - Group 2
     - Grouping Scheme 2
       - Group 0
         - Grouping Scheme 3
           - Group 0

III. By Layer
   Sorts rooms based on the layer number they are positioned on.
IV. Advanced

Allows the user to select one or more fields by which to sort rooms. The rooms will be sorted by the first field; then by the second field within each occurrence of the first field; etc. The order can be ascending or descending. Included in the sort field options are all grouping schemes along with:
- Room name
- Colour
- Layer
- Heating Zone
- Cooling Zone

3.2.1.3. Select

Allows the user to select room groups across grouping schemes.

Available options:
- All rooms in all chosen groups
- Only rooms common to the chosen groups
3.2.1.4. Go To Room

This allows a room to be selected and highlighted by entering its reference ID.

Some messages refer to rooms by their ID so this feature is very handy when identifying spaces.

3.2.1.5. Display Room ID

This option toggles the display of room names or IDs in the browser.

3.2.1.6. Rename

This feature allows a user to identify a string pattern within the model rooms and either replace with another string or add text before or after it. It also has the ability to add room numbering.

3.2.1.7. Delete

Allows user to delete room/rooms or rooms within a room group.
4. Model Functions

4.1. Colour

ModelIT uses colours for highlighting, indicating inactive layers, displaying DXF elements and distinguishing one layer from another. The Colour box displays the active object colour and colour number. Any new object placed will be assigned this object colour.

Note that you can choose to display objects in the model either by their object colour or by their layer colour, by selecting "Colour" from the View pull-down menu. The default is to display objects by their layer colour.

4.2. Layers

This option allows parts of the model to be made inactive. When parts of the model are made inactive (switched OFF) they will not be included in the thermal simulations. Switching parts of the model OFF will reduce simulation time and will also enable efficient checking and trouble-shooting of models. For thermal zones (three-dimensional) spaces in the model on layers that are turned OFF the icons for these zones will be grey in the Model Browser tree. The geometry for these zones will be grey and no longer selectable within the model view. These spaces will not be present in the Model Viewer, however, any color and texture used to indicate the type of construction on an interior surface—i.e., one that is adjacent to a space that is on an inactive layer—will remain unchanged.

Solar gain will not be present either on or within any space that is on an inactive layer. Solar gain will not be present on ceilings, floors, walls, fenestration, etc. that form an adjacency to a space that is on an inactive layer. As long as the geometry for the spaces that remain active has not changed, SunCast calculations for Apache do not need to be re-run. The physical properties of constructions for walls, floors, ceilings, etc., shared by active and inactive zones will be unchanged.

For more information on the part of the model that has been rendered inactive refer to ApacheSim Calculation Methods section 3.5 Boundary Conditions.
4.3. **Grid Settings**

**Toolbar button:** ; **Menu item:** “Settings” ⇒ “Grid”.

The grid is used as an aid in model creation (provided the appropriate Lock is active). The Grid Settings dialogue box may be left open throughout the drawing process or may be closed and re-opened at any time. The user can set the drawing grid spacing in the X and Y directions, determined by the values entered in the X and Y Spacing fields.

Note that if the spacing is too small for the view in the ModelIT window (i.e. if the grid mesh is too fine), the grid will not be displayed. You may display/hide the grid by clicking in the Display box. The Grid and Axis locks will function even if the grid is not displayed.

4.4. **Grid alignment**

**Toolbar button:** ; **Menu item:** “Settings” ⇒ “Grid alignment”.

It is always preferable to work orthogonally and in alignment with the grid. This option allows the grid to be aligned with the model.

To use this feature switch on the end-point lock and zoom the view in to an area of the model you wish to lock on to. Click the toolbar button and then click once on the vertex point identified we wish to act as anchor. The grid will immediately shift to align with this point.

Used in conjunction with the Rotate View a user can always obtain an orthogonal grid to align with.
4.5. Locks

("Settings" ⇒ “Locks")

Pops-up the following window:

Locks are used to force points placed during drawing operations to fall precisely at positions determined by the lock. The Locks dialogue box may be left open throughout the drawing process or may be closed and re-opened at any time.

4.5.1. Grid

Checking this box causes the origin of a line or other element to be fixed at the nearest grid line intersection (See Endpoint below) to a point on the view determined by a mouse click.

4.5.2. Axis

Checking this box enables a line to be drawn orthogonally with regard to the grid. The position of the mouse pointer with regard to the origin of the line determines which grid line the drawn line follows.

4.5.3. Endpoint

Selecting this option enables you to snap on the nearest end point of an existing line.
If the Grid is locked on, the new line/element will snap to the nearest grid unless the Endpoint is nearer.

4.5.4. **Midpoint**

Selecting this option enables you to snap on the nearest middle point of an existing line. If the Grid is locked on, the new line/element will snap to the nearest grid unless the Midpoint is nearer.

4.5.5. **Nearest Point**

Selecting this option enables you to snap to a point anywhere along a surface.

4.5.6. **Perpendicular**

When using draw extruded shape, the line being drawn will display light blue if it is 90 degrees to the previously drawn line.

4.5.7. **Parallel**

Selecting this option enables you to draw a surface parallel to that of another zone. Using the draw extruded shape, move the cursor near the surface which you want to draw parallel to and press shift. Then when you go to draw your surface you will see the line is displayed yellow indicating it is parallel.

4.5.8. **Drawing Guides**

Selecting this option enables you to draw a line to a snap point in line with another surface either on the X or Y axis. Drawing guides are not designed to be used in conjunction with grid snap.

4.5.9. **Angular Lock**

Selecting this option enables you to draw a line with draw extruded shape with an angular setting. The user finds their desired angle and can then type in the length of the surface and press <enter>. The surface has then been drawn and the user can move on to the next point.

4.5.10. **Drag Face Lock**

This lock option allows you to control the distance that you adjust a volume size by when you are using the Drag face tool.

4.5.11. **Face Snapping**

This lock option allows you to drag the face of a room that you are editing to match up with another existing room face without having to type in any dimension information.
4.6. Draw Arc

("Draw" ⇒ “Arc")

If you want to incorporate an arc within the perimeter of an extruded shape or pyramid base, use this option. This button becomes active after you have placed the first point of an extruded shape or pyramid perimeter. It allows you to define a curve that originates from the last vertex you have placed. The “Arc Settings” dialogue box opens -

The "Sweep" setting is used to define the sweep angle (in degrees) of the arc, a positive value for a clockwise sweep and negative for an anti-clockwise sweep. The "Segments" setting is used to define the number of straight-line segments used to create the arc. The accuracy of the arc may be improved by increasing the number of segments. However, the greater the number of segments, the longer the processing times will be. When you move the cursor back into the model window, you will see a small circle attached to the cursor. This circle is used to define the centre of the arc. When the arc is placed, you may place another arc, or press the right mouse button to continue drawing the extruded shape or ‘unwind’ the arc segment by segment by repeatedly pressing the right mouse button.
4.7. **Draw Extruded Shape**

("Draw" ⇒ “Extruded Shape")

Pops-up the following window:

Selecting this command allows you to create an extruded shape as a series of straight-line segments. Select each point of the shape in turn, in either clockwise or anti-clockwise order. To close the shape, click on the “Close Shape” button which is active while you are drawing the shape. If you make a mistake and need to undo a point, click on the right mouse button. The current lock settings will apply and key-in values can also be used. The extruded shape will be created with the defined Plane (m) and Depth (m) values as currently set in the Shape Settings dialogue box. An extruded shape can be created along any axis.

Note that you cannot cross a segment with another segment and you cannot place a perimeter point on an existing perimeter point unless it is the first point in which case this will close the shape.

The relevant key-ins for the extruded shape are:

\[ x=<x, y>\]
\[ dx=<dx, dy>\]
\[ p=<length, angle>.\]

4.8. **Draw Prism**

("Draw" ⇒ “Prism")

Pops-up the following window:
Selecting this command allows you to create a prism shape. Select the point where one corner of the prism is to be located, then select the point that is at the opposite corner of the prism. A new prism will then be created with the defined Plane (m) and Depth (m) values as currently set in the Shape Settings dialogue box. A prism can be created along any axis.

The relevant key-ins for the prism are:

\[ x = \langle x, y \rangle \]
\[ dx = \langle dx, dy \rangle \]
\[ p = \langle \text{length, angle} \rangle \].
4.9. Draw Pyramid

("Draw" ⇒ “Pyramid")

Pyramids are created in a very similar way to extruded shapes except that after completing the perimeter, you will enter a point to define the apex of the pyramid.

Pops-up the following window:

Selecting this command allows you to create a pyramid shape. To create pyramids, you must first define the shape of the base of the pyramid and then position the top of the pyramid. To define the pyramid base, select each point on the perimeter of the base in turn, in either clockwise or anti-clockwise order. To close the shape, click on the "Close Shape" button on the Shape Settings dialogue box which is active while you are drawing the shape. Next, select the position of the top of the pyramid. A new pyramid will be created with the base at the defined Plane (m) value as currently set, and the top point at the Plane + Depth (m) values as currently set. A pyramid can be created along any axis.

The relevant key-ins for the pyramid are:

\[
\begin{align*}
x &= <x, \ y> \\
\text{dx} &= <\text{dx}, \ \text{dy}> \\
\text{p} &= <\text{length}, \ \text{angle}>.
\end{align*}
\]
4.10. Draw Sphere

(“Draw” ⇒ “Sphere”)

Pops-up the following window:

Selecting this command allows you to create a spherical shape. To create a sphere, first select the centre of the sphere and then select a point which defines the radius of the sphere. A new sphere will be created with its centre at the defined Plane (m) level that is currently set in the Shape Settings dialogue box which is active while you are drawing the shape. The number of chord segments which make up the sphere is defined in the Shape Settings dialogue box. A sphere can be created along any axis.

The relevant key-ins for the sphere are:

\( x = \langle x, y \rangle \)
\( dx = \langle dx, dy \rangle \)
\( p = \langle \text{length, angle} \rangle \).
4.11. Draw Hemisphere

("Draw" ⇒ “Hemisphere”)

Hemispheres are created in exactly the same way as spheres.

Pops-up the following window:

Selecting this command allows you to create a hemispherical shape. To create a hemisphere, first select the centre of the hemisphere and then select a point which defines the radius of the hemisphere. A new hemisphere will be created with its base at the defined Plane (m) level that is currently set in the Shape Settings dialogue box which is active while you are drawing the shape. The number of chord segments which make up the hemisphere is defined in the Shape Settings dialogue box. A hemisphere can be created along any axis.

The relevant key-ins for the hemisphere are:

\[ x = <x, y> \]
\[ dx = <dx, dy> \]
\[ p = <\text{length, angle}>. \]
4.12. Draw Cylinder

("Draw” ⇒ “Cylinder")

Cylinders are created in a similar way to spheres and hemispheres.

Pops-up the following window:

Selecting this command allows you to create a cylindrical shape. To create a cylinder, first select the centre of the cylinder and then select a point that defines the radius of the cylinder. A new object will be created with the defined Plane (m) and Height/Depth (m) at the values currently set in the Shape Settings dialogue box which is active while you are drawing the shape. The number of chord segments which make up the cylinder is defined in the Shape Settings dialogue box. A cylinder can be created along any axis.

The relevant key-ins for the cylinder are:

\[ x = \langle x, y \rangle \]
\[ dx = \langle dx, dy \rangle \]
\[ p = \langle \text{length, angle} \rangle. \]
4.13. Draw Partition

(“Draw” ⇒ “Construction Line”)
Draw partitions of any shape into existing zones to generate sub zones or separate zones. The Partitioning dialog gives various options for representation of the new space in the model.

(“Draw” ⇒ “Construction Line”)

Selecting this command allows you to draw a construction line which can be used to trace along and/or snap to a point. Construction lines follow the same process of drawing as extruded shape except the user does not have to return the start point as this is not a space.

4.15. Remove All Construction Lines

(“Edit” ⇒ “Remove All Construction Lines”)

This command only becomes active when a construction line has been drawn.
4.16. *Add Door*

("Edit" ⇒ “Add Opening” ⇒ “Door”)

Doors can be placed at any level of decomposition.

At model level when Add Door is selected the Add Opening dialog pops up:

This has pre-built openings that can be used to place any type of opening on any surface by entering Base Height, Width and Height then selecting the location on the surface where the opening is desired.

These openings are based on components within the CompLib component Modeller. Any new or existing component given the category Opening can be used as an opening in ModellIT.

When the level of decomposition is at the Surface level there are 3 modes available, “Rectangular”, “Polygonal” or “100%”.

The default setting is to place rectangular doors. Place a door by entering a data point for one corner of the door and then drag a box to the diagonally opposite corner of the door. However, you can also place polygonal shaped doors by clicking on the small arrow button next to the “Add Door” button and selecting the “Polygonal” option. Complete the door by pressing the ‘C’ key on your keyboard. This command remains active allowing you to add multiple doors onto the same surface. For 100%, select the 100% opening option and click on the surface.

Note at the Surface level of decomposition, you are always looking from the inside of a space outwards.
Select the space at Model level and move down to the Space level. Select the surface to which you want to add a door and move down to the Surface level.

Key-In: In "Rectangular" mode: \(dx=<dx, dy>\) to select first and/or second corner (relative to the bottom left corner of the surface). In "Polygonal" mode: \(dx=<dx, dy>\) after first co-ordinate has been selected manually.
4.17. Add Window

(“Edit” ⇒ “Add Opening” ⇒ “Window”)

This option operates identically to the "Add Door" option (see section 4.15).

Windows can be placed at any level of decomposition.

At model level when Add Window is selected the Add Opening dialog pops up (see section 4.15).

When the level of decomposition is at the Surface level there are 3 modes available, “Rectangular”, “Polygonal” or “100%” (see section 4.15).

The default setting is to place rectangular windows. Place a window by entering a data point for one corner of the window and then drag a box to the diagonally opposite corner of the window. However, you can also place polygonal shaped windows by clicking on the small arrow button next to the "Add Window" tool button and selecting the "Polygonal" option. Complete the window by pressing the ‘C’ key on your keyboard.

Key-In: As for "Add Door" see section 4.15.
4.18. Add Hole

(“Edit” ⇒ “Add Opening” ⇒ “Hole”)

This option operates identically to the "Add Door" option (see section 4.15).

Holes can be placed at any level of decomposition.

At model level when Add Hole is selected the Add Opening dialog pops up (see section 4.15).

When the level of decomposition is at the Surface level there are 3 modes available, “Rectangular”, “Polygonal” or “100%” (see section 4.15).

This has the effect of retaining two separate spaces, but there is a hole (sometimes referred to as a superfices) in the connecting partition.

Key-In: As for "Add Door" see section 4.15.
4.19. *Import gbXML File*

(“File” ⇒ “Import gbXML File”)

See Section 7.8 for details.

4.20. *Import GEM File*

(“File” ⇒ “Import GEM File”)

See Section 7.6 for details.

4.21. *Construct DXF*

See the Construct DXF User Guide for details.
4.22. Create Slice

This option allows a user to create a 2D dxf file by a slice through a selection of rooms. The slice can be created in PLAN, FRONT or RIGHT views.

The cutting plane is defined using the slider which operates from the minimum active level to the maximum.
The user can flood fill the areas (takes object colour) and add room names.
For best results use inner volumes.
The image can be copied to clipboard

The following window indicates the display.

A cutting plane is selected and ‘Create Slice’ selected. The user will then be prompted to save the dxf file.
4.23. Scale Selected Openings

4.23.1. Anchor point
This is the point from where the opening(s) will be expanded or shunk from. This is relative to the inner-surface of the room containing the opening(s).

4.23.2. Scaling options
We can chose to expand or shrink the opening(s) by a percentage of the original dimensions or by an absolute value.

4.23.2.1. Percentage
Scale the opening as a percentage of its current size.

4.23.2.2. Absolute
Scale the opening by a set distance in X and Y planes.
4.23.3. Scale Selected Openings Example

Consider the following 5mx5mx5m box zone with a single 1m² window in the centre of one surface.

To expand the window width by 100% and height 50% from the centre point we would use the following settings:

To increase the size by the same amount but keep the original sill height we would use these settings:
4.24. Extrude along a path

It is possible to create a SECTION from any plane drawn in ModelIT and use this SECTION to define a shape along a PATH drawn in PLAN view.

A. Select a space and move down into it
B. Select a plane (here we have selected the floor)
C. KEYIN: “SECTION”

D. Move back up to model level
E. Ensure you are in PLAN view
F. KEYIN: “PATH”

G. Select the SECTION to use
H. Draw the PATH you wish to follow
I. When complete click “Create Shape” button
J. Shape is created following defined PATH
4.25. Opening Stamp tool

It is possible to copy any selected group of openings and paste anywhere in the model.

For example consider the following arrangement that we wish to copy all over our model.

A. Select Openings
B. KEYIN: “STAMP”
C. Move to new surface
D. Select Stamp from openings drop-down
E. Place openings
F. Repeat C – D as many times as necessary
4.26. Draw Simple Openings in Plan View

Menu item: “Draw” ⇒ “Openings” ⇒ “Place In Plan”

Windows and doors can be placed in PLAN simply by clicking a start and end point (for example tracing a DXF) with a given base plane and height.

![Place opening](image)

Tracing over a DXF file

Notes:
- Rooms need not be selected – the tool will identify the current room as you draw.
- Windows and Doors have different default plane and height settings (e.g. doors will default to 0m plane and Windows will default to 1m plane).
- Once edited the values for plane and height are retained.
4.27. Create Storeys

Menu item: “Selection” ⇒ “Create storeys”

Feature enabled when a single zone is selected at Model level.

![Storey Extruder/Creator]

4.27.1. Options

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Number of storeys</td>
<td>Total number of floors to create (including original space)</td>
</tr>
<tr>
<td>Storey height</td>
<td>Height of each occupied storey</td>
</tr>
<tr>
<td>Add floor voids?</td>
<td>Create floor voids for each space (original space will have void below its existing ground plane).</td>
</tr>
<tr>
<td>- Height</td>
<td>Height of void created</td>
</tr>
<tr>
<td>- Reference</td>
<td>Text to append original zone name with</td>
</tr>
<tr>
<td>Add ceiling voids?</td>
<td>Create ceiling voids between spaces</td>
</tr>
<tr>
<td>- Height</td>
<td>Height of void created</td>
</tr>
<tr>
<td>- Reference</td>
<td>Text to append original zone name with</td>
</tr>
</tbody>
</table>

4.27.2. Notes

- Feature enabled when a single zone is selected at Model level.
- Works on spaces with flat roofs only – other shapes may lead to inconsistent and unexpected results.
- There should be no spaces above the selected zone otherwise there may be an intersection danger (it will be flagged in and alert on creation).
- Image is for indication only and will not be to scale or represent shape of actual room.
- Glazing/Openings retained (should the storey height not be reset to a figure less than the glazing height).
- Openings are not placed on void spaces.
4.27.3. How to use the Storey creator

Consider that we want to create a 18 storey tower block from the following large floor plate zone with existing glazing.

In order to do this we would:

**Step 1** - Select the zone

**Step 2** - Start the Storey creator tool

**Step 3** - Set the number of storeys to be 18; set the storey height to be the new required height (if desired – by default this will be the existing room’s height); Add floor voids and/or ceiling voids if required.

**Step 4** - Click OK button to create the storeys.
4.28. Add voids and/or stratify

Menu item: “Selection” ⇒ “Add voids and/or stratify”

It is possible to split existing zones vertically to add in void spaces and create basic stratified spaces using the Zone splitter tool.

4.28.1. Options

<table>
<thead>
<tr>
<th>Section</th>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Occupied space</td>
<td>Height</td>
<td>The floor-ceiling height of the occupied space created</td>
</tr>
<tr>
<td></td>
<td>Add. Text</td>
<td>Additional text to place in brackets after the original room name</td>
</tr>
<tr>
<td>Stratified zones</td>
<td>Create</td>
<td>Split original space into zones above occupied area?</td>
</tr>
<tr>
<td></td>
<td>Number of zones</td>
<td>Number of equally sized spaces to create</td>
</tr>
<tr>
<td></td>
<td>Retain partitions?</td>
<td>Keep internal ceiling partition in between zones?</td>
</tr>
<tr>
<td>Voids</td>
<td>Ceiling void</td>
<td>Add a ceiling void?</td>
</tr>
<tr>
<td></td>
<td>- Height</td>
<td>Height of ceiling void to create</td>
</tr>
<tr>
<td></td>
<td>- Name</td>
<td>Append original room name with this text</td>
</tr>
<tr>
<td></td>
<td>Floor void</td>
<td>Add a floor void</td>
</tr>
<tr>
<td></td>
<td>- Height</td>
<td>Height of floor void to create</td>
</tr>
<tr>
<td></td>
<td>- Name</td>
<td>Append original room name with this text</td>
</tr>
</tbody>
</table>

4.28.2. Notes

- Feature enabled when a single zone is selected at Model level.
- Image is for indication only and will not be to scale or represent shape of actual room
4.28.3. **How to use the Zone splitter**

Consider the following block zone on which we have placed a lot of glazing so that we can see what is happening inside.

![Zone splitter image](image)

We can use the Zone splitter tool to divide this space vertically so that we have a floor void under an occupied area which then has some stratification spaces above topped off with a ceiling void.

**Step 1** – Select the room that we wish to split

**Step 2** – Open the Zone splitter using the menu item: Selection>Add voids and/or stratify

**Step 3** – Set the occupied height and number spaces we want to create above it then choose to add on floor and ceiling voids.

![Zone splitter dialog](image)

**Step 4** – Click OK button to split the zone
4.28.4. Creating building storeys with the splitter

As well as creating simple stratified spaces (for MacroFlo for example) with the Zone splitter we can also create building stories.

The following image shows the previous example split in the same manner but this time with the partitions between spaces retained.

In this manner we could, for example, import block geometry (from OSM?) and quickly split the building geometry into storeys then add glazing...
4.29. Model Consistency Report

The model consistency report allows the user to run a quick quality check on the geometry they have created and the basic data that has been assigned within the model.

There are two sections to the report:

i) Section A – Consistency checks
This section details any errors within the geometry that require addressing before moving on to any thermal simulations. The main issues that have to be addressed are **intersections, non-planar surfaces** and **external holes** with the latter two issues being of uppermost importance. If your model has issues with non-planar surfaces or external holes then you must address these to avoid simulation errors.

ii) Section B – Data assignment
This section lists room data and template assignments.

Each section has toggleable sub-sections which can be included or excluded in the model report:

4.29.1. Including or excluding a section in the report
Setting the check next to the .

The report generated has a header which has a hyperlink to each section:

<table>
<thead>
<tr>
<th>Section A - Consistency checks</th>
<th>Section B - Data assignment</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Zero-volume zones</strong></td>
<td><strong>Room data</strong></td>
</tr>
<tr>
<td><strong>Non-Planar surfaces</strong></td>
<td><strong>Template assignment by room</strong></td>
</tr>
<tr>
<td><strong>Intersecting spaces</strong></td>
<td><strong>Templates: General Thermal Lighting, MacroFL, Construction</strong></td>
</tr>
<tr>
<td><strong>External Holes</strong></td>
<td><strong>Room Surface breakdown</strong></td>
</tr>
<tr>
<td><strong>Unmatched adjacencies</strong></td>
<td><strong>Room grouping schemes (by room)</strong></td>
</tr>
<tr>
<td><strong>Surfaces with more than 10 openings</strong></td>
<td><strong>Room grouping schemes (by scheme)</strong></td>
</tr>
<tr>
<td><strong>Small Area surfaces (≤0.001 m²)</strong></td>
<td><strong>Components</strong></td>
</tr>
<tr>
<td><strong>Small Areas Adjacencies (≤0.001 m²)</strong></td>
<td><strong>Texture assignment</strong></td>
</tr>
</tbody>
</table>
4.29.2. Report format

The report generated is of HTML format and should be opened automatically by whatever web browser application your system has associated with the html file extension (Internet Explorer, Chrome, Firefox, etc). The data is displayed in tabular format wherever possible and hyperlinks are used to navigate to different areas of the document.

### Room Data

A simple summary of every thermal room within the model.

<table>
<thead>
<tr>
<th>Index</th>
<th>Room</th>
<th>Type</th>
<th>Gross Area ($\text{ft}^2$)</th>
<th>Net Area ($\text{ft}^2$)</th>
<th>Gross Volume ($\text{ft}^3$)</th>
<th>Net Volume ($\text{ft}^3$)</th>
<th>Base Plane ($\text{ft}$)</th>
<th>Body Height ($\text{ft}$)</th>
<th>Whirl Area ($\text{ft}^2$)</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>1</td>
<td>1</td>
<td>1038</td>
<td>1038</td>
<td>31783</td>
<td>31783</td>
<td>0</td>
<td>10</td>
<td>3237</td>
</tr>
<tr>
<td>2</td>
<td>1</td>
<td>1</td>
<td>2580</td>
<td>2580</td>
<td>78080</td>
<td>78080</td>
<td>0</td>
<td>15</td>
<td>3237</td>
</tr>
<tr>
<td>3</td>
<td>1</td>
<td>1</td>
<td>280</td>
<td>280</td>
<td>4481</td>
<td>4481</td>
<td>0</td>
<td>15</td>
<td>1618</td>
</tr>
<tr>
<td>4</td>
<td>1</td>
<td>1</td>
<td>169</td>
<td>169</td>
<td>11201</td>
<td>11201</td>
<td>0</td>
<td>15</td>
<td>1262</td>
</tr>
<tr>
<td>5</td>
<td>1</td>
<td>1</td>
<td>169</td>
<td>169</td>
<td>11201</td>
<td>11201</td>
<td>0</td>
<td>15</td>
<td>1262</td>
</tr>
<tr>
<td>6</td>
<td>1</td>
<td>1</td>
<td>229</td>
<td>229</td>
<td>5297</td>
<td>5297</td>
<td>0</td>
<td>15</td>
<td>1164</td>
</tr>
<tr>
<td>7</td>
<td>1</td>
<td>1</td>
<td>194</td>
<td>194</td>
<td>2178</td>
<td>2178</td>
<td>0</td>
<td>15</td>
<td>906</td>
</tr>
<tr>
<td>8</td>
<td>1</td>
<td>1</td>
<td>1184</td>
<td>1184</td>
<td>10422</td>
<td>10422</td>
<td>0</td>
<td>15</td>
<td>2008</td>
</tr>
<tr>
<td>9</td>
<td>1</td>
<td>1</td>
<td>1184</td>
<td>1184</td>
<td>10422</td>
<td>10422</td>
<td>15</td>
<td>15</td>
<td>2008</td>
</tr>
<tr>
<td>10</td>
<td>1</td>
<td>1</td>
<td>1290</td>
<td>1290</td>
<td>21002</td>
<td>21002</td>
<td>30</td>
<td>23</td>
<td>2079</td>
</tr>
</tbody>
</table>

Clicking on a room name / ID will hyperlink to a detailed breakdown of the space.

If opened in a text editor the format may appear quite unclear:
4.29.3. **Room grouping schemes**

Each sub-section of Section A will have a room grouping scheme created containing two groups **OK & Problem** which will allow the user to more easily repair the errors. For example here we see in this test model that we have 8 intersecting rooms. We can select them instantly by clicking on the **Problem** room group.
4.30. Rename Rooms

Selected rooms can be renamed and have indexing applied using the Rename rooms dialog window. The function can be accessed in 3 ways:

1. Right-click context menu in model browser (displayed below)
2. Model Tools navigator
3. Key-In command (RENAME)

An index can be placed before or after the text string using the Add room numbers option and specifying the position in the Numbering options.
5. Model Viewer

Clicking one either of these two icons opens the following window:

5.1. Icons

The Pan, Orbit and Zoom functions are controlled by the mouse buttons.

The following icons are available:

- Print
- Copy image to clipboard
- Save: Saves as a .bmp file.
- Create avi: The user can orbit, zoom and pan in when making their own movie of the model.
- Camera Path (See P44 for more information)
X-Ray Effect
Wireframe display
Hidden Line Removal display
Shaded display
Open Display Settings Dialog
Textured display
Display ground plane.
Mousecam – Standard camera controls.
Flycam – Fly-through camera.
Walkcam – Walk-through camera.
Recover – Reverts views to default.
Goto Room
Toggle between dialog window and docked window

5.2. Mousecam controls

<table>
<thead>
<tr>
<th>Control</th>
<th>Action</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Left mouse button</td>
<td>Click and drag</td>
<td>Orbit</td>
</tr>
<tr>
<td>Right mouse button</td>
<td>Click and drag</td>
<td>Pan</td>
</tr>
<tr>
<td>Middle mouse button (wheel)</td>
<td>Click and drag</td>
<td>Pan</td>
</tr>
<tr>
<td>Middle mouse wheel</td>
<td>Scroll</td>
<td>Zoom</td>
</tr>
</tbody>
</table>

An alternative to scrolling with a middle mouse wheel is to hold the Ctrl button on your keyboard and click and drag the left mouse button to zoom in or out.

Flycam (and Walkcam) controls:

<table>
<thead>
<tr>
<th>Key</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>W</td>
<td>Move forward</td>
</tr>
<tr>
<td>S</td>
<td>Move backwards</td>
</tr>
<tr>
<td>A</td>
<td>Strafe / sidestep left</td>
</tr>
<tr>
<td>D</td>
<td>Strafe / sidestep right</td>
</tr>
<tr>
<td>E</td>
<td>Raise eye level</td>
</tr>
<tr>
<td>C</td>
<td>Lower eye level</td>
</tr>
</tbody>
</table>

Click and drag the left mouse button to look around in Walk-through and Fly-through modes
to control direction of motion (Walk-through movement will be restricted to be parallel to the ground plane).

To speed up scroll the middle mouse wheel forward, scrolling backwards will slow down. Alternatively, press Ctrl and left click drag forwards and backwards to control speed.

Recover will revert all views back to the original defaults when ModelViewer was opened.

The *Goto Room* feature takes the user directly into the room selected in the Model browser. Simply select the room and click on the *Goto Room* button and the view position will be changed to inside the room.

Display Controls Overlay:
In any view the controls can be displayed in the bottom right corner of the Model Viewer by pressing F2.

### 5.3. Display Settings

A sketch like style of displaying the model is now available. View settings can be adjusted with the *Display Settings* dialog. *Extension* shows architectural extension of lines, *end points* shows dotted end points and *jitter* shows sketchy rendering style.
Model viewer shows textures assigned to surfaces in ModelIT. Settings can be changed for improved rendering in the *User Preferences* dialog. Bump mapping – depth, specular mapping – shininess

By default, controls are displayed each time the Model Viewer is opened. This feature can be switched off in the Model Viewer Settings dialog (Tools > Preferences > Model Viewer Settings tab. For more information please refer to General help topics user guide section 5.7.3.).

### 5.4. Set Camera Path

This allows the user to record a camera path while moving around the building or even go inside by adding view positions and directions using the *Camera Path* dialog. These locations can be edited at any time and the camera path will be visualized in model viewer if the option *Show path* is active. An animation can be created based on the created camera path. (This option can be switched off for final recordings.)

Creating an AVI with the camera path tool

First open up the model viewer, select the Fly through first person camera and click on the
camera path tool. Next manoeuvre the camera to the position you would like the AVI to start at.

Now click the right hand Add> arrow to add your first camera position.

Next move your view to the next point where you would like your AVI to stop or change direction and click the Add> button again. Follow this same process to make your full camera path.

Once you have created your path you click the Build button to create the AVI.

You can then click play to view your AVI, use the Back and Forward to go through the AVI frame by frame or use the fader bar to manually scroll through.

If you are happy with the AVI on the first take then you can click the record button to make your AVI file. Once the software has recorded the camera path the user will be given the option of where to save the AVI. Once a suitable location has been selected the Make the video button can be clicked.

Other Options such as the Show path and frames per second can be alter. The camera path can also be saved to be opened and used again at a later date.

When the save option is used a new modelviewer folder is created within the project folder.
Once you have created your path you have a few options that allow you to edit your camera path.

The Prev and Next buttons can be used to jump to the main camera positions and using the remove option can erase any hold positions.

If you want to <Add a camera into a sequence use the <Add button or if you want to Add> an additional camera hold position onto the end of a sequence then used the Add> button. If you do add or remove any additional cameras remember to perform another build of the AVI.

You can also manually edit the camera hold positions, time transitions between points, view orientation and direction. Again use the Prev and Next buttons to cycle through to the position you wish to edit and then click edit.

When you do this you will see the all these options mentioned will no longer be greyed out allowing them to be edited.

These variables can be altered and the steps described on the previous pages followed to create the new AVI and as before the new edited path can be saved for future use.
6. APlocate

This button activates the APlocate application which allows the user to edit data related to the site location of the model.

For more information please refer to the APlocate User Guide.
7. Edit Functions

This section looks at functions associated with the Edit toolbar.

7.1. Key-in Field

This allows you to enter commands or positional information using key-ins instead of the mouse.

Note: The Enter key must be pressed after typing a key-in.

By pressing the "Esc" key while in the key-in field a menu of a few basic commands is shown, selecting from this list will perform the appropriate function. Pressing the “Esc” key again or selecting the “cancel” option will close the list.
7.2. **Undo**

(“Edit” ⇒ “Undo”)

Use this command to reverse the last action.

7.3. **Redo**

(“Edit” ⇒ “Redo”)

Use this command to reverse an "Undo" action.

7.4. **Select Object**

(“View” ⇒ “Select Object”)

Various controls require object selection before they can be used, e.g. copying or rotating spaces. ModelIT supports both multiple and single object selection. To select a single object, click on the "Select Object" button in the Edit toolbar, move the mouse so that the cursor is over the object to be selected and then click the left mouse button (without dragging the cursor).

Another method of space selection is to use the Model Browser. By default the Model Browser is to the left of the ModelIT workspace, although it can be moved or hidden (see the Virtual Environment Framework document for more details). Single zones can be selected by clicking on the zone to highlight it. There are two methods of multiple selections. The first method involves holding down the <CTRL> key on your keyboard while repeatedly selecting single objects in the model view or in the Model Browser. The second method is similar to single object selection except that after pressing the mouse button to select an object, you keep the mouse button pressed and drag the cursor across the objects to be selected.

You will also notice that various buttons on the Edit toolbar, which were formerly inactive, become active. This is because the controls associated with these tool buttons require space selection before they can be used.

In order to de-select objects, choose the “Select Object” button. Move the mouse so the cursor is in the active model window and click the right mouse button.
7.5. **Measure Length**

This command allows you to measure the distance between two points. The distance in metres will be shown in the "Key-in" field in the edit toolbar.

7.6. **Measure Angle**

This command allows you to measure the angle between two points. The angle will be shown in the "Key-in" field in the edit toolbar.

7.7. **Query Co-ordinates**

This button is only active at the Model level; it highlights the point nearest to the cursor and displays the x, y, z co-ordinates in the "Co-ordinate" field in the view toolbar. In this mode the dynamic display of the cursor location is switched off.

7.8. **Copy**

Use this command to copy the selected objects in any 2D view. Once the object(s) are selected, click and hold the left mouse button and drag the object(s) to the new position in the active view. The copy will then be completed, provided there are no intersection errors. Absolute and relative coordinates may be keyed in to copy spaces.

Note if you want to use a vertex as the handle point for copying a group, you must press the mouse button when the cursor is close to the vertex (zoom in if necessary). Otherwise the handle point will be the actual model space point selected, even if there is no object at that point.

Key-In: dx=<dx, dy>

7.9. **Move**

This command allows you to move the selected objects. Once the object(s) are selected, click and hold the left mouse button and drag the object(s) to the new position in the active view. The move will then be completed, provided there are no intersection errors. Absolute and relative coordinates may be keyed in to move spaces.
Use this command to move the selected objects in any 2D view. Once the object(s) are selected, click and hold the left mouse button to drag the object(s) to the new position in the active view. The move will then be completed, provided there are no intersection errors.

Key-In: \( dx = <dx, dy> \)

### 7.10. Scale

("Edit" \( \Rightarrow \) "Selection Set" \( \Rightarrow \) "Scale")

Use this command to scale the selected objects in any 2D view. The "Scale Object" dialogue box will appear, in which you can enter the scale factors for the x, y and z axes.

![Scale Object Dialogue Box]

The "Lock Axes" check box is used to lock all three axes to the same scale factor. Next, click on one of the handle points of the selected objects to carry out the scaling operation.

The scaling limits are set at 0.0001 to 9999.9; any values entered out with this range will give the following warning:

![Warning Dialogue Box]

### 7.11. Rotate

("Edit" \( \Rightarrow \) "Selection Set" \( \Rightarrow \) "Rotate")

Use this command to rotate the selected objects in any 2D view. The "Rotate Object" dialogue box will appear. Enter the angular increments by which you wish to rotate the selected objects.
Now as you move the cursor around the defined axis point, you will see the objects rotating by increments dictated by the "Angular Increment" setting in the "Rotate Object" dialogue box. Click the left mouse button when you have the required rotation, and the rotation will be completed.

7.12. Mirror

(“Edit” ⇒ “Selection Set” ⇒ “Mirror”)

Use this command to create a mirror copy of the selected objects in any 2D view. The "Mirror Object" dialogue box will appear, in which you select the mirror axis – "Horizontal axis" or "Vertical axis".

Move the cursor so that it is close to a space vertex that you want to use as the handle point and then press the left mouse button. Keeping the button pressed, drag the mirror copy of selected spaces to the required location, and then release the mouse button. The mirror copy will then be completed.
7.13. Drag Face

("Edit" ⇒ "Selection Set" ⇒ “Drag Face”)

Drag a selected face a desired amount. Use the lock menu to adjust default settings.

![Drag Face lock](image)

- Drag dimension [m]: 1.0000
- Face Snapping (in Axonometric View): ✔
7.14. Connect Spaces

("Edit")

If you wish to model a space with a complex shape (e.g. a room with a dome shaped rooflight), and you wish to treat this space as one zone, you must first draw the two shapes separately, and then connect them using the "Connect Spaces" option. This will create a single composite space.

Select one of the spaces and then select the "Connect Spaces" option, the following dialogue box will appear:

Select the space you wish to connect to by selecting it in the view or the Model Browser. The name of this second space will appear in the "Add Spaces" section of the dialogue box.

Before you connect the spaces you can decide if you wish the partitions between them to be removed or retained after connection, by selecting the required option from the drop down list in the Connect Spaces dialogue box. To connect the two spaces (i.e. to create a single composite space) click the "Add" button.
7.15. *Edit Attributes*

Use this command to edit the "Colour" and/or "Layer" of the selected space. Pops-up the following window:
7.16. Edit Glazing, Doors and Louvres

(“Draw” ⇒ "Openings" ⇒ “Edit Openings”)

Use this option to place, replace or remove glazing, doors or louvres in selected rooms.

There are four options:

- "Add by Percentage Area"
- "Add by Percentage Area /Heights"
- "Add by Height/Width/Spacing"
- "Remove"

Each tab has a different set of items to set:
7.16.1. Add by Percentage Area

You can set the minimum and maximum azimuth in the first two columns and the minimum and maximum tilt in the third and fourth columns. For this tab the only other value to set is the "% Area".

At MODEL level - select a set of zones - key in "g=50" (or "G=50") - this will create 50% glazing on external surfaces.

7.16.2. Add by Percentage Area /Heights

"Min. Azimuth", "Max Azimuth", "Min Tilt" and "Max Tilt" defined as above. The other values to set in this tab are the lower sill (Y-Offset) of the window, Height and "% Area".

7.16.3. Add by Height/Width/Spacing

This tab allows a more complex arrangement to be defined:

"Min. Azimuth", "Max Azimuth", "Min Tilt" and "Max Tilt" defined as above. The distance from the edge of the wall is defined, "X-Offset", and from the bottom of the wall, "Y-Offset". The size of each window is defined by "Height" and "Width". The distance between each window is defined by "X-Spacing" and "Y-Spacing". The default is for the number of rows and columns to be automatically created by the numbers that fit, "-", but if required these may be constrained to a specific number.

7.16.4. Remove

"Min. Azimuth", "Max Azimuth", "Min Tilt" and "Max Tilt" defined as above.

Click on "Apply" to apply the settings to the selected room(s).

Note: when entering azimuth or tilt angles, if you enter a minimum value that is greater than a maximum value or vice versa, the value that you last entered will reset itself.
7.17. Edit Opening size and shape

When in Surface level (see Model Decomposition), this function becomes active. This feature allows to resize and reshape existing openings. Just left select a vertex and use the right mouse button to drag it to a new location. An arrow will show the vertex shift.
7.18. Edit Element Heights

("Edit" ⇒ "Selection Set" ⇒ “Element Heights")

Use this command to modify ceiling, floor and opening heights for the selected objects. Pops-up the following window:

From the top list, select the element type you wish to modify - “Floors/Ceilings”, “Windows”, “Doors”. The list box displays a list of selected element heights throughout the set of selected spaces. Notice that as you select each height in the list, the edges of all elements at this height are highlighted and a bounding frame is displayed around the highlighted edges. Select the height you wish to modify from the “Heights” list, enter the new height in the “Change To” box, and click on the “Change” button.

If “Dependent” Mode is used in the case of ceilings and floors (the mode selection is disabled when modifying window or door heights), the spaces above will shift up or down accordingly (i.e. the total height of the building will change). If “Independent” Mode is used, the location of the adjacent spaces above will remain static, and so the adjacent spaces above will shrink or grow in height (i.e. the total height of the building will remain static).

It is usually easier to see the various element heights if you select an Axonometric view in the active model window before using the "Set Element Heights".
7.19. Create Roof

This opens the following window which can be used to generate a basic roof space:

![Generate Roofs Window]

- **Slope**: 30
- **Overlap**: 0.250

Creates a pitched roof over the selected space(s) with the defined characteristics i.e. "Slope" and "Overlap", provided other conditions are met e.g. non-interpenetration.

**Hint:**
We have found that better results can be obtained by drawing a temporary space on top of the building and generating the roof on that “clean” space. Then delete the temporary space and move the roof down to meet the building.
7.20. Assign textures

Assign textures to external and internal surface for an improved visual representation of the model with the Assign Texture function. Select a texture from the list and click the Replace button to assign the new texture. Applied changes can immediately be seen in Model Viewer.

7.21. Refresh Display

In order to cut down on the time spent refreshing the display, particularly as models get larger and more complex; ModellIT has a minimal approach to refreshing the display. This button provides the user with this function.

7.22. Delete

("Edit" ⇒ "Delete")

Use this command to delete the selected objects. If you delete an object by mistake, use the "Undo" option to retrieve the object(s).
7.23. *Divide Space*

This is the first tab option in the "Edit Space" window.

First select the zone you would like to divide and go down to the space level using the level arrows as shown previously.

Next select edit from the drop down menu

The edit space dialogue box (image below) will appear along with the cutting plane in the modelling window.
You can select the orientation of the plane. Click to action the position change. You can either manually type in the co-ordinates of the cutting plane or you can click on the tool at the top of the box (get locator co-ordinates from space vertex) then click and drag (holding the left mouse button) the three corner points of the cutting plane in the model space to position it as shown in the diagram on the next page.
Click the generate cutting plane button and a yellow indicator will appear giving you a preview of the cut.

Finally you select whether or not you would like to retain the partitions and click the divide space button.
7.24. Separate Composite Space

This is the second tab option in the "Edit Space" window.

This gives the user the option of creating separate spaces from the composite space. So if the user has used the Divide Space tool they must use the Separate Composite space tool to make the Rooms complete separate entities. The other scenario where this tab would be utilised is when the user has connect two (or more) spaces and wish them to be separated again.
7.25. *Edit Vertices*

This is the third tab option in the "Edit Space" window.

![Edit Vertices window]

The user selects vertices, which are highlighted in the view. Multiple selections can be made by using the <CTRL> key. When the "Move Vertices" button is pressed the defined shift in x, y and z is applied.

When the user is in a 2D view the button becomes active, which allows the user to drag the selected vertices in the graphics window.

If after making the defined modifications to the space, a surface is warped, then the following pop-up warning is issued and the user can either resume editing the vertices or restore the original space.

![Warning pop-up]

Yes to exit and restore original space, 'No' to exit anyway, or 'Cancel' to continue editing.
8. View Functions

This section looks at functions associated with the View toolbar.

8.1. Fit View

(“View” ⇒ “Zoom” ⇒ “Fit”)

Use this command to fit the whole model into the active view.
8.2. Zoom Window

("View" ⇒ “Zoom” ⇒ “Window”)

Use this command to define a window area to view a particular part of the model. Click in a point in the view to define a corner of your desired window, and keeping the mouse button depressed, move the cursor to the opposite corner, then release the mouse button.
8.3. **Zoom In**

(“View” ⇒ “Zoom” ⇒ “In”)

Performs an incremental zoom into the view.

8.4. **Zoom Out**

(“View” ⇒ “Zoom” ⇒ “Out”)

Performs an incremental zoom out from the view.

8.5. **Pan**

(“View” ⇒ “Zoom” ⇒ “Pan”) or use middle mouse button

Selecting this option activates allows you to pan round the model view. Click in the view, and keeping the mouse button pressed, pan the window to the desired location, and then release the mouse button. The view will be updated with the contents of the panned window.

Direct access to the pan function gives the middle mouse button (scroll wheel), keep it pressed while moving the mouse to pan the window to the desired location, and then release the button.

8.6. **Zoom Previous**

(“View” ⇒ ”Zoom” ⇒ ”Zoom Previous“) or use Mouse Scroll Wheel

Change the view window to the last view before the current view.

8.7. **Zoom Next**

(“View” ⇒ ”Zoom” ⇒ ”Zoom Next“)

Change the view window to the next view in the sequence, assuming the ”Zoom previous“ has been invoked.
8.8. View Selection

("View" ⇒ "Rotation")

Allows the user to view the model from different aspects:

- **Plan** ("View" ⇒ "Rotation" ⇒ "Plan View [X-Y]")
- **Back** ("View" ⇒ "Rotation" ⇒ "Back View [X-Z]")
- **Front** ("View" ⇒ "Rotation" ⇒ "Front View [X-Z]")
- **Right** ("View" ⇒ "Rotation" ⇒ "Right View [Y-Z]")
- **Left** ("View" ⇒ "Rotation" ⇒ "Left View [Y-Z]")
- **Axon.** ("View" ⇒ "Rotation" ⇒ "Axonometric View")

For example, axonometric view:

![Axonometric View](image)

Front view:

![Front View](image)

8.9. Set Axonometric Rotation

("View" ⇒ "Rotation" ⇒ "Set Axonometric Rotation"

This command allows you to define the altitude and azimuth for the axonometric view. This can be done dynamically in the model space using the mouse. When you have the desired rotation click once on the right mouse button to set.
8.10. Rotate View

VE Toolbar button: 
Menu shortcut: “View”  “Rotation”  “Rotate View”

From the drop down list in this box you may choose to rotate any 2D view by either "Rotate using two points" within the view (the view will be rotated to the angle between the two points), or by "Rotating by angle" (and entering a rotation angle in the box provided below). You may return the view to its pre-rotated state by choosing the "Unrotate View" option from the drop down list.

8.10.1. Rotate View – example of use

Consider the following model that is rotated to the normal and thus not aligned with the grid.

1. Measure the angle by:
   a) clicking on the Measure angle toolbar item
b) clicking on two points to identify a line then reading the angle from the key-in display field.

2. Rotate projection by angle
   a) click Rotate view button on VE toolbar
   b) enter angle (here 45)
   c) click OK button

View is now rotated and model aligned with grid
8.11. Mode Selection

This is linked to the level of decomposition (see section 2.5).

Initially the mode is MODEL. When a space is selected and the user moves down to the SPACE level the mode changes to. In this mode various functions will become active and others inactive. An option at this level is to invoke the option, which pops-up the "Edit Space" window. The alternative is to go down another level to the SURFACE level. At this level there is the option to invoke the option.

8.12. Storey Level Selection

The whole model can be viewed or each floor (storey) can be selected individually.

8.13. Move Up One Level

Moves from a lower to a higher level of decomposition. See section "2.5 Levels of decomposition" for more details.

8.14. Move Down One Level

Moves from a higher to a lower level of decomposition. See section "2.5 Levels of decomposition" for more details.
8.15. Object List

When the edit option is invoked the following window is popped-up:

This activates the three edit options:

"Divide Space"
"Separate Composite Space"
"Edit Vertices"

These three edit options are described in more detail in sections 7.23, 7.24 and 7.25. If this window closes whilst you are still in the edit mode you can click on the icon on the generic tool bar and open it again.
8.16. North Indicator

This shows the orientation of the model to North, the default being that North is in the
direction of the positive Y-axis.

To edit this value, go to the "Settings" pull-down menu and select the "Site Rotation" option,
which pops-up the following window:

A positive angle rotates North anti-clockwise from the +ve Y-axis.

North orientation will be indicated in Model Viewer through an arrow pointing north.

8.17. Co-ordinate Location

In "Query Co-ordinate" mode the location of the selected point is displayed in the coordinate
status tool bar at the bottom of the screen, otherwise the cursor location is displayed when it
moves across the view window.
9. ModellIT Menu Functions

9.1. Attach DXF File

Use this command to attach a DXF format drawing file to the project. You may only attach one DXF file to the project at any time.

The “Attach DXF File” dialogue box is as follows:

![Attach DXF File dialogue box]

The "Scale Factor" is used to specify the DXF file units. You can either opt for one of the set units (metres, inches, etc.) or define your own factor. ModellIT will translate all working units to SI units, which is the adopted IES design software convention.

The "Plane" value refers to the height in the ModellIT Z-plane at which the DXF file is attached. The attachment plane has particular significance when using the optional Construct/DXF module because spaces will be automatically extruded from this plane.

When you attach a DXF file, ModellIT will convert all arcs and curves into series of straight lines or vectors which you will see in the ModellIT view. The arc-chord distance is the maximum distance between the resulting vectors and the actual line, define this value in the “Maximum Arc-Chord Distance” field. A very small arc-chord distance will result in a very accurate representation of the arc or curve but will result in a longer processing time and
conversely a large arc-chord distance will produce a less accurate model but much faster processing times.

Select the DXF file and click on "Open" to attach the DXF file. You will then see the DXF file in the ModelIT window.

9.2. Detach DXF File

Use this option to detach a DXF file from the project.

9.3. Active DXF Layers

This option activates the "DXF Layers" dialogue box, which displays the levels (or layers) with which the DXF file was constructed when it was drawn. Clicking the On or Off buttons shows or hides levels of the DXF drawing which may contain information you do not wish to view while building a model, or which you do not wish ModelIT to interrogate during the optional Construct/DXF process, such as furniture, dimensions etc.

Click on "Close" to accept the changes.

9.4. Move DXF File

This allows the user to manipulate the position of the DXF file once it is attached in the VE model space.

9.5. Attach Obstructions File

Opens a MIT file which is to be used as an obstructions file.

9.6. Detach Obstructions File

Use this option to detach an obstructions file from the project.
9.7. Import GEM File

Imports a geometry file in the GEM (geometry) file format into ModelIT. The following window is displayed.

Click Import to bring up the following window. Browse for the desired GEM file and click Open.
The GEM file will be imported for preview as in the following window. Templates can then be applied for:

- Room attributes
- Constructions
- Macroflo opening types
- Thermal conditions
- Electric lighting
- Radiance surface properties

Click OK to confirm the geometry import.

**9.8. Export GEM File**

This option exports the geometry created by ModellT, to the GEM file format.
9.9. Import gbXML File

ToolBar button: ; Menu Item:
This function is found in the file drop down menu. It allows for the import of geometry in the gbXML file format into ModellIT. The following window is displayed.

Before clicking Import there are a few surfaces and check options to select from.

You can then select import to bring up the following window. Browse for the desired gbXML file and click Open.

The gbXML file will be imported for preview as in the following window. Templates can then be applied for:
- Room attributes
- Constructions
- Macroflo opening types
- Thermal conditions
- Electric lighting
- Radiance surface properties
Click OK to confirm the geometry import.

If the source of the gbXML file is Autodesk Revit, then a Heating and Cooling Loads dialog will open:

This window allows the imported model to be viewed with the modelviewer controls. Template data can be set to rooms or the building as desired.
**Building Tab** – Data that can be applied to the entire model.

- **Building Type** can be used to apply thermal template data including Heating and Cooling Set Points, Internal Gains and Air Exchanges.
- **Building Constructions** apply constructions from the Constructions Database to surfaces and openings in the building.
- **Building Service** can be used to select a Service for the building.
- **Place and Location** allows the building geographical position to be set.

**Rooms Tab** – Data can be set for individual rooms.

- **Level** can be used to display the rooms that have their z-base on each floor individually.

![Select button](image)

Select button

This causes the model viewer control to show all rooms in normal colours except the selected room(s), which will be shown in red “highlight” colours.

![Isolate Button](image)

Isolate Button

This causes the model viewer control to hide all rooms except the selected room(s).

Room Type, Room Construction and Room Service can be used to apply data to the selected room(s).
9.10. Export STL File

This option saves the selected zone(s) in the "STL" (stereolithography) format. This is an ASCII file where surfaces are broken down into triangular polygons.

The following window is popped-up -

![Export STL dialog box]

The user has options to include Components and/or Openings in the exported file.

9.11. Export DXF File

This option exports the geometry created by ModelIT, to a 3D dxf file format. The surface representation can be switched between Polyline and Polyface mesh. Openings (windows, doors, etc.) can be included or excluded from the export.

![Export DXF dialog box]

9.12. Attach/Detach Bitmap File...

This function allows the user to attach bitmap images into the VE model space to create models from an alternative template source.
9.13. Merge Model Data

This will update the current model (the "New" model) with Room Attribute and Template data by matching zones to an existing model (the "Old" model).

The following window is popped-up -

Initially this shows the list of zones in the "New" model - the assigned templates are shown when zones are selected, and can be modified by clicking the "Apply changes to Zone" button. This dialog can be used to check and update the model without going into the full "Model Merge".

The next step is to select a "Merge Zones By" option, if you haven't made a selection and click the "Browse" button first you will be prompted to do so.

When you use the "Browse" button to select the "Old" model, you will get the following pop-up warning -

When you have selected the "Old" model it replaces any templates you have in your "New" model and replaces the assignments to zones it has "matched" between the two models. The dialog is updated to show this -
Zones that have failed to find a match will show "<no match>" and these can be updated by selecting a zone from the "Old" model and using the "Copy to New Model" button.
10. Settings Menu / Model...

![Model Settings Window](image)

10.1. Adjacency Separation Distance

When a model is created by placing zones side by side (or on top) the relationship between adjacent (or overlapping) surfaces is detected. The "Adjacency Separation distance" is the threshold at which the detection occurs, i.e. if the surfaces are closer than this distance they are flagged as adjacent otherwise not. This value can be changed in the "Model Settings" pop-up window ("Settings"->"Model" menu). After this value has been changed the "rebuild" command should be invoked.

10.2. Vertical-Horizontal element transition angle

This is the angle at which a sloping wall becomes a roof/ceiling. In normal zones walls are vertical and roofs/ceilings are horizontal, however if we create complex zones which surfaces at non-vertical and/or non-horizontal surfaces we have to decide whether these are treated as walls or roof/ceiling. This angle is the slope at which this transition occurs.

10.3. Rebuild model adjacencies

The "Rebuild model adjacencies" button performs exactly as the "rebuild" key-in option does. This goes through the model and recreates the adjacencies and constructions based on the above two values. This command has to be called after either of the above values has changed.
10.4. Model report options

The model report options allow the user to run a quick quality check on the geometry they have created and the basic data that has been assigned.

There are two sections to the report:
   iii) Section A – Consistency checks
   iv) Section B – Data assignment

For more details please see Model Consistency Report.

10.5. Visibility

This option allows the user to turn the visibility of rooms off by six different options.

- All rooms
- Selected rooms
- Room
- Adjacent Building
- Topographical Shade
- Local Shade

These visibility controls give the user more options and are similar to the room group ticks in the model browser and the stories options which also allow the user to turn the visibility of rooms on and off.

10.6. Room Types/Obstructions

The way that you set up your models with regards to solar shading devices and obstructions has changed in VE 6. You now have the option when you are creating a room to choose what type of room it is going to be from the following:

- Room (1)
- Adjacent Building (2)
- Topographical Shading (3)
- Local Shade (4)

If you forget to set this up when you are creating your model you can change the properties of a room(s) in the model browser at a later point. Please refer to section 3.2 for more information on how to do this.
11. ConstructDXF

11.1. What is ConstructDXF?

ConstructDXF is used to produce data for IES’s thermal, shading analysis, lighting and building design appraisal software by scanning ordinary DXF drawings of building plan layouts, and generating a 3D building data model, within the ModellIT environment. ConstructDXF simplifies and accelerates the preparation of data for a wide range of building design studies including thermal design, shadow modelling, dynamic thermal simulation, multi-zone airflow analyses and electric lighting/daylighting studies.

ConstructDXF allows the generation of a full three-dimensional spatial building model and associated non-graphical attribute data from DXF format drawings.

The data model can be generated from DXF drawings containing any conventional drawing element (arcs, shapes, cells, B-splines, etc.). No special elements or attributes are required. In addition to single floor plans, ConstructDXF will cater for several buildings on one site, multi-storey buildings, and buildings that bifurcate as they rise up.

Once the 3D model has been created by ConstructDXF, geometric (and attribute) modifications or additions can be made to the model if required using the standard ModellIT facilities. Likewise, models created using ModellIT can be built further using ConstructDXF (if, for example, you wish to generate an additional storey from a DXF drawing).

Additionally, luminaires can be placed and modified in the 3D model either directly by the user (for subsequent point-by-point analysis by the lighting calculation software) or as a result of performing a lighting design with the lighting software.
11.2. How ConstructDXF Works

The use of ConstructDXF can be broken down into the following basic operations:

- ModelIT is started and a new (or existing) project is opened.
- A drawing file in DXF format is read into ModelIT.
- Defaults for the room thermal and lighting data and fabric element constructions are set by means of room templates.
- ConstructDXF is then started within ModelIT.
- Extract settings (rules and tolerances) are set, together with default storey heights for the storey to be generated, and default window and door heights.
- A 3D data model for that storey is then generated (extracted).
- If required, another DXF drawing can then be loaded into ModelIT, and further storeys can be generated.
- Within the 3D model, the data for individual rooms and elements can be modified.
- The finalised 3D data model can then be used by the IES thermal and/or lighting software for calculation purposes.
- Calculated luminaires can be added to the 3D model.

11.3. Preparation of the DXF Drawing

First, start ModelIT, and open a new or existing project by selecting New or Open from the File menu. Next, from the File menu, select Reference Files, and select Attach DXF File to find and attach your required DXF drawing. The DXF drawing will then be displayed in the ModelIT window.

A DXF drawing in ModelIT

Layers (levels) in the DXF file can be switched on or off within ModelIT. To do this, use the File menu and select Reference Files, then Active DXF Layers. Layers which contain elements which are not to form part of the building model (grids, dimensions, furnishing and fitting symbols, etc.) should be turned off.

ConstructDXF is designed to operate on DXF plan view drawings. If required, the same DXF file may be used for several storeys.
11.3.1. Drawing Elements Required by ConstructDXF

The only items in a drawing which are essential for the use of ConstructDXF are external and internal walls and room name text.

Additionally, door and window symbols (if they exist in the drawing) can be used by ConstructDXF, if you require these items in the building model.

It may be appropriate to make a copy of the original drawing, and to prepare the copy for subsequent use by ConstructDXF.
When the DXF drawing is being prepared, elements which are not to form part of the building model (such as grids, dimensions, furnishing and fitting symbols, services, drawing title blocks, etc.) should be deleted. When the drawing is initially being created, it may be easier for these items to be placed on separate layers (levels) from wall, window, door or room text elements, and then the appropriate layers can be deleted.

Stair symbols, riser symbols and hatching must be deleted. Desk partitions and partitions which do not divide a room into two separate rooms should also be deleted.

Any elements outside the building perimeter (including text) should be deleted. Alternatively, during preparation of the DXF drawing, the unwanted items can be placed on different layers (levels) from wall, window, door or room text elements. When the DXF drawing is subsequently attached in ModelIT prior to model generation using ConstructDXF, layers (levels) in the DXF file containing unrequired elements can be switched on or off using facilities within ModelIT.

It should be noted that the best method is to delete the unwanted items or the layers containing the unwanted items. This will shorten the time taken to attach and display the drawing in ModelIT, and will also shorten refresh times when views are changed within ModelIT. The simpler the drawing, the faster ConstructDXF will generate the building model.

An example of a drawing containing only the required items is shown below:
11.3.2. Basic Rules

ConstructDXF applies three basic rules to each DXF drawing file in order to identify building perimeters, room perimeters and bordering elements including roofs, ceilings, internal floors, ground floors, external walls and internal partitions:

- **Rule 1** - each building on a drawing must have a closed external loop which may incorporate door symbols and window symbols (see Window Symbols and Door Symbols below).

- **Rule 2** - all internal spaces or rooms in the drawing must have a closed internal loop which may include door and window symbols (see Window Symbols and Door Symbols below). The internal loop may include some of the elements of the external loop.

- **Rule 3** - all rooms to be included in the generated model must have one text label located within the room perimeter.

11.3.2.1. Wall Elements

Wall element lines should meet or slightly overlap at their intersections at internal room corners so that rooms are closed spaces, i.e. there are no breaks in the room perimeters. Similarly, wall element lines should meet or slightly overlap at their intersections at external building corners, so that the building has a closed external...
loop.

Note there is a facility within ConstructDXF to account for lines which do not quite intersect, but an appropriately draughted drawing will shorten the time spent using ConstructDXF.

Ideally, wall thicknesses should be comprised of one or two lines. If more than two lines are used, this may interfere with the recognition of window symbols by ConstructDXF.

Internal or external sill lines should be deleted. Hatching lines must also be deleted.

11.3.2.2. Room names

All rooms/spaces in the drawing (including internal courtyards, stairs, lifts, atria, corridors etc) to be included in the generated model should have one text label located within the space. ConstructDXF will recognise the existence of multiple labels within one room but this will significantly increase the processing time and therefore any unnecessary text should be removed.

If any rooms/spaces in the drawing do not have any text labels, then these rooms will not be included when the model is generated using ConstructDXF.

The origins of text labels must not lie within the thickness of internal or external walls.

The room text must be single line text, not multi line text.

11.3.2.3. Window Symbols

Where possible, window symbols should be placed on a separate layer (level) from other elements. When ConstructDXF is being used, a particular layer can then be specified for the identification of window symbols. If possible, windows should not have any unnecessary detail lines.

Windows should be drawn in one of two ways:

1. Elements forming an overlaid or indented rectangle within an external wall, as shown below:

   ![Window Symbol 1](image1)

   w = window width
   d = window offset from wall plane

2. A number of parallel lines within an external wall element, as shown below:

   ![Window Symbol 2](image2)
w = window width
n = no. of parallel lines

11.3.2.4. **Door Symbols**

Doors may be represented using two lines at an angle of between 30 degrees and 60 degrees to each other or a 90-degree swept arc as shown below. Small line segments included within a door symbol will automatically be ignored.

\[
\begin{align*}
&d = \text{door thickness} \\
&l = \text{door recess depth} \\
&w = \text{door width}
\end{align*}
\]

Door swings must be comprised of either an arc or a single straight line. If an arc is used, it must be an arc element (i.e. the arc must not be comprised of individual straight segments). If the door symbol is comprised of any other type of element, it will not be recognised by ConstructDXF.

The door opening in the wall must not be closed off with a line, see below:

Correct

Incorrect

If possible, where a 2-line wall element is being used, the door swing should connect with the inside corner of the wall element, rather than the outside corner.
11.4. Setting Up Room Templates Using the BTM

ConstructDXF uses room templates, which contain defaults for both construction and non-graphical attribute data (lighting, thermal, casual gains, air exchange, etc). The available templates are shown in the drop down list in the dialogue bar at the bottom of the ModelIT window.

Templates are created and edited using the Building Template Manager utility, which is accessed via the Templates menu on the <VE> menu bar (see the Building Template Manager User Guide for further information).

Note that you do not have to use the Building Template Manager before you generate a model. If you have no attribute information, just use the ‘default’ template. Rooms that are generated will be assigned default attributes, and you can then modify the attributes of each room individually when you have the correct attribute information.
11.5. Starting ConstructDXF

Select ConstructDXF from the Utilities menu.

The ConstructDXF window is where extract settings are specified, and from where the model is generated.

When ConstructDXF is first started, the ConstructDXF window displays the model view which is comprised of the current DXF drawing and the 3D model (if it has been generated).

The ConstructDXF window showing the DXF drawing
11.6. Settings

Clicking on the Settings button in ConstructDXF opens the Settings dialogue box, which is split into tabbed sections.

11.6.1. Settings - Tolerances Tab

This contains controls to set various tolerances used during the model generation process.

Settings - Tolerances tab

11.6.1.1. Max Arc-Chord Distance

ConstructDXF will convert all arcs and curves into series of straight lines or vectors. The arc-chord distance is the maximum distance between the resulting vectors and the actual line. A very small arc-chord distance will result in a very accurate representation of the arc or curve but will result in a longer processing time and conversely a large arc-chord distance will produce a less accurate model but much faster processing times. Any arc having a radius within the minimum-maximum door width range will automatically be converted to a single straight line.

11.6.1.2. Line Extension

Having extracted all drawing elements from the DXF file, ConstructDXF then converts all elements into series of lines or vectors. In order to cater for drafting inaccuracies or errors in file translation, an extension may be added to the ends of all vectors to ensure that lines that should meet do actually meet. Be careful when applying extensions not to inadvertently cause lines to be joined which should be kept separate.

11.6.1.3. Maximum Horizontal Separation

This allows you to identify horizontal room adjacencies. This value should be set to slightly
greater than the maximum wall thickness as it appears in the drawing.

If the distance between one space and another space (after model extraction) is less than this value, the two spaces are deemed to be adjacent to one another, i.e. the facing elements of each space are the same connecting partition.

If the distance between the two spaces is greater than the adjacency separation distance, then the two spaces are deemed to be independent of each other, i.e. the facing elements of each space are exterior walls.

11.6.1.4. **Maximum Vertical Separation**

This allows you to identify vertical room adjacencies. This value should be set to slightly greater than the maximum slab thickness (including floor and ceiling depths).

11.6.2. **Settings - Line Combination Tab**

During the model generation process, any lines or vectors which are considered to be parallel and touching will be combined into a single vector. The Line Combination tab contains the tolerancing controls for determining whether or not lines should be combined.

**11.6.2.1. Connecting Angle**

Two lines will be considered parallel if they meet at an angle between the Connecting Angle and 180 degrees.

**11.6.2.2. Max. Separation**

The maximum distance between two lines, below which the lines are considered to be touching.
11.6.3. **Settings - Heights Tab**

This tab is used to set default heights for the automatic model generation.

![Settings - Heights tab](image)

**11.6.3.1. Base Plane**

The base plane is the point in the model Z (height) plane from which the storey will be extruded.

**11.6.3.2. Storey Height**

The storey height is defined as the distance between the finished floor level and the finished ceiling level (i.e. the useable room height).

**11.6.3.3. Window Cill Height**

The default window cill height is the height of the window cills from the finished floor level.

**11.6.3.4. Window Height**

This is the default window height above the cill height.

**11.6.3.5. Door Height**

This is the default height of doors above the finished floor level.
11.6.4. **Settings - Doors Tab**

This tab contains controls that are used to set tolerances for the identification of door symbols in the drawing.

![Settings - Doors tab](image)

11.6.4.1. **Min. Door Width**

Doors may be represented using two lines at an angle of between 30 degrees and 60 degrees to each other or a 90-degree swept arc. If the line representing the door (as opposed to the sweep) is less than the minimum door width, the symbol will not be interpreted as a door.

11.6.4.2. **Max. Door Width**

Doors may be represented using two lines at an angle of between 30 degrees and 60 degrees to each other or a 90-degree swept arc. If the line representing the door (as opposed to the sweep) is greater than the maximum door width, the symbol will not be interpreted as a door.

11.6.4.3. **Max. Door Recess Depth**

This tolerance caters for cases where the door symbol has been draughted such that the door panel line originates from one point relative to the wall (e.g. the inner surface of the wall), and where the door swing line or arc originates from another point relative to the wall (e.g. the outer surface of the wall, or within the room).

This may occur where the intersection of a double door symbol extends beyond the wall plane.

If the distance (perpendicular to the wall) between these two points is greater than the maximum door thickness, the symbol will not be interpreted as a door.
11.6.4.4. **Min. Wall Length**

If the length of a wall element is less than the minimum wall length, ConstructDXF will not identify this element as a wall. ConstructDXF also uses this tolerance in the identification of door elements. If door symbols contain details such as the thickness of a door, make sure that the minimum wall length is greater than the maximum length of all detail lines.

11.6.5. **Settings - Windows Tab**

This tab contains controls that are used to set tolerances for the identification of window symbols.

Window symbols are identified using the following hierarchical rules:

- Any element found on a drawing layer (level) specified in the Layer box.
- Any sequence of elements forming an overlaid or indented rectangle within an external wall.
- A number of parallel lines within an external wall element. This number must be greater than or equal to the Minimum Number of Lines setting for the identification of a window.

11.6.5.1. **Min. Width**

A window symbol will not be interpreted as a window if its width is less than the minimum window width.

11.6.5.2. **Max. Width**

A window symbol will not be interpreted as a window if its width is greater than the maximum window width.
11.6.5.3. Max. Offset
A window may be represented by a rectangle overlaying or indented within an external wall element. If the offset or indent of the rectangle sides from the parallel wall surfaces is greater than the maximum window offset, it will not be interpreted as a window.

11.6.5.4. Min. No of Lines
This is the minimum number of parallel lines that have to be drawn for a window element, for that element to be identified as a window.

11.6.5.5. Layer
If a drawing layer is selected for a search, ConstructDXF looks for windows on the DXF drawing layer (or level) that is selected. If you do not wish to search on other layers, select ‘No Layer Search’.

11.6.6. Settings - Key Labels Tab
String patterns are entered here. They are used in the extraction process to identify spaces that are to be treated as void or stacked spaces, by analysing the text in the rooms in the DXF file. Stacked spaces only apply to multi-storey models.

11.6.6.1. Void
This is used to define a search string pattern for external spaces within a building perimeter, e.g. courtyards, light-wells, etc. Any room having a name, which complies with the void space search string pattern, will be considered an external space (e.g. courtyard). The string may contain wild-card characters (* and ?). For example to include all rooms containing the string ‘court’, you would type in "court". More than one key label can be defined by using a semicolon to separate the labels.
11.6.6.2. Stacked

This is used to define a search string pattern for spaces that are vertically continuous. Any room having a name, which complies with the stacked space search string pattern, will be considered a vertically stacked space (e.g. stairwell). The string may contain wild-card characters (* and ?). For example to include all rooms containing the string ‘stair’, you would type in “*stair*”. More than one key label can be defined by using a semicolon to separate the labels.

The default values set up in these Settings tabs are the result of extensive application and have been found to be appropriate for most cases. Consequently, if you are uncertain of which values to use for a drawing file, try generating a model using the default values and then modify them if necessary.

Check that the minimum/maximum door range and minimum window length and maximum window offset cover all occurrences in the drawing.

When you have entered the required data in all the above tabs, press OK to update the Settings. The Settings dialogue box will then close.

11.6.7. Settings – Room Templates Tab

The room templates tab lets the user select which template is to be applied to all the zones constructed from the DXF drawing. Templates allow for easy designation of common zone features and conditions when constructing a <VE> model. Only one template for each category can be assigned to all the zones during a ConstructDXF operation. More information on templates can be found in the Building Template Manager user guide.

11.6.7.1. Room Attributes Template

This section allows the user to set the percentage of floor area that is lettable or circulation.
11.6.7.2. **Constructions Template**
This section is where the opaque and glazed constructions are specified for templates.

11.6.7.3. **MacroFlo Opening Types Template**
This section is where the MacroFlo opening types are assigned to templates. The opening types available are:
- Rooflight
- External Glazing
- Internal Glazing
- Door.

11.6.7.4. **Thermal Conditions Template**
This section is where room thermal conditions are assigned to templates. There are four tabs for thermal conditions data (five if Building Regulations are enabled):
- Building Regs (optional)
- Heating
- Cooling
- Casual Gains
- Air Exchanges

11.6.7.5. **Electric Lighting Template**
This section allows electric lighting data to be assigned to templates used by programs within the <VE> Lighting section.

11.7. **Extract**
Clicking on the Extract button initiates the model generation process which is displayed on a percentage completion bar. The process may be aborted at any stage by clicking on the Cancel button.

When the Extract process is complete, you will see the generated model in both the ModellIT window and in the ConstructDXF window.
If required, another DXF drawing can then be loaded into ModelIT, and further storeys can be generated. To do this, close ConstructDXF, then use the Reference Files option from the File menu to attach the next DXF file. Then start ConstructDXF again. Before you extract the next storey, make sure that the value of the Base Plane in the Heights tab of the Settings dialogue box is equal to or greater than the Z value of the top of the current storey.

Note that you need to close the ConstructDXF window before you can use any of the ModelIT facilities.

11.8. **Modifying the 3D Model**

Once the model has been generated, you may use the standard ModelIT techniques to modify the thermal, lighting and construction attributes for a single room or a selected group of rooms. You may also add rooms or draw pitched roof constructions using the ModelIT drawing tools. See the ModelIT User Guide for further information.

Note that you need to close the ConstructDXF window before you can use any of the ModelIT facilities.

Use the Building option from the Settings menu in ModelIT to define the building rotation for thermal and shading calculations.

Use the APlocate utility to set up site and weather data for thermal and shading calculations (see the APlocate User Guide).
11.9. A Quick Guide to Generating a ConstructDXF Model

Create a new project by selecting ‘New’ from the File pull down menu.

Attach a DXF drawing using the Reference Files option from the File menu. Turn off all unnecessary layers in the drawing.

Start ConstructDXF. Check that the extract settings are appropriate for the current DXF file then click on the Extract button to generate the data model. The model generation progress will be displayed on a completion bar.

The process may be aborted at any stage by pressing the Cancel button.

When the extract process is complete, the generated building model data is written to a model project file with the extension *.mit. This file holds both geometric or spatial data and non-graphical attribute data.

When you close ConstructDXF, the ModelIT facilities that allow you to modify the data model are now enabled.

If required, another DXF drawing can then be loaded into ModelIT, and further storeys can be generated.
12. Geometry Navigators

12.1. Settings
Documentation in progress.

12.2. Draw Spaces
Documentation in progress.

12.3. Draw from DXF
Documentation in progress.

12.4. Import BIM
Documentation in progress.

12.5. Draw features & shades
Documentation in progress.

12.6. Room grouping (name/type)
Documentation in progress.
12.7. Tools

The geometry tools navigator.

12.7.1. General tools

12.7.1.1. Select by layer
This selects all rooms in the model which have the same layer property as the currently selected space.

12.7.1.2. Select by colour
This selects all rooms in the model which have the same colour property as the currently selected space.

12.7.1.3. Open viewer to perform visual checks
This opens the model viewer (basic) in order to visually examine the model for correctness.

12.7.1.4. Expand or Shrink openings
This opens the Scale selected openings tool.

12.7.1.5. Create single shell from all spaces
Combines all the spaces into a single shell.

Warning: Should be used with caution.

12.7.1.6. Split combined space
Splits up the currently selected combined space into its constituent sub-spaces.

12.7.1.7. Rename rooms
Rename all selected rooms.
12.7.2. Geometry checks

12.7.2.1. Detach DXF
Removes the attached dxf file.

12.7.2.2. Remove construction lines
Removes all constructions lines from model.

12.7.2.3. Perform geometry consistency check
(Same function as found in Settings > model > check menu in ModelIT).

12.7.2.4. Open model consistency check results
This will open the results of the geometry check. This step is dependent on previous step (Perform geometry consistency check) having been carried out first.

12.7.2.5. Export templates, systems and constructions to XML
This navigator step outputs the template data, system data and construction data to an XML file.

12.7.3. Speed up model edit
Some functions added by request in order to speed up the manipulation of geometry for very large projects.

12.7.3.1. Enable sparse mode
Switches off model browser and undo operation in order to improve the response time while working with larger models in ModelIT.

Warning: Should be used with caution and disabled when current edits are finished.

12.7.3.2. Disable sparse mode
Switches the browser update and undo operation back on.

12.7.3.3. Refresh model browser
Re-populates the model browser with the current model status. This is required if the user has been using the sparse mode.
13. key-ins

List of key-ins commands (click to jump to a description of scroll down to browse).

A
ADJHOLE
AXON
BUILD
BYPASSCHECK
C
CELLS
CLIPOPENINGS
COL
CORE
CORRECTSHELL
D
DEL
DELCOMPS
DELMV
DELSURF
DIM
DUMPCOMPS
DUMPNM
DUMPRM
DV
DX
DXF
DXFNames
FIND
FIX
G
GW
INITZONES
INN
INT
INTBODY
INTERSECTION
LAY
LISTCOMPS
MB
MIT
MODEL
OPEN
ORIGIN
OSM
P
Path
PSWIN
REBUILD
RENAME
RG
RMD
RMDE
RMDI
RMH
RMHE
RMHI
RMOPEN
ROOM
SECTION
SELCOL
SELLAY
SHELL
SHRINK
SPLIT
STAMP
TEXT
TIDY
Tidymirror
Tidysurfs
Tidyunbound
TOOLOFF
TOOLON
TOOLRESET
UNDO
UNITS
VIEWINIT
VIS
VP
X
XMLDUMP
ZONEID
V.  A

Rotate selected object(s) by angle (degrees).

Parameters:
angle

Example:

\( a=45 \)

VI. ADJHOLE

Make adjacent surfaces Holes

Example:

\( adjhole \)

VII. AXON

Set axonometric view rotation (no parameters = display current azi, alt)

Parameters:

<none>

or

azimuth, altitude

Example:

\( axon=120,35 \)

VIII. BUILD

Regenerate adjacencies for selected zone(s)

Example:

\( build \)

IX. BYPASSCHECK

Bypass geometry checks
Parameters:
ON/OFF

Example:
\[ \text{bypasscheck}=\text{on} \]

X. C
Closes current shape

Example:
c

XI. CELLS
Convert selected body's surfaces to 1m² cells. Works on a single selected zone at model level.

Example:
cells

XII. CLIPOPENINGS
Ensures openings do not extend beyond adjacency they are on

Example:
clipopenings

XIII. COL
Set Color For Selected Spaces

Parameters:
ColorIndex

Example:
\[ \text{COL}=5 \]
XIV. CORE
Creates perimeter and core zoning of the current space

Notes:
• Development feature made available on specific request - use with caution as results can be very questionable!

Parameters:
Perimeter depth (in metres)

Example:
```
core=6
```

XV. CORRECTSHELL
Attempt to heal an unclosed shell

Example:
```
correctshell
```

XVI. D
Dragging direction/distance for dragface tool or opening resize

Parameters:
offset

Example:
```
d=-2.4
```

XVII. DEL
delete the selected space(s)

Example:
```
del
```

XVIII. DELCOMPS
Delete all placed components from currently selected spaces
Example:

```
delcomps
```

**XIX. DELMV**

Deletes model variants (Caution must be used as important variants can be lost e.g. proposed and baseline models for PRM)

Example:

```
delmv
```

**XX. DELSURF**

Removes selected surface from zone

Example:

```
delsurf
```

**XXI. DIM**

Show dimensions while drawing space

**Parameters:**

ON/OFF

Example:

```
dim=off
```

**XXII. DUMPCOMPS**

Dump component geometry (placed components) into a GEM file

Example:

```
dumpcomps
```

**XXIII. DUMPNM**

Export the UK NCM Notional Model to GEM file

Example:
XXIV. DUMPRM

Export the UK NCM Reference Model to a GEM file.

Example:

dumpnm

XXV. DV

Depth of view - set view limits from h1 to h2

Parameters:

h1, h2

Example:

dv=3.25, 7.8

XXVI. DX

Set relative position from current position by x and y offset. Or... set displacement to (dx, dy) in move or copy

* In Window/Door/Hole mode set first co-ordinate relative to bottom left corner, then width, height (rectangular mode)

Parameters:

x, y

Example:

dx=20, 10

XXVII. DXF

Show DXF layers window

Example:

dxf
XXVIII. DXFNAMES

Get zone names from DXF file

Example:

```
dxfnames
```

XXIX. FIND

select space by the referenced ID

Parameters:

roomid

Example:

```
find=room0001
```

XXX. FIX

Rounds vertices to a given number of decimal places for selected room(s). Range = 3-6.

Parameters:

precision

Example:

```
fix=6
```

XXXI. G

Define % glazing for selected space

Parameters:

glazing area

Example:

```
g=50
```

XXXII. GW

Define % glazing to Walls only

Parameters:
glazing area

Example:

    g=25

XXXIII. INITZONES

Initialises zone lists (defunct)

Example:

    initzones

XXXIV. INN

Toggle inner-volumes on/off

Parameters:
ON/OFF

Example:

    inn=off

XXXV. INT

Switch intersection check on or off depending on param

Parameters:
ON/OFF

Example:

    INT=OFF

XXXVI. INTBODY

key-in for intersection check on selected zones

Example:

    intbody
XXXVII. INTERSECTION

Switch intersection check on or off depending on param

Parameters:
ON/OFF

Example:

```
intersection=on
```

XXXVIII. LAY

Set Layer For Selected Spaces

Parameters:
LayerIndex

Example:

```
LAY=2
```

XXXIX. LISTCOMPS

List component geometry (placed components) into a text file which is viewed

Example:

```
listcomps
```

XL. MB

set Model Browser switch

Parameters:
on/off

Example:

```
mb=on
```

XLI. MIT

Merge another ModelIT project into this one

Example:
XLII. MODEL

key-in option to perform model consistency check

Example:

model

XLIII. OPEN

Set Openings to new type (i.e. convert Windows to Holes)

Parameters:
W/D/H

Example:

open=w

XLIV. ORIGIN

Centres the model on the grid origin (0,0).

Notes:
- All geometry will be considered and a virtual bounding box will be considered. This bounding box will then be moved to have its centre point at 0,0.
- One or more dimensions can be specified as parameters.
- Calling without parameters is equivalent to 'origin=xy'.

Parameters (optional):
x/y/z

Example:

origin

XLV. OSM

Imports map data from OpenStreetMap and automatically creates geometry.

Notes:
- This key-in is still in development and not a fully supported feature.
- IES do not maintain any of the data on OSM (openstreetmap.org).
Example:

Let's grab a corner of Central Park in New York City, NY, USA.

Once imported to the VE...

And using the model viewer...

**XLVI. P**

Set polar position.

**Parameters:**

x, y
Example:

\[ P=4,5 \]

XLVII. Path

Define a follow-me path to create geometry. Requires at SECTION to have been created first. See [Extrude along a path](#) for more detail.

Example:

```
PATH
```

XLVIII. PSWIN

Place simple openings tool. Used in PLAN view to add windows and doors on to model. Commonly used when tracing over a DXF drawing. See [Draw simple openings in plan view](#) for more detail.

Example:

```
PATH
```

XLIX. REBUILD

Rebuild model adjacencies

Example:

```
rebuild
```

L. RENAME

Rename the selected rooms.

For more detail please see [here](#).

Example:

```
rename
```
LI. RG

Set Room Group for selected zones (browser may not refresh automatically)

Parameters:

- group index

Example:

\[ rg=3 \]

LII. RMD

Remove doors

Example:

\[ rmd \]

LIII. RMDE

Remove doors (external)

Example:

\[ rmde \]

LIV. RMDI

Remove doors (internal)

Example:

\[ rmdi \]

LV. RMH

Remove holes

Example:

\[ rmh \]
LVI. RMHE
Remove holes (external)
Example:
rmhe

LVII. RMHI
Remove holes (internal)
Example:
rmhi

LVIII. RMOPEN
remove all openings of area <= openingArea
Parameters:
openingArea
Example:
RMOPEN=5.5
removes all openings of 5.5m or less

LIX. ROOM
key-in for Geometry Type. Range 1-4.
Parameters:
1/2/3/4
Example:
room=2
sets room to be adjacent building

LX. SECTION
Create a section for use with the path tool.
See Extrude along a path for more detail.
Example:
section
LXI. **SELCOL**
Select all rooms with current colour

**Example:**
```
selcol
```

LXII. **SELLAY**
Select all rooms on current layer

**Example:**
```
sellay
```

LXIII. **SHELL**
Create a single outline shell from all model spaces.
**WARNING:** all assignments and openings will be lost – treat with care!

**Example:**
```
shell
```

LXIV. **SHRINK**
Opens the following dialog window which allows the user to scale the currently selected openings by either as set dimension or by a percentage.
See [Scale selected openings](#) for more detail.

**Example:**
LXV. **SPLIT**

separate connected spaces

Example:

```
split
```

LXVI. **STAMP**

Create an opening stamp from the selected openings. Must be done at opening level. Once stamp has been created it can be pasted anywhere in the model using the “Stamp” option in the openings drop-list. See [Opening stamp tool](#) for more detail.

Example:

```
stamp
```

LXVII. **TEXT**

Show/Hide text on model view. Currently shows ID, name, volume and floor area.

Parameters:

ON/OFF
Example:

```
text=on
```

**LXVIII. TIDY**

Scan selected body to remove colinear vertices, merge coplanar surfaces and find unmatched edges creating polygons to fill gaps

Example:

```
tidy
```

**LXIX. Tidymirror**

Looks at the selected room, and detects surfaces which lie in the same plane, but face in opposite directions (are mirrors of each other). It clips them in relation to other polygons, and then deletes any remaining pairs of mirrored faces facing in opposing directions. These forms of surfaces are usually present in gbXML where there are offshoot floating surfaces outside a room volume, and are effectively a mirror image of each other.

Example:

```
tidymirror
```

**LXX. Tidysurfs**

Calls “tidyunbound” and then “tidymirror”.

Example:

```
tidysurfs
```

**LXXI. Tidyunbound**

Looks at a selected room, detects any surfaces with disconnected edges, and removes the ‘unbound’ surfaces because any disconnected surfaces cannot be part of a volumetrically bound shell. Useful to tidy up some of the more fractured ‘rooms’ that can come from external geometry files.

Example:

```
tidyunbound
```
LXXII. TOOLOFF
Hides all ModelIT toolbars other than the key-in toolbar.

Example:

```
tooloff
```

LXXIII. TOOLON
Shows all ModelIT toolbars that were chosen in preferences.

Example:

```
toolon
```

LXXIV. TOOLRESET
Reset toolbars to default (all visible)

Example:

```
toolreset
```

LXXV. UNDO
Add option to switch off the undo operation in order to speed up response

Parameters:
ON/OFF

Example:

```
undo=on
```

LXXVI. UNITS
key-in option to change the model measurement units i.e. metric (SI) or InchPound(IP).

Parameters:
IP/METRIC

Example:
LXXVII.  VIEWINIT
Set view initialisation to be either late or early (defunct)

Parameters:
LATE/EARLY

Example:
viewinit=late

LXXVIII.  VIS
toggle visibility of selected space(s)

Parameters:
ON/OFF

Example:
vis=on

LXXIX.  VP
set Viewport switch (defunct?)

Parameters:
on/off

Example:
vp=on

LXXX.  X
set the current co-ordinate to be the absolute position x,y

Parameters:
x,y

Example:
X=20,4
LXXXI.  XMLDUMP

Exports Templates, ApacheSystems and Constructions to XML files (not complete)

Example:

```
xml_dump
```

LXXXII.  ZONEID

Toggle to redraw Browser with "ID" rather than "Name" (& vica verca)

Example:

```
zoneid
```