Contents

1 Introduction................................................................................................................................. 3
  1.1 Responsibility......................................................................................................................... 3
  1.2 Copying.................................................................................................................................. 3
2 Testing Features with the Sample Projects............................................................................... 4
3 Playback Controls...................................................................................................................... 5
4 The Project Files....................................................................................................................... 6
5 Other Functions ........................................................................................................................ 7
  5.1 Characteristics....................................................................................................................... 7
  5.2 Testing Routes......................................................................................................................... 7
  5.3 Distance Map........................................................................................................................ 7
6 Modelling an Evacuation with Simulex.................................................................................... 8
  6.1 Floors................................................................................................................................... 8
  6.2 Exits...................................................................................................................................... 11
  6.3 Staircases............................................................................................................................. 12
  6.4 Defining Links...................................................................................................................... 13
  6.5 Calculation of Distance Maps.............................................................................................. 14
  6.6 Defining the Occupants......................................................................................................... 15
7 Simulation.................................................................................................................................. 17
  7.1 Information Window.............................................................................................................. 18
  7.2 Multiple Distance Maps (different routes-to-exit)................................................................. 18
  7.3 Hints for Problem-Free Simulation....................................................................................... 20
8 Main Program Menu ................................................................................................................ 21
  8.1 Menu: Project ....................................................................................................................... 21
    8.1.1 Menu Item: Project > Open ............................................................................................ 21
    8.1.2 Menu Item: Project > Save ......................................................................................... 21
    8.1.3 Menu Item: Project > Save As ....................................................................................... 21
    8.1.4 Menu Item: Project > Close .................................................................................... 22
    8.1.5 Menu Item: Project > Exit ....................................................................................... 22
  8.2 Menu: Building ..................................................................................................................... 23
    8.2.1 Menu Item: Building > Add Floor .................................................................................. 23
    8.2.2 Menu Item: Building > Replace Floor ............................................................................ 24
    8.2.3 Menu Item: Building > Add Staircase .......................................................................... 24
    8.2.4 Menu Item: Building > Change Name .......................................................................... 24
    8.2.5 Menu Item: Building > Change Height ......................................................................... 24
    8.2.6 Menu Item: Building > Delete ..................................................................................... 24
    8.2.7 Menu Item: Building > Add Link ................................................................................ 25
    8.2.8 Menu Item: Building > Delete Link ................................................................................ 25
    8.2.9 Menu Item: Building > Add Exit .................................................................................. 25
    8.2.10 Menu Item: Building > Delete Exit ............................................................................ 26
    8.2.11 Menu Item: DistMap > Setup .................................................................................... 26
    8.2.12 Menu Item: DistMap > Calculate ............................................................................. 26
    8.2.13 Menu Item: DistMap > Display .................................................................................. 26
8.3 Menu: Routes

8.3.1 Menu Item: Routes > Most Remote

8.3.2 Menu Item: Routes > Test Position

8.3.3 Menu Item: Routes > Stop Testing

8.4 Menu: People

8.4.1 Menu Item: People > Single Person

8.4.2 Menu Item: People > Group People

8.4.3 Menu Item: People > Delete All People

8.4.4 Menu Item: People > Characteristics

8.5 Menu: Simulate

8.5.1 Menu Item: Simulate > Begin

8.5.2 Menu Item: Simulate > Playback

8.5.3 Menu Item: Simulate > Playback in 3D

8.5.4 Menu Item: Simulate > Pause

8.5.5 Menu Item: Simulate > Stop

8.6 Menu: Window

8.7 Menu: Help

9 Function Keys

10 Technical Requirements

11 Principles and Assumptions

12 Walking Speeds

13 Body Dimensions

14 Occupant Types

15 Troubleshooting

16 Literature
1 Introduction

Simulex is a computer package for PCs which is able to simulate the escape movement of many people from large, geometrically complex building structures. Simulex allows the user to create a 3-D model of a building by using a number of CAD-designed floor plans, connected by staircases. The user defines ‘final’ external exits just outside the building, and Simulex will automatically calculate all travel distances and routes throughout the building space. Occupants are ‘placed’ into the building, either one-by-one or as groups. When the building population has been defined, and the potential routes calculated, then a simulation can be carried out. The user can view an ‘evacuation’ on-screen and ‘zoom’ in on areas of interest. It is also possible to record a simulation onto hard disk for later ‘real-time’ playback.

The algorithms for the movement of individuals are based on real-life data, collected by using computer-based techniques for the analysis of human movement, observed in real-life footage. Depends on the number of people and the performance of the PC.

1.1 Responsibility

IES Ltd. takes no legal responsibility for the results created with the program by individual users. The user should be familiar with the statutory fire safety regulations concerning evacuation requirements for building design in his/her own country.

1.2 Copying

The program can be used by the license holder only. The license holder is prohibited from any unauthorised distribution of the software. Copying for back-up and security reasons is allowed but any other duplication is strictly prohibited.
2 Testing Features with the Sample Projects

To see the example animation files:

- Download the sample projects and unzip them
- Select Project > Open from the Menu
- Browse to the sample projects and select a *.spj file, then the sample building will appear.
- Select Simulate > Playback, and select the corresponding playback file with the same name as the project.
- The evacuation will start running automatically.
3 Playback Controls

- F2 - Step one frame backwards.
- F3 - Step one frame forward.
- F4 - Reveal properties of person pointed to by mouse.
- F5 - Increase magnification of view in current plan window (zoom-out).
- F6 - Reduce magnification of view in current plan window (zoom-out).
- F7 - Re-centre window about the mouse position.
- F8 - Pause.

Note: Function keys F4 to F7 also work during other function modes. Also, for a function key to work, you may need to click onto a floor or staircase window first.
4 The Project Files

The following project files can be downloaded as a zip which contains the following:

- **1floor**: The project file (1floor.spj) contains the Simulex information for a single-storey building, the route-map and the population. The playback file (1floor.slx) is a pre-recorded playback file of a sample population leaving the single-storey building which you can access by using the menu Simulate > Playback. The results output from this evacuation are stored in 1floor.txt. To view these results, you will need to open the files with any word processor or text editor.

- **2floors**: The project file (2floors.spj) contains information which defines a simple 2-storey building. The playback file (2floors.slx) contains a pre-recorded evacuation file, and the results are stored in 2floors.txt.

- **college**: The project file (college.spj) contains information which defines a more complex 2-storey college building. The playback file (college.slx) contains a pre-recorded evacuation file, and the results are stored in college.txt.
5 Other Functions

5.1 Characteristics
When you have opened up an evacuation project, you can click near a person and press F4, which will reveal more information about that person than can be obtained during playback mode.

5.2 Testing Routes
Select 'Routes > Test Position'. You can use this function to click onto a position in one of the floor plans or staircases & 'drop' a test person in at that location. The test person will then walk out of the building, guided by the default distance map. To stop using the function, just select Routes > Test Position a second time.

5.3 Distance Map
You can display the 'distance map' by selecting 'DistMap » Display' & return to normal view by just selecting the same menu item a second time. The distance map represents a mesh of squares 0.2m x 0.2m in size which is spread over the entire building space. The value of distance-to-exit from the centre of each square is calculated by Simulex. The distance values are shaded in bands of 1 metre, which results in the display of 'distance contours' throughout the building. When a person tries to find a way out of the building then he/she heads at right angles to these contours.

There are a number of functions that you can test out. Just test out different menu items, and have a go. Note that the main principle of constructing a model of a building is to attach different planes together with 'Links'. Look closely at the sample before trying to change the links.
6 Modelling an Evacuation with Simulex

The program shows the evacuation process graphically on the screen, with plan views of individual floors and staircases displayed in separate windows. Graphics representing a plan view of the occupants can be viewed during the whole simulation process. The occupants move towards pre-defined exits, with individual walking velocities dependant upon individual characteristics and the proximity of other people. During a simulated evacuation, the program produces realistic flow rates of 1.1 to 1.4 persons per metre exit width per second, representing a normal adult population under calm conditions.

When all the occupants have moved through the exits, the total evacuation time is displayed on the screen, and a data file for the results is written to disk. The simulation can be recorded onto hard disk to facilitate a later play-back of the simulation. This feature can be very useful for larger simulations because the calculation time can take many hours if thousands of people are modelled. The later play-back can be run almost in real time, depending on the hard access time, CPU speed and graphics performance of your PC.

In the program, three types of windows are present. They are; floor plan windows, staircase windows and an information window containing general information about the simulation. Each floor and each staircase are displayed on separate windows.

6.1 Floors

The first activity to carry out is to create a ‘building’. A building consists of floor pans (imported from CAD files in DXF format) and staircases (defined within Simulex).

To add a floor, you import a DXF drawing file created with a standard CAD program. However, when you create the DXF file you must delete all information which is not relevant to the building shape - only the walls must be left. All other information such as door swing lines, text and other irrelevant lines must be deleted in advance, otherwise the simulation cannot proceed. Simulex uses the wall lines to define the physical space available for evacuation. Building contents can of course exist on the drawings if the location of those are known in advance, but remember that all physical objects are regarded as immovable. Each new floor plan is assigned, and displayed in, a new window. The contents will obstruct the occupants trying to evacuate. A sample screen display from Simulex is displayed below.
It is advisable to frequently save the project file which is done in the Project menu. By saving a project, the floor plan drawings, staircases, connections and all other relevant information will be stored under a separate filename. A project file has the extension *.spj.
To add a floor, use the Menu Item: Building > Add Floor, which activates the DXF filter. You will need to specify the file name and location. Simulex analyses the file, and then will ask you what units the file is stored in, because this information is not specified in the DXF file (see Figure 2). Normally, this will either be meters or inches. To check if you have used the right units of measurements, you should compare the size of the plan when it is drawn in the display window, to the meters scale drawn on all sides of the plan. If it is displayed at the wrong scale, then you will need to delete the floor plan, using Menu Item: Building > Delete, and then re-import the DXF file with a different scale. Usually, when you have found the correct units, this will be okay for all DXF files created on the same CAD package. Once the DXF import has completed you will be presented with the Floor Geometry dialog (see Figure 3). This will display the name of the DXF, how many lines were imported and what elevation (i.e. height) the floor is at. The height is important for viewing your project in 3D (see 8.5.3). A maximum of 100 floors can be added.

The floor plan is now visible as a small icon in the lower left corner of the main window. Double-click on the icon and the floor plan window will open. The drawing can be enlarged or reduced by using the zoom keys F5 and F6, which will zoom in and out. A distance scale is visible around the floor plan showing the distance in metres.
6.2 Exits

The next step is to define the final exits outside a building. Several exits can be inserted into the floor plan windows. The exits are represented by an exit marker looking like a capital I. It is possible to let the occupants choose the exit that is closest to their initial location or to specify their movement to an exit located further away than the closest exit. This choice is enabled by allowing the occupants to use different distance maps, which use different exits.

An exit is defined by using the Menu Item: Building > Add Exit. A dialogue box will appear. The exit can be named by the user. A maximum of 50 exits are allowed in the current version of the program. The width of the exit and on which floor it will be located, are defined by the user. Click OK to confirm the choice. Now, click, using the left mouse button, on the floor plan defined in the dialogue box, to position the exit. It is possible to reposition the exit by using the left button and simply drag it to the correct position. The exit can be rotated by using the right mouse button. An exit should be placed outside a building, preferably at least a metre away from the last doorway, to enable Simulex to model some of the occupant movement after moving through the last door opening, before occupants are removed from the simulation when they arrive at the exit marker.

The procedure is repeated for every new exit to be added. To remove an exit, simply select it and choose Delete Exit from the Building menu. To select an exit, click onto it with the left mouse button. The marked exit is red while all the others are yellow.
6.3 Staircases

If evacuation from a multi-storey building is going to be simulated, then the floors have to be connected to each other by stairs. Staircases are created within Simulex. Add a staircase using the Menu Item: Building > Add Staircase. A maximum of 200 staircases can be used in the current version of Simulex.

The staircase can be assigned a name in the Input Staircase Name dialogue box. Also add the correct length and width of the staircase. The length to be inserted is the true length of the stair measured as the slope length. Stairs with landings have a total length represented by the sum of the sloping parts and the landing.

Spiral stairs are treated in the same way. The width of spiral stairs should be so narrow that overtaking cannot take place. People do not normally overtake on spiral stairs but instead...
normally walk behind each other. All the simulated stairs are presented as straight stairs independent of their actual appearance in the real building.

By double-clicking on the staircase, the size of the border around the staircase can be changed. Normally this border size should be 0.5 m in all directions where occupants are likely to enter the staircase. This is to give people enough space, so that they don’t try to ‘step-off’ the distance map space.

### 6.4 Defining Links

The staircase then has to be connected to the floors with two links, one on each end of the stair. Each link, looking like an upper case T, is actually composed of two parts with the same appearance. One part is placed on the floor and the other on the staircase, forming one link from the floor to the staircase. The link can be added using the Menu Item: Building > Add Link. Choose the name of the link, the width and indicate which floor and staircase the link is going to connect. Confirm the creation of the link by clicking on OK. Position the link on the floor plan by clicking the left mouse button on the location of the link. The button can also be used to reposition the link. The right mouse button will rotate the link. Do the same in the staircase connected to the floor. The link cannot be rotated in a staircase. The vertical part of the T (link) shall, on the floor, be directed towards the stairs and the same goes for the link in the staircase, pointing towards the floor plan, as shown below. No part of the vertical line in the link must cross any of the blue lines indicating the walls of the building.

![Figure 5: Screen display of sample links](image)

The link connecting the staircase and the other floor is performed in the same way. There is no limit to the number of links you can create. A link can be removed by marking it and the choosing the Menu Item: Building > Delete Link. The link is marked by clicking onto it. A marked link is red and all the other links are yellow.

Note that there should be a minimum of 0.5 metres clear space in front of, and behind, a link marker both on floors and staircases. This allows free movement around the link, and ensures that there are no problems when a person’s body is transferred across a link.
6.5 Calculation of Distance Maps

A ‘distance map’ consists of a mesh of 0.2 by 0.2m spatial blocks, which is used to represent a ‘low-resolution’ form of the total building space. The numerical value assigned to each block is equal to the total travel distance to an exit from that block. Simulex is able to calculate a distance map when at least one exit has been defined for a building.

The distance maps are used by the program to direct the occupants to the closest available exit. The maps are calculated by the program before the simulation can start. Different distance maps (maximum 50), can be used with different exits being allowed for use by different occupants. This will allow the user to assign final destination exits to the occupants which are not necessarily the closest ones. This is described in more detail in the section Multiple distance maps.

When all the staircases and exits are in the right positions a distance map can be calculated. This will be executed by commands under the Menu: DistMap. Choose Calculate and indicate which distance map shall be calculated. The default distance map should always be available and should always be calculated even if it is never used. After confirmation with OK the distance map is calculated. Other distance maps can be defined under Setup and having other exits available to use. Whenever a building has changed (i.e. the status of any exit, link, staircase, or floor is altered) then each distance map must be recalculated.

The walking paths in the building can now be tested by using the commands under the Menu: Routes.
6.6 Defining the Occupants

After the distance maps are calculated, the occupants can be added to the building. The occupants can be inserted one by one or as a group. The available commands are located under the Menu: People.

First, the characteristics of the occupants must be defined. This is done in a dialogue box accessed by the Menu Item: People > Characteristics. These characteristics are valid for all occupants defined until new characteristics are entered. In the dialogue box, the type of occupants can be defined. This will affect the size and distribution of the occupants and their maximum individual velocity. It is also possible to define which distance map the next defined occupants will follow. All maps available are displayed even if they are not calculated. Simulating a scenario with occupants following a non-calculated distance map will create a program failure.

The occupant response times are also entered in the Characteristics box. The times are defined by a mean value and the deviation from this mean. The actual times assigned to the occupants will be chosen according to one of three distributions, uniform, triangular or normal distribution, specified by the user. If for example the response times are going to be randomly chosen in the interval 90 to 100 seconds, the mean is 95 seconds and the deviation is 5 seconds and the distribution shall be ‘random’. The response times are assigned in the same way for both a group and a single person.

![Characteristics Dialogue Box](image)

Figure 7: Characteristics Dialogue Box
Characteristics which are defined in the Person Characteristics dialogue box will apply to all newly added people, until the characteristics are changed again.

A single person is defined by choosing the Menu Item: People > Single Person and is positioned on the floors by a click with the left mouse button. The occupants can only be located on areas covered by a distance map. Otherwise an error message will appear.

A group of occupants are defined in the same by choosing Menu Item: People > Group People. By clicking with the left mouse button, point by point, a polygonal area will be defined. Click in that area with the right mouse button and the dialogue box Area Properties will appear. It is now possible to add the number of occupants or to define an occupant density for that area. You can turn off the addition of new people, just by clicking onto the same menu item a second time.
7 Simulation

When all the people are defined and the project file is saved the simulation can begin. Select the Menu Item: Simulate > Begin. A dialogue box will appear and ask whether the simulation shall be recorded for later play-back. This feature works like a tape-recorder. Choose Yes and define the filename of the play-back file, which shall have the extension .SLX. Be aware that the .SLX files can reach significant sizes, depending on the size of the population and the evacuation time.

The simulation of large numbers of people can take a long time (sometimes many hours), depending on the speed of your PC. If you are simulating the evacuation of a large, crowded population you may need to let the calculation run overnight or at a weekend, and then play back the recorded evacuation at a later time. Note that the playback files can become very sizeable for large populations. For example if 200 people leave within 2 minutes, then the playback file may only be 3 - 5 Mb, but if you are modelling the movement of thousands of people the playback may be greater than 50Mb.

As the evacuation progresses, you will see people progressing towards exits, in simulated movement steps of 0.1 seconds. The number of people and simulation time are updated every 0.1 seconds in the Information Window.

![Figure 9: Sample screen display of a crowded area](image)

The response of the program may slow down if many people are being modelled. This is because Simulex only process Windows messages (commands) after each single time-step calculation is completed for the whole population. You will notice this effect especially when you have large, crowded populations. To pause a simulation, just click once onto the Simulation menu, and wait for it to respond - it will usually respond when it has finished one calculation step for the whole population. The best way to interrupt a simulation is to make sure that a
floor plan or staircase window is the currently focused window, and press F8. The evacuation will pause when the next time-step calculation is finished. The processing of Windows commands is slowed down to try to make Simulex calculations as fast and uninterrupted as possible.

When the simulation is finished the total evacuation time is displayed together with a question asking if an output file shall be created. This file, a normal text-file, contains basic data about the simulation such as the total evacuation time, number of persons on each floor, number of exits, etc. The output file has the extension *.txt and can be read by all word processors.

The play-back of a simulation can be performed by choosing the Menu Item: Simulate > Playback. The play-back will be performed in almost real time depending on the performance of your PC. It is also possible to play the file step by step forward or backward. Choose Pause and the sequence stops. By using the function keys F2 and F3 the recording can take one step back or forward at the time. Each step is 0.1 second.

7.1 Information Window

For every project, an information window is available showing the most relevant data about the simulation. The information shown in the window depends on which is the currently viewed floor or staircase window. The upper part of the information window displays general information about the simulation such as number of floors and persons. The lower part contains information relevant to the active window such as size of the floor, links and exits and the marker position on the screen.

In the information window, information about the number of persons left in the building during simulation is displayed together with the actual simulation time. This information is only displayed during simulation or during play-back. Therefore, it is convenient to have the information window open in the background during simulation so the time is visible.

7.2 Multiple Distance Maps (different routes-to-exit)

If only one (default) distance map is used then the occupants will always move towards the nearest exit. In certain situations, then a more realistic scenario may be desired - where some people may ignore the nearest emergency exit and instead leave the building by the same route that they came in. In order that you can be given some control over the routes that the occupants take, then Simulex allows you to create up to 10 different (route) distance maps in memory. The normal way of using this facility is to first define a ‘default’ distance map which uses all the exits, and then create other distance maps afterwards, with each distance map using only a selection of the exits that the default distance map uses. Later, when specifying occupant characteristics you can specify which distance map a person will use.

As a general guide, the following steps should be taken:

1. Define all the exits and links which are going to be used in a simulation.
2. Choose Setup... in the DistMap menu. Use ‘Change’ to specify the exits to be used in a default distance map. Use the Menu Item: DistMap > Calculate to calculate the default distance map.
3. Use the Menu Item: DistMap > Setup, and Add a new Distance Map. This time, specify the exits that you wish to be used in this new distance map. Afterwards, calculate the distance map.
4. Step 3 can be done up to 9 times, to create different sets of escape routes throughout the building space. If you have limited memory on your PC, however, then you may find that you get an error warning which prevents you from calculating any more distance.
maps, after a certain number of maps have been calculated. As a guide, 1 square metre of a distance map occupies 100 bytes in memory.

Note always calculate all distance maps after changing any aspect of the building, such as exit positions, link positions, floor plans or staircases. Changing the building invalidates previously calculated distance maps, and if occupants attempt to use an invalid map, then an error will occur. When you need to check which distance maps are valid, use the Menu Item: DistMap > Display - all valid distance maps will be displayed as available, and the invalid ones will be coloured grey.
7.3 Hints for Problem-Free Simulation

Save the project file often during the setup procedure.

Always recalculate all distance maps after changing any attributes of the physical building space, links or exits. In other words, don’t bother creating distance maps until you are happy that you have finished altering the building.

Define the possible (immovable) furniture according to where it is likely to be located. Obstruction by furniture and other obstacles can be simulated. These are defined in the CAD program prior to exporting the *.dxf file to Simulex. Avoid locating furniture so that only narrow gaps are available for movement. If narrow gaps (less than 0.55 metres) are created it is possible that the distance may find a way through, but the physical size of a person will prevent him/her from getting through the gap.
8 Main Program Menu

The following sections give descriptions of all menu items available within Simulex.

8.1 Menu: Project

A ‘Project’ describes all important aspects of a defined building and consists of the following data:

- The dimensions and defining lines for each floor and staircase.
- Data for all exits and the links between different windows (floors & stairs).
- Information about each distance map.
- Data concerning the building population that has been defined.
- The size, position and status of each viewing window.

The data for each project is stored in a project file, which can be saved, loaded and changed.

Note the current project must be closed before a new one can be opened. Simulex cannot handle multiple projects simultaneously.

Menu Items: Open, Save, Save As, Close, Exit

8.1.1 Menu Item: Project > Open

This opens a project file from disk. When loaded, the previous state of all windows and icons will be restored to the same status as when the project was last saved. If the video resolution has been changed and the windows cannot all be seen, then use the Cascade or Tile command, and readjust the positions.

8.1.2 Menu Item: Project > Save

This saves the currently opened project to disk. The status and positions of all windows are saved.

8.1.3 Menu Item: Project > Save As

This saves the currently opened project to disk with a new name. The status and positions of all windows are saved.
8.1.4 Menu Item: Project > Close

Closes the current project and frees all previously allocated memory. Also, the state of the viewing windows and window icons are saved automatically to the project file. This command must be used before opening a new project.

8.1.5 Menu Item: Project > Exit

Exits Simulex, closes the current project and frees all reserved memory. Also, the state of the viewing windows and window icons are saved automatically to the project file.
8.2 Menu: Building

A model ‘building’ consists of the following:

- Floor plans: defined by the importing of CAD-based DXF format drawing files.
- Staircases: defined within Simulex as linear ‘vertical corridors’ to represent the simplified geometry of a normal staircase.
- Links: which connect different floors and staircases together to create a connected 2D representation of a 3D building.
- Exits: represent lines of final destination for the occupants, usually only used outside the external envelope of a building. When a ‘person’ reaches an exit he/she is removed from the simulation.

Menu items: Add Floor, Replace Floor, Add Staircase, Change Name, Delete, Add Link, Delete Link, Add Exit, Delete Exit

8.2.1 Menu Item: Building > Add Floor

This command allows the user to import a new floor plan, and add it to the current ‘building’. The plan must have been previously defined with a standard CAD package, and exported in DXF format.

Specify the file which is to be imported with the ‘Open Floor File’ dialogue box. You will also be asked to type in a name that you wish to act as a title for this new floor. Simulex will analyse the data in the file. You will then be asked to specify a scaling factor for the DXF file (metres, inches, feet etc.) because the DXF format does not contain unit scaling information. Usually the correct setting will be metres, but some CAD packages use default units of inches, feet or millimetres.

When a new floor plan is successfully imported, a new window is created, and the floor plan is displayed when the window is opened. You will notice a linear scale in metres around the perimeter space which encompasses each plan. If you have specified an incorrect scaling factor when importing the DXF file, then the plan will appear with an incorrect size, compared with the scale at the edges. If this is the case you will need to delete this current (incorrect) floor and add it again using the method described above.

It is important to note that usually the same scaling factor will apply each time when you use files created with the same CAD package.

Note: when you double click into a floor window with the mouse, a dialogue box will appear which allows you to add additional perimeter space around a building. This perimeter space
should be a minimum of 0.5 metres in all directions if any links are later inserted near the perimeter.

8.2.2 Menu Item: Building > Replace Floor

This command enables the user to replace a floor with a new DXF file, using the same method as described for the menu item: Building > Add Floor. The wall and building lines are deleted for the old floor and the lines for the new floor plan are used to replace the old ones. All exit, link and person data is maintained.

This command is very useful if you which to make changes to one floor plan after a problem has come to light during the distance mapping, route testing or simulation stages.

You need to make the changes to the DXF file with a CAD package, and import it back into the current building, into the same floor, using this command.

8.2.3 Menu Item: Building > Add Staircase

This command allows the user to add a new staircase to the current building.

You will need to specify the name that you wish to act as a title for this new staircase. Then, you will be asked to specify the length and width of the staircase.

The measured stair length follows a line which runs along the longitudinal centre of the treads of each flight, and through the centre of any intermediate landings. The length represents the ‘mean’ travel length for occupants walking up or down the staircase. Therefore, total staircase length consists of the sum of the ‘flight’ lengths and ‘landing’ lengths. The ‘flight’ length is measured in the same plane as the rake of the stairs, centrally between any handrails. The mean (horizontal) length of the landing(s) is added to this total length.

The best way to envisage the measured stair length is to follow a line that a person would take when walking from top to bottom of the staircase, maintaining a perfect central position between handrails and walls all the way down.

When a staircase has been added, a new window in which the staircase will be displayed, is created, and will appear as an icon in the main window.

Important note: when you double click into a staircase window with the mouse, a dialogue box will appear which allows you to add additional perimeter space around the outside of the staircase. This perimeter space should be a minimum of 0.5 metres in all directions.

8.2.4 Menu Item: Building > Change Name

This command allows the user to change the title of the currently active floor or staircase window.

8.2.5 Menu Item: Building > Change Height

This command allows you to alter the height at which the currently active floor will be viewed in 3D (see 8.5.3).

8.2.6 Menu Item: Building > Delete

This command allows the user to delete the currently active floor or staircase window. Upon execution of this command, all exits and links which are contained within the active window are also deleted.
8.2.7 Menu Item: Building > Add Link

This command allows the user to add a new link between 2 windows (floor and staircase). A dialogue box will appear, to enable you to specify the following:

- Which staircase the link will connect to.
- Which floor the link will connect to.
- The name to be assigned to the link (preferably no more than 10 characters).
- The width of the link. The width of the link will be equal to the exact width of the doorway opening into the staircase.

After being added, the link must then be positioned in the two windows. You should activate the floor and stair windows in turn, and then click onto a position in the floor or stair plan, with the left mouse button. A T-shaped link marker will appear in the window. You can click-onto this link marker with the mouse and drag it to any position in the specified window.

In floor windows, you can click onto the link marker with the left mouse button and drag the marker to the correct position. You can click onto the link marker with the right mouse button to rotate the marker. Link markers on floor plans must be positioned accurately between the edges of the surrounding door frame or opening. Look at the sample projects for examples of link positioning, where the immediate geometry of link markers are the same in a staircase and floor plan (i.e. the marker edges are adjacent to the end of a wall or solid object).

In stair windows, the markers cannot be rotated because they appear in the outline of the staircase and are used to create an opening or doorway in the wall perimeter. The marker is automatically aligned with the line of the staircase wall.

After a link has been created, the link marker positions can be adjusted at any later time by using the left and right mouse buttons to ‘click-and-drag’ the marker to the new position.

Note the stem of the T-shaped marker should be positioned on the outside of the normal circulation space, such that people will enter and emerge from the link on the ‘flat’ side of the marker.

8.2.8 Menu Item: Building > Delete Link

A ‘current’ link is selected by clicking onto it with the left mouse button.

This command deletes the currently selected link from the two windows in which it appears.

8.2.9 Menu Item: Building > Add Exit

This command adds a line of final exit to a building. An exit can be added to either a floor or staircase but normally exits are not added to staircases. The location, name and width of an exit line can be specified in the dialogue box which appears. The user should then click into the window which is to contain the exit line. When the mouse points to a valid area of the floor/staircase, an exit line will appear when you click the left mouse button. You can ‘click-and-drag’ the exit with the left mouse button, and rotate it by using the right mouse button.
8.2.10 Menu Item: Building > Delete Exit

A ‘current’ exit is selected by clicking onto it with the left mouse button. This command deletes the currently selected exit from the window in which it appears.

Menu: DistMap

This menu enables the creation and manipulation of ‘distance maps’, which are used to calculate the potential escape routes for occupants travelling through a building. The use of different distance maps enables the use of different possible escape routes by different occupants throughout the building.

A ‘distance map’ consists of a mesh of 0.2 by 0.2m spatial blocks, which is used to represent a ‘low-resolution’ form of the total building space. The numerical value assigned to each block is equal to the total travel distance to an exit from that block. Simulex is able to calculate a distance map when at least one exit has been defined for a building.

When the distance map has been calculated, you can view it as a series of coloured contours where each contour represents an increment of 1 metre distance-to-exit. Up to 10 distance maps can be created, and you can specify different final exits to be used for different maps.

Note: you should position all exits in the correct place before creating a distance map. Then during the setup stage, you can specify which exits are to be used as valid exits for each distance map.

Menu Items: Setup, Calculate, Display

8.2.11 Menu Item: DistMap > Setup

This command allows you to add new distance maps, delete unwanted maps and change existing ones. If you want to change a map, you can specify which exits are to be used as valid exits for each distance map.

See also: Calculation of Distance Maps, Multiple Distance Maps (different routes-to-exit).

8.2.12 Menu Item: DistMap > Calculate

This command tells Simulex to calculate a specific distance map, which has been defined in the setup procedure.

Note for large and multiple-level distance maps, the calculation procedure can take some time. An hour-glass mouse pointer appears at first, while Simulex writes all wall positions into the corresponding spatial blocks, and defines these blocks to be ‘solid’. Then, a dialogue box appears which tells you how far the distance calculation procedure has progressed.

8.2.13 Menu Item: DistMap > Display

This command displays a specific distance map in the currently viewed windows. Each coloured band represents an increment of 1 metre distance-to-exit.
8.3 Menu: Routes

This menu allows you to test out specific routes-to-exit in a building using a specific distance map.

When a distance map has been specified, then you just click onto a position anywhere in the building, and Simulex will place a ‘person’ at that position. The ‘person’ will then walk out of the building and you can view the progress through the current windows. The distance travelled is displayed in the information window. The testing of routes must be stopped with the bottom menu item if you wish to resume any other functions.

Menu Items: Most Remote, Test Position, Stop Testing

8.3.1 Menu Item: Routes > Most Remote

This command places a person at the location in the building which has the highest value for distance-to-exit, and illustrates that person walking out of the building. The distance travelled is displayed in the information window.

8.3.2 Menu Item: Routes > Test Position

Allows the user to click onto a location in the building, and watch that person walk out to the nearest exit in the assigned distance map. The distance travelled is displayed in the information window.

8.3.3 Menu Item: Routes > Stop Testing

Stops all routes testing procedures, and allows you to use the other functions once more.

8.4 Menu: People

This menu allows you to define a building population. You need to check that the characteristics are set to the correct values before defining the population.

Menu Items: Single Person, Group People, Delete All People, Characteristics

8.4.1 Menu Item: People > Single Person

This command allows the user to ‘click’ into a floor or staircase window, and place a person at the position clicked onto by the mouse. The orientation of the person is random & all characteristics are governed by the settings defined in the Menu Item: People > Characteristics dialogue box.
8.4.2 Menu Item: People > Group People

This command allows the user to define a group of people spread in a regular grid over a defined area of the building. You click onto different points to create a polygonal area which defines the boundary within which people will be placed. Use the following method:

1. Use the left mouse button to insert a new polygonal point.
2. Press SHIFT+left mouse button to adjust an existing point.
3. Press CTRL+left mouse button to add another point in between existing points.
4. Press the right mouse button with the mouse pointer inside the polygon to complete the definition of the area.

When an area has been defined a dialogue box will appear which will allow you to add a specific number of people, delete people within the polygon, and add a group with a specific density. Note that the number of people added may not be exactly the number specified. This is because Simulex attempts to distribute the people in a regular grid pattern, and may need to adjust the number by a small amount to make the grid fit in the area. The program tells you exactly how many people have been added. Note also that the area of the defined polygon is displayed at the top of the Area Properties dialogue box.

8.4.3 Menu Item: People > Delete All People

This command deletes the entire building population.

8.4.4 Menu Item: People > Characteristics

This command allows you to define the characteristics of individuals or groups of people. The following characteristics can be specified:

1. The body type (will govern the dimensions of the bodies).
2. The distance map (will govern which route-to-exit the occupant(s) take).
3. The response time. This is defined by using one of 3 distributions, with you specifying the mean response time, and the limits (plus or minus a specified amount from the mean) within which the distribution will lie. If random distribution is chosen, then the response times will be distributed randomly amongst between the limits. Triangular Distribution and Normal Distribution also involve random distribution, but the speeds are distributed with a weighting to create the specified distribution type. In the case of the normal distribution, the plus / minus limits represent a value of 3 standard deviations from the mean.

The characteristic settings remain in place for any number of groups and individuals defined afterwards, until you want to change them again with this menu item.
8.5 Menu: Simulate

This menu allows you to model the evacuation procedure, or replay a previously stored evacuation.

Menu Items: Begin, Playback, Pause, Stop

8.5.1 Menu Item: Simulate > Begin

Initiates the simulation procedure, and allows you to record the simulation to hard disk (recommended) to be played back for later viewing.

The simulation of large numbers of people can take a long time (sometimes many hours), depending on the speed of your PC. If you are simulating the evacuation of a large, crowded population you may need to let the calculation run overnight or at a weekend, and then play back the recorded evacuation at a later time. Note that the playback files can become very sizeable for large populations. For example if 200 people leave within 2 minutes, then the playback file may only be 3 - 5 Mb, but if you are modelling the movement of thousands of people the playback may be greater than 50Mb.

As the evacuation progresses, you will see people progressing towards exits, in simulated movement steps of 0.1 seconds. The number of people and simulation time are updated every 0.1 seconds in the Information Window. Refer to the function keys section for additional viewing and pausing procedures during the simulation process.

8.5.2 Menu Item: Simulate > Playback

This command allows you to replay a playback *.slx file from hard-disk. Simulex attempts to animate the evacuation at real-time, but the playback may be slowed down if there is a very large population. Playback also depends on the speed of your processor and hard disk access. Refer to the function keys section for additional viewing, pausing, and single-frame steps during the playback procedure.

8.5.3 Menu Item: Simulate > Playback in 3D

This command allows you to view your project file and playback the simulation (.slx) files in 3D. It enables you to animate occupant movement on each floor of your building, while allowing you to fly around the building or separate the floors for easier visual analysis. The height at which each floor is initially displayed is determined during the DXF import process. You can however adjust the height via the Change Height option (see 8.2.5). For more information on how to use the viewer please refer to documentation here. Please be aware that old project files will need upgrading and simulations rerun in order to use the new viewer.

Notes: This menu option is only available when the Model Viewer has been installed.
8.5.4 Menu Item: Simulate > Pause

This pauses the simulation so that you can look around the building to check the progress of the evacuating population during a simulation or playback procedure. Refer to the function keys section for additional viewing, pausing, and single-frame steps during the playback procedure.

8.5.5 Menu Item: Simulate > Stop

This command terminates a simulation or playback procedure. Refer to the function keys section for additional viewing, pausing, and single-frame steps during the playback procedure.

8.6 Menu: Window

<table>
<thead>
<tr>
<th>Cascade</th>
<th>Tile</th>
<th>Arrange Icons</th>
</tr>
</thead>
</table>

This menu allows the type of manipulation of windows and icons which is normal for packages with multiple windows, such as Program Manager.

Menu Items: Cascade, Tile, Arrange Icons

8.7 Menu: Help

<table>
<thead>
<tr>
<th>Manual</th>
<th>About...</th>
</tr>
</thead>
</table>

The Help > Manual command will call the full on-line manual.

The Help > About command will display some general information about this version of Simulex.
9 Function Keys

Some commands are available only by using the function keys. The active function keys are:

- Step one frame backwards during play-back, 0.1 second.
- Step one frame forwards during play-back, 0.1 second.

Shows the characteristics of the person pointed at with the mouse. The person must be in the active window.

- Zoom in - the picture will be more detailed.
- Zoom out - better overview.

Moves the picture so it centralises around the mouse. Works only when the drawing is larger than the open window.

- ‘Pause’ in the simulation or in the play-back.

To use these function keys, the currently active viewing window must be a stair or floor window. The action is then relevant to that window.
10 Technical Requirements

The minimum requirement is a PC with a Pentium processor and at least 8 Mb internal memory (RAM). For larger simulations with a large occupancy load and an extended building, it is recommended to use a computer with a Pentium processor of at least 133 MHz and 32 Mb RAM.
11 Principles and Assumptions

Simulex makes a number of principle assumptions about the geometry of escape and methods of individual movement:

1. Each person is assigned a normal, unimpeded walking speed.
2. Walking speeds are reduced as people get closer together.
3. Each person heads towards an exit by taking a direction which is at right angles to the contours shown on the chosen distance map.
4. Overtaking, body rotation, sideways stepping and small degrees of back-stepping are all accommodated.
12 Walking Speeds

Figure 10: The relationship between walking velocity and inter-person distance

The walking velocity for a person is dependant on the forward linear distance (proximity) to people ahead. One person in front of another will reduce the velocity for the person in question, as shown in the Figure 10. Inter-person distance is defined (in this case) as the distance between the centres of the bodies of two people.

The velocity in stairs is reduced compared to the velocity for horizontal surfaces. The velocity descending a stair will be 0.5 times the horizontal velocity. Ascending a stair will take place with a velocity of 0.35 times the horizontal velocity. The normal unimpeded walking velocity for each person will be randomly chosen in the interval between 0.8 - 1.7 m/s.
13 Body Dimensions

The plan view representation of the ‘body’ of each person is represented mathematically as three circles. The diagram below illustrates the central ‘torso’ circle with radius $R(t)$, and the 2 shoulder circles with radius $R(s)$. The offset of the centre of the shoulder circle from the centre of the body is $S$ metres.

![Diagram of body dimensions](image)

Figure 11: The Definition of a ‘Body’ within Simulex

Simulex contains different body types, containing the dimensions (in metres) given in the following table:

<table>
<thead>
<tr>
<th>Body Type</th>
<th>$R_b$ (m)</th>
<th>$R_t$ (m)</th>
<th>$R_s$ (m)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Median</td>
<td>0.25</td>
<td>0.15</td>
<td>0.10</td>
</tr>
<tr>
<td>Adult Male</td>
<td>0.27</td>
<td>0.16</td>
<td>0.10</td>
</tr>
<tr>
<td>Adult Female</td>
<td>0.24</td>
<td>0.14</td>
<td>0.09</td>
</tr>
<tr>
<td>Child</td>
<td>0.21</td>
<td>0.12</td>
<td>0.07</td>
</tr>
<tr>
<td>Elderly</td>
<td>0.25</td>
<td>0.15</td>
<td>0.09</td>
</tr>
<tr>
<td>NFPA-1 m/s</td>
<td>0.25</td>
<td>0.15</td>
<td>0.10</td>
</tr>
<tr>
<td>SFPE-1.4 m/s</td>
<td>0.25</td>
<td>0.15</td>
<td>0.10</td>
</tr>
<tr>
<td>SFV-1.2m/s</td>
<td>0.25</td>
<td>0.16</td>
<td>0.10</td>
</tr>
<tr>
<td>SFV-1.2m/s (+jacket)</td>
<td>0.25</td>
<td>0.235</td>
<td>0.10</td>
</tr>
</tbody>
</table>

Table 1: Body dimensions for the body types in Simulex
14 Occupant Types

When you add a group of people, the occupancy type that you select will govern the distribution of body sizes that are assigned to the individuals in the group. The percentage distribution of different body types for different occupant groups are given in the table below.

<table>
<thead>
<tr>
<th>Occupant Type</th>
<th>%’Average’</th>
<th>%’Male’</th>
<th>%’Female’</th>
<th>%’Child’</th>
</tr>
</thead>
<tbody>
<tr>
<td>Office Staff</td>
<td>30</td>
<td>40</td>
<td>30</td>
<td>0</td>
</tr>
<tr>
<td>Commuters</td>
<td>30</td>
<td>30</td>
<td>30</td>
<td>10</td>
</tr>
<tr>
<td>Shoppers</td>
<td>30</td>
<td>20</td>
<td>30</td>
<td>20</td>
</tr>
<tr>
<td>School Children</td>
<td>10</td>
<td>10</td>
<td>10</td>
<td>70</td>
</tr>
<tr>
<td>Elderly</td>
<td>50</td>
<td>20</td>
<td>30</td>
<td>0</td>
</tr>
<tr>
<td>All Male</td>
<td>100</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>All Female</td>
<td>0</td>
<td>0</td>
<td>100</td>
<td>0</td>
</tr>
<tr>
<td>All Children</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>100</td>
</tr>
</tbody>
</table>

Table 2: Distribution of body types for different occupant groups
15 Troubleshooting

Some commonly encountered problems:

1. An error occurs when a person tries to assess his/her route-to-exit. Using multiple distance maps, make sure that those used by the occupants are always calculated. You should do a quick test of each distance map before executing a simulation (Menu Item: Routes > Test Position). Alternatively, if you have replaced a floor, with a new layout, and maintained the same occupant positions, it is possible that a body may now be inside a wall. Check the area that has changed for any potential solid object/person position conflicts. If you have reduced the perimeter space of a distance map, then check that there were no people present in the old space that has now been deleted. In all cases, you should delete the person whose position is invalid.

2. People are jamming close to links. Note that there must be enough space around the link for people to move around, behind and in front of the link. There should be a minimum of 0.5 metres clear space behind and in front of a link. You may need to delete some lines from the source DXF file, to delete any obstruction test the new link position by using Test Position under the Routes menu. Also, remember that the edges of a link are used to define the edges of a doorway into a staircase. The corresponding link marker on a floor plan MUST also have solid wall lines which go up to and stop at the edges of the link marker. Remember that peoples’ positions are being transferred across the link, so a different immediate geometry around the opening will cause problems.

3. An error message appears saying that a link cannot transfer information - the link is located in a faulty place. No part of the link marker must cross any of the blue lines indicating a wall obstruction. The link must fit in the opening to the staircase. Remember that link markers on floor plans must be positioned accurately between the edges of the surrounding door frame or opening. Look at the sample projects for examples of link positioning.

4. An error message tells you that not enough memory is available to calculate another distance map. You probably have a large, multi-level building, and simply do not have enough memory in your computer to be able to model a building of this size with more than 1 or 2 distance maps. Remember that each 1 square metre of distance map occupies 100 bytes in memory, so a single distance map with dimensions 100 metres by 100 metres occupies 1Mb in memory.

5. A person tries to walk through a space that is too small for his/her body. You will need to either increase the width of the opening, or close it off in new DXF file. Simulex tries to close these narrow gaps, but the ability of people to get through the gaps depends on individual body sizes, so this may happen sometimes with openings less than 0.6 metres wide.

6. You cannot place a person into a particular place in the building. Either you haven’t calculated any distance maps, or you are trying to place a person into a space which the distance mapping functions have identified as too narrow for the distance mapping to work. You may need to widen the space available.

7. The menu commands are very slow to respond during a simulation. This is due to the fact that Simulex only process Windows messages (commands) after each single time-step calculation is completed for the whole population. You will notice this effect especially when you have large, crowded populations. To pause a simulation, just click once onto the Simulation menu, and wait for it to respond - it will usually respond when
it has finished one calculation step for the whole population. The best way to interrupt a simulation is to make sure that a floor plan or staircase window is the currently focused window, and press F8. The evacuation will pause when the next time-step calculation is finished. The processing of Windows commands is slowed down to try to make Simulex calculations as fast and uninterrupted as possible.

8. Not all of the walls are drawn on the screen. Very few types of video card (usually integrated video capture & mjpe cards) do not appear to properly support Microsoft’s ROP2 graphics mode, which Simulex uses. The only card this has been encountered on so far is the MiroVideo TD Live TV integrated capture & compression video card. The only solution is to use another, more conventional video card.
16 Literature


