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Release 2024.0.0 – January 2024 

New login Mechanism 

iCD was updated to make use of the Azure B2C authentication system as well as the new IES 

MyLicensing platform to manage licensing and authentication. 

As a result, a new login interface was implemented in iCD to allow the user with a valid license to 

activate the iCD plugin in SketchUp. 

When iCD is launched for the first time, the toolbar will be grey and inactive as long as the user’s 

license has not been validated. The only available icons when the user is not yet logged in are the My 

IES Account icon and the Help icon. 

The My IES Account icon opens the dialog that allows the user to login 

 

This opens the My IES Account dialog 

 

After having clicked login, the user is navigated to the IES login page in their browser to enter their 

credential. 

 

Once validated, the user can close the browser. The My IES Account dialog is updated with user license 

information. 



 

 

 

Simulation improvement: Roof-space 

In iCD, when a building’s Roof type attribute is set to either Gable or Hipped, the building is 

modelled with a roof space on top of the last floor. 

As part of this release, an improvement has been made to how the roof spaces are modelled to 

better take into account theses spaces within iCD simulation. 

Important notes:  

- These roof spaces cannot be edited (using attributes) and are always assumed unoccupied 

and un-conditioned. 

- This update introduces a change in the simulation behaviour and user can expect different 

simulation results with this release if compared to simulation using an older version of iCD.  

For more information please refer to our FAQ 

https://www.iesve.com/support/icd/knowledgebase_faq  

 

 

  

https://www.iesve.com/support/icd/knowledgebase_faq


 

Release 2023.1.0 – September 2023 
 

Synchronisation of iCD models to IES iRoadmap 

iCD was updated to use the new authentication mechanism which allows iCD users to create project 

in iRoadmap from their iCD model using the synchronisation functionality. 

Similar to how user can currently create projects in iCIM from iCD and keep their models 

synchronised between the two applications, iCD users can add their iRoadmap endpoints, 

synchronise their iCD model to iRoadmap and use them as baseline models for their decarbonisation 

road mapping project.  

To set your iRoadmap endpoint in iCD, the process is identical to adding an iCIM endpoint: 

Open the synchronisation dialog via the button in the toolbar. 

 

In the “manage” menu add the URL to the iRoadMap deployment 

 

Once the endpoint saved, you can create a new iRoadmap project or synchronise your iCD model to 

an existing iRoadMap project using the synchronisation dialog 

 

Bug fixing and upgrade 

Fix on data painter 

Fix on data painter was incorporated to prevent from potential accidental object duplication in the 

model. 

Integrated engine 

The iCD integrated engine was updated to use the latest version of the Model Translation Engine 

(MTE 0.27.2) 

 



 

 

 

  



 

Release 2023.0.1 – April 2023 

Bug fixing 

Bug introduced in the latest release resulted in some models ending up in a corrupt state (related to 

roof surface). 

This bug has been fixed as part of this release 

  



 

Release 2023.0 – March 2023 

Create tool 

The create tool was re-designed and improved to retain previous user settings 

 

 

Computer and lighting max power consumption fixes 

Recently introduced attributes Computer Max Power Consumption, Lighting Max Power 

Consumption and Process Load Max Power Consumption were fixed and now trigger the right 

Apache input and have the expected behaviour for simulation.  

 

iCD plugin supported by SketchUp 2023 

iCD is now compatible with SketchUp2023. 

 

ICD integrated engine update 

iCD integrated simulation engine has been updated. 

The use of the new version of the integrated engine removes the error previously seen when editing 

a U-value. 

 

U-values can now be set within these ranges: 



 

 

 

  



 

Release 2022.3.0 – October 2023 

New Object selection filter (Locate entity Dialog) 

The locate entity functionality was re-worked in order to allow the user to easily find and select 

objects in iCD based on their attributes’ values. 

To use the new object selection tool, click on the Locate Entity icon in the toolbar  

 

It opens the Filter object dialog 

In this dialog, you can select the object type you want to research 

Then: 

- select the attribute to filter your selection  

- The operator or the condition 

- And finally, the value targeted for the filter 

Ex: below the filter will selects all buildings which have the attribute Building Storey height greater 

than 4m. 

 

By clicking the +Add button, it is possible to narrow down the selection by adding more conditions 

or operators with an “And” predicate 

Ex: below the filter will select all buildings that have a Building storey height greater than 4m and 

that have a primary use set to Apartment. 



 

 

Once the filter is set, clicking “Select from Filter” will select all the objects in the model that match 

the filter conditions. 

“Zoom to selection” sets the zoom to view all the selected objects. 

 

Query Tool and Visualisation tool update 

iCD allows now users to open the Query tool (Edit object dialog) when the Visualisation tool is on. 

This allows the user to edit objects attributes while visualising the data visualisation overlay and 

facilitate which building to edit when modifying your model manually 



 

 

 

  



 

Release 2022.2.0 – July 2022 

Incorporation of the iCD integrated engine (MTE) 

The iCD integrated engine is a simulation engine embedded in the in the ICD. It gives the users the 

option to use IES simulation engine Apache if a user does not have the VE installed on his machine. 

The iCD integrated engine is now the default simulation engine in iCD. To change the simulation 

engine back to the VE can go back to: 

Extension > IES iCD > Preferences > Templates and Units Energy simulation engine, and select the 

simulation engine from the drop-down menu 

 

Using the iCD integrated engine gives the user access to additional attributes that allow him to enter 

inputs with more details. 

These additional attributes can be found in the query tool under the category Advanced – MISC 

These attributes have dynamic default values that automatically update when changing template 

values which also gives the user more visibility on the used inputs in the simulation. 

These values are editable by the user. 



 

  

 

 

 

 



 

Time dimension input in the query tool 

The way to input data over multiple years in the query tool has been updated and made easier for 

users. 

Now a clock icon appears when hovering on an attribute’s value. Clicking this clock opens a dialog 

which allows to set the values for this attribute for multiple years. 

 

 

 

SHP file import dialog re-shape 

The SHP file import dialog was aligned to the Geojson import dialog and now gives the same options 

to the user to: 

- Match SHP files fields to iCD attributes 

- Allow the user to select the imported object type and import point objects 



 

 

 

Simulation results sent as aggregated timeseries to iSCAN 

iCD gives the user the possibility to export to iSCAN simulation results as hourly timeseries. The new 

functionality now offers to aggregate each variable across a group of simulated buildings and export 

them into a single channel in iSCAN. 

As a result, now for each variable, instead of exporting one channel per building, the user can export 

a single channel for all the simulated buildings. This facilitate the use of iSCAN channels for later use 

in iSCAN and iVN. 

To export simulation results as aggregated time series, the user needs to:  

- Go to the simulation launcher 

- Under IES iSCAN Export tick the “Export Simulation results as aggregated timeseries” 

 

 



 

Simulation in Batches 

Simulations can now be run in batches. This means that the user can specify the amount of buildings 

to simulated in one group.  

This functionality can be particularly useful when simulating a large number of buildings: with this 

functionality, the simulation can be broken down into smaller batches preventing potential 

simulation failure to impact the entire model and only the batch the failure happened on. The other 

batch will simulate even if one batch fails 

 

To simulate you model in batches the user can go to the simulation launcher > Simulation Batches > 

tick the Run simulation in batches tickbox > select the maximum number of building each batch will 

contain. 

In the example below the selection will be simulated by groups of 25 buildings until the all selection 

is simulated 

 

Note: If users come across an error during the simulation run it is possible that some batched will 

have already been simulated until the ICD has encountered the problematic building.  

 

Decoupling DHW from HVAC 

In the query tool, the category Advanced – MISC, the Attribute DHW profile gives the user to 

decouple the DHW use form the HVAC system. 

The user has the choice to set the profile as: 

- Default values: corresponds to the default profiles used by the Template (ASHRAE or ICL) 

- Linked to occupancy: the DHW profile corresponds to the Occupancy profile attribute 

- Independent profile: the user can select the DHW to follow one of the pre-set profiles 



 

 

 

Notes: A new profile was added to this pre-set list (DHW house) which is meant to capture domestic 

use of DHW. 

   



 

 

Release 2022.1.0 – April 2022 

Object Highlighting 

The highlight functionality allows to identify a sub-object within an object (like a space within a 

building) from Edit Object dialog or to identify a building within a group of selected buildings. It is 

useful tool to understand which column in the query tool corresponds to which space in the model. 

To highlight an object or a sub-object from the query tool, simply the “box” icon of the desired 

column. 

The example below shows Building 1. Clicking the box below “Room 2” highlights the position of this 

space in the model. 

 

 

Dialog Re-work 

The Channel association dialog was simplified and inconsistencies in the Scenario dialog were 

removed. 

GeoJSON import improvement 

The GeoJSON import now allows users to import point layers as point objects in iCD (PV, Streetlight, 

EV chargers and Trees).  

In the import dialog, below the attributes’ settings, two dropdowns menus give the user the 

possibility to choose the object type corresponding to your GeoJSON import (see figure below). 

Polygon layers 

If the GeoJSON layer contains only polygons, only the “Polygon object import type” will appear. 

Polygon layers can be imported as any object defined by their footprint in the iCD: buildings, 

boundaries, landscape, roads, water etc… 



 

Point layers 

If the GeoJSON layer contains only points, only the “Point object import type” will appear. 

Polygon layers can be imported as any point object: PVs, Trees, Streetlights, EV chargers. 

 

 

 

iCIM project-level scenarios 

If the iCD model is part of a larger centralised iCIM project (multi-model iCIM projects) it is possible 

to create a scenario of the full iCIM project from the iCD. This functionality creates a duplicate of the 

entire iCIM project the iCD model is synchronised to as a new scenario. The scenario can then be 

synchronised later back in each iCD model being part of the iCIM project for editing. 

This functionality is essential in order to create a scenario for an iCIM project that is an aggregation 

of multiple iCD models. 

To create a scenario of the full iCIM project: 

- Click the Synchronisation button to open the iCIM Synchronisation dialog; 

- Click the + Create Scenario on iCIM; 



 

 

Figure 0-1 Create Scenario in iCIM 

 

Note: this button will only appear in models that are already synchronised to an iCIM project.  

- In the Scenario Name dialog that iCD prompts, enter the name of the new scenario and click 

Create scenario (see Figure 0-2). 

 

Figure 0-2 Scenario Name dialog 

- Once the scenario is created in iCIM, iCD shows the newly created scenario in the 

synchronisation dialog. As this scenario has only been created in iCIM, it appears “Not 

synched” and is greyed out by default (see Figure 0-3). 



 

 

Figure 0-3 Newly created iCIM scenario visible from the synchronisation dialog 

- To retrieve the scenario for further editing in iCD, turn the Toggle button on, select “create 

in iCD” (see Figure 0-4) and click Start synch. 

 

Figure 0-4 Importing newly created scenario 3 to iCD 

- Once downloaded, the new scenario will be available as scenario in iCD (and located in the 

same folder as the baseline SketchUp model). To open it in iCD, select it from the scenario 

dialog (see more on that in chapter Error! Reference source not found.) or open the .skp 

file with SketchUp. 



 

 

 

Preferences panel time awareness 

Model-level inputs entered in the Preferences panel such as Carbon Emission Coefficient and 

Resource Costs Per Unit are now time aware and values can be entered manually for each specific 

year.  

Values entered manually are applied to the year displayed in the top right of the dialog (see Figure 

below). All the following years retain this value.  

In the example below, the Biogas default value is set to 0.098. It is manually edited to 0.095 for year 

2023. And then modified again to 0.092 in 2026. Note that for all the year before 2023 the default 

value applies. For 2023-2025, the value entered in 2023 is applied. For all the year from 2026 

onward, the value entered in 2026 is applied. 

 

Additional attribute for Roof Solar Potential 

In addition to the other available attribute, the Panel rotation on flat roofs gives the user the 

possibility to set the orientation of the auto-generated PVs. 



 

Below the example when the rotation is set to 150°. 

 

 

Below the same example but with the rotation set to 200°. 

 

 

 

  



 

Release 2022.0.0 – January 2022 

Complex geometry 

iCD now allows users to create buildings from 3D shapes and not only from extruded footprint. 

 

The general process to create a Complex geometry building is as follow: 

- Importing or creating a 3D shape in Sketchup 

- Checking the geometry and the identification of bounded volumes using the Geometry 

Preview 

- Making the 3D shape a group and creating the building with the create 

3D shapes can be created using all the usual drawing tools such as Line, Rectangle, Circle, Push/Pull, 

Follow Me, etc… 

Note: 

- shapes that don’t define a bounded volume are treated as local shades by iCD 

- Polygons fully within a face are treated as glazing 

It also possible to import 3D models from other software such as Rhino, Blender but also the VE and 

convert them into Complex Geometry buildings in iCD. 

To check how iCD will understand the 3D shape and create the building, users can use the Geometry 

Preview functionality before creating the building. 

 

Once the 3D shape is properly defined, creating a complex geometry from it is done in 2 steps: 

- Making a group out of the 3D shape 

- Using the Create tool. 

 



 

It is also possible to convert a Simple geometry Building that was initially created from a polygon – 

whether it was manually drawn or imported from an OSM or created from a GeoJSON file – into a 

Complex Geometry Building in order to edit the geometry in more detail. 

Note: Converting a building into a Complex Geometry building is non-reversible process. A Complex 

Geometry building cannot be converted back into a simple geometry building. 

 

Improved flexibility for PV auto-generation 

The Roof solar potential has been updated and now gives the user the possibility to set different 

parameters:  

- Panel Inclination on Flat roofs: sets the angle the PV panel makes with the horizontal. By 

default, this value is set to the site’s latitude + 15°. On slopped roofs, PV will be placed with 

the same inclination as the roof they are on. 

 

- Spacing between rows: sets the distance between 2 consecutive rows of PV. By default, this 

value is set to 1m.  

Panel Inclination 



 

 

- Spacing between columns: Sets the distance between 2 consecutive PV in a row. By default, 

this value is set to 0m. 

 

- Panel width: sets the panels’ width attribute. By default, this value is set to 1.5m. 

- Panel height: sets the panels height attribute called Non-Building height. By default, this 

value is set to 1m. 

- Efficiency: sets the panels’ efficiency also called PV conversion factor. By default, this value is 

set to 0.15. 

- Minimum Solar insolation (kWh/m2): This parameter sets the minimum threshold for roofs 

to be included in the Roof solar potential. All roofs with an annual solar insulation higher 

than this threshold will be included in the Roof solar potential. By default, this value is set to 

the median value solar insolation  

Space between rows 

Space between columns 



 

Note: On flat roofs, PV will automatically be facing south if the model is located in the northern 

hemisphere or north if the model is located in the southern hemisphere 

Improved iCIM synchronisation process  

The iCIM synchronisation was improved to allow to connect to an existing iCIM project an iCD model 

that already contains objects. This process is meant to facilitate the synchronisation of several iCD 

model to a single iCIM project. 

The synchronisation dialog now gives the option to the user to select the Synch Mode when 

synchronising an iCD model with objects to an existing iCIM 

 

It is possible to tick the Download only option, in this case clicking Open will only import the object in 

the iCIM into the iCD model. 

If the the Download only option is not ticked, then clicking open will both import what is on iCIM into 

the iCD model but also upload the objects in the iCD model to the iCIM project. 

 

Updated import of iSCAN channel (channel association) 

iSCAN channels can be associated to boundary objects in iCD 

The channel association process was also improved and now allow to apply a single channel to 

several objects in CD. Object can import if they all share – in the chosen attribute – the same value 

as the channel’s tag. 

Solar assessment dialog UI updated (React-based) 

The solar assessment dialog has been updated. 



 

  

  



 

Release 2021.1.0 – April 2021 

Selective Synchronisation between iCD and iCIM using the Area of Interest (AOI) 

iCD now allows users to synchronise only part of the iCD model that are within an AOI. The AOI is a 

geographical zone that can be defined in iCD. The iCIM Synchronisation process can limit the 

synchronisation only to objects within an AOI. This can be particularly useful to synchronise several 

different iCD models (covering different geographical areas) into a single iCIM project or if multiple 

users are independently editing and synchronising specific parts of an iCD model. 

In order to use an AOI to synchronise a model, it is first necessary to create it in iCD beforehand. There 

are different ways to create an AOI: 

- From a free form shape in iCD (see below)  

 

 

- Around selected objects (see below) 

 

 

- In the iCIM Synchronisation window 

If the user is synching a model to an existing iCIM project the iCIM Synchronisation windows 

offers the possibility to create an AOI before synchronising (see below). 



 

 

 

Once an AOI is defined in iCD it can be used to synchronise only part of the iCD model to the iCIM.  

For the synchronisation process to consider only the changes that occurred within the AOI, the box 

Limit to the buildings inside the baseline Area of Interest? Should be ticked (see below) 

 

In the example below, one of the two highlighted buildings is located within a defined AOI. Both 

buildings were edited to have 15 storeys. The AOI is then synchronised with the iCIM project. In 

iCIM, only the building within the AOI was updated. 



 

 

 

 

Multi-scenario synchronisation between iCD and iCIM 

An iCD model with multiple scenarios can now also be synchronised and visualised in the same iCIM 

project. 

In the example below, the baseline and two additional scenarios were created. 

 

Figure 0-1: The baseline (left) and two scenarios in iCD 

To synchronise the model for the first time, click the Synchronise button in the iCD toolbar and 

select the desired iCIM endpoint. As the model contains several scenarios, the synchronisation 

window gives the possibility to choose which scenario to synchronise (see image below) 



 

 

If the model had previously been synchronised or if scenarios were added after the first 

synchronisation, the synchronisation window will display the different available scenarios with an 

indication on which of scenario has already been synched and the latest time of synchronisation. It is 

possible to choose which scenario to synchronise clicking on the blue switch button next to each of 

them (see image below). 

On the image below, the baseline had already been synchronised but not the other two scenarios. 

One the left image, only the Baseline will be synchronised. On the middle image, the baseline and 

scenario 2 will be synchronised. On the right image all the scenarios will be synchronised. 

 

  

Note: Only the other scenarios can be ignored for a synchronisation, the baseline is always 

synchronised. 

Note: any change made to the Baseline will be also applied to all other scenario while synchronising 

to iCIM. The user must then be cautious while editing and synchronising the baseline. Changes made 

to a scenario are only applied to this specific scenario.  

If the baseline is already synchronised, iCD will prompt that no changes are to be synchronised for the 

baseline. Clicking Skip Baseline will then show the different scenarios that need to be updated (see 

image below). 



 

   

Once all the scenario synchronised, they are available for visualisation in iCIM. To switch from one 

scenario to another, the desired scenario can be selected in the dropdown menu on the bottom left 

of the screen (see image below).  

 

 

 

 



 

Faster results processing and timeseries export to iSCAN 

The generation of the simulation results was improved in order to speed up the process and the 

export of timeseries to iSCAN. 

 

Dialog UI updates  

Some dialogs visuals were updated and harmonised 

OSM Import  - INCLUDE 

Create tool   - INCLUDE 

Boundary tool  - INCLUDE 

Custom attributes  - INCLUDE 

Painter tool  - INCLUDE 

Time  - INCLUDE 

Vis tool  - INCLUDE 

Sim launcher  - INCLUDE 

Sim progress  - INCLUDE 

Locate entities  - INCLUDE 

Help  - INCLUDE 

 

  



 

Release 2021.0.0 – January 2021 

Highlights for intelligent Community Design (iCD) Tool 

Updated preferences panel 

The preference panel layout is updated and a new section has been added. The panel is now 

organised into the following sections: 

1. Templates and units: 

2. Carbon emission coefficients 

3. Resources cost per unit (New) 

4. Material colours 

5. Miscellaneous 

6. Troubleshooting 

Basic Cost Analysis 

In iCD, it is possible to complete an energy simulation with a basic energy cost analysis.  

The cost analysis will allow the user to get some understanding the monthly energy costs per 

commodities over a community. 

In order to give relevant results, the following steps are necessary:  

1. Set the Resources’ cost per unit – from the preferences panel  

a. Set the desired currency and resource 

b. If the model includes some PV panels, it is important to make sure the value for PV 

offset / kWh is set. As this value will represent a saving, please note its value should 

be negative. 

 

2. Set the Fuel type for heating and hot water for the buildings – from the Room/Building 

Query Tool 



 

 

3. Set the PV layout if any – by adding PV panels and running a Solar assessment 

4. Perform an energy/water simulation  

5. View the report from the Reports section –  

a. Cost analysis results can be visualised in the Cost Savings Breakdown report. This 

report is accessible in Extension > IES iCD > Reports > Site Reports > Cost Savings 

Breakdown. 

 

Carbon Emission Coefficients  

In iCD, it is possible to complete an energy simulation with a basic carbon emission analysis for each 

type of commodity based on the applied ratio in the country the model is located in. 

The carbon analysis will allow the user to get some understanding the total site’s carbon emissions. 

In order for this report to give relevant results, the following steps are necessary:  

1. Set the Carbon emission coefficients – from the preferences panel  

a. It is possible to keep the pre-set coefficient or to manually overwrite each coefficient. 

b. When a value is manually overwritten, a tick mark will appear in the box next to it. 

Unticking this box will bring back the default value. 



 

 

2. Set the Fuel type for heating and hot water for the buildings - from the Room/Building Query 

Tool 

 

3. Set the PV and tree layout if any; 

4. Perform an energy/water simulation 

5. View the results in the Room/Building Query tool or in the report from the reports section 

a. The results are expressed as the following:  
i. For Trees, in Sim annual carbon sequestration in CO2, kg per year  
ii. For Buildings, is Sim total carbon, expressed in kg of CO2 per m2 per year 

iii. For EV Chargers, it is Sim total carbon – in kg of CO2 per year 

 



 

 

This report consists in a pie chart showing annual carbon emission (electrical and non-electrical) as 

well as PVs and trees emission offsets.  

iCD to iSCAN  

iCD simulation results can be exported to iSCAN. Exporting simulation results to iSCAN allows end-

users to access them as hourly time series which are not available within iCD. 

The user can choose which time-series to export to iSCAN by ticking the appropriate option. 

 

Additional options to export the data to iSCAN have been added.  

1. Select Post-Simulation - the use can select the iSCAN project post simulation  

2. Add new endpoint – the user can add a new endpoint from here  

3. iSCAN project URL - If the iSCAN project is already set up in iCD, the user can select the relevant 

iSCAN project URL directly from here 

 

 



 

Updated PV Auto-generation 

Once the solar assessment has been undertaken and the results saved. The user can click on the 

“Roof solar potential” button to generate PV panels. This button is available once the solar 

assessment has been run for the first time. 

The user now has the option of selecting specific buildings for the PV auto generation, this can be 

done by checking the box “Filter selected building” and then selecting the building for the auto 

generation.  

 

iCD current year displayed in iCIM 

The current year as set in the iCD time dimension tool will be displayed in iCIM. 

 

 

 

 

  



 

Release 2020.1.0 – October 2020 

Highlights for intelligent Community Design (iCD) Tool 

 

New Point Objects (Trees, EV charger and Street lights) 

iCD now includes 3 new points objects: Trees, EV charger and street lights. 

Similarly, to PV panels (freestanding PV), these point objects can be individually created in a model 

using the Create tool. 

Trees 

Tree objects sequester CO2 which is taken into account in the Site renewable report. 

They also generate a water demand which is taken into account in the site water reports. 

A tree’s parameters – its type, age, size, water consumption - will have an impact on its CO2 

sequestration and water demand.   

Trees store two simulation results as attributes: 

sim annual carbon sequestration: Total sequestered CO2 by the tree in a year.  

Sim water total: Total annual water demand for the tree.  

EV chargers 

EV chargers generate an electricity consumption which is reflected in sites energy reports. 

Adjusting the EV charger type, maximum power and daily profiles allows the end user to model 

different EV chargers, from small individual installations to larger charging stations.  

EV chargers store two simulation results as attributes: 

sim total carbon: Total CO2 generated by the EV charger in a year.  

Sim total energy: Total annual energy consumption.  

Street lights 

Street lights generate an electricity consumption which is reflected in sites energy reports. 

Adjusting the Street light’s type, maximum power and usage daily profiles allows the end user to 

model different street lights. 

Street lights store two simulation results as attributes: 

sim total carbon: Total CO2 generated by the EV charger in a year.  

Sim total energy: Total annual energy consumption.  

 



 

 

 

New Scenario dialog 

The scenario dialog is improved. 

The same functionalities remain: create new scenario, access the different scenarios to edit them, 

access the report for comparison. 

 

The scenario dialog also allows the user to compare reports between boundaries in the same model. 

Ticking the box left of the model scenario, expands all the boundaries present in the model. 



 

 

Updated Preference Panel 

The preference panel is updated and organised into the following sections 

Templates and units: allows the end-user to select the simulation template (ASHRAE or ICL) and the 

units (metric or IP) 

Carbon emission coefficients: allows the end-user to set the carbon emission coefficients either 

manually or automatically by selecting the location of the project. 

Material colours: allows the end-user to set the colour for the different material in the model 

Miscellaneous: allows the end-user to set the VE location and enable the invalid annual occupancy 

warning 

Troubleshooting: enable the end-user to optimise the visualise tool and the imports 

 

PV Auto-generation 

The Solar assessment now gives the possibility to run the Roof Solar Potential. This auto-generates 

PV panels on building’s roofs in the model. 

Once the solar assessment has been undertaken and the results saved. The user can click on the 

“Roof solar potential” button to generate these PV panels. This button is available once the solar 

assessment has been run for the first time. 



 

 

 

Every roof space in the model within the highest 50th percentile of surface insolation will then be 

populated with PV panels. The panels will by default be 1.5m by 1m and have an efficiency of 0.15. 

The roof space will be filled with rows of panels, separated by 1m. On flat roofs the panels will have 

an inclination of 15°, on pitched roofs the inclination will match that of the roof surface. These 

panels will then be included in any future energy simulations undertaken on the site, with results 

showing in boundary and site renewables reports.  

Note: running this analysis on large sites can take some time for the generation to complete. 

 

 

Peak loads 

Energy simulation includes the option to retain Peak loads in iCD. 

To do so, in the simulation launcher under Energy Simulation Options, the box Retain Peak Loads 

should be ticked before launching. 



 

 

Peak loads can be retained for the following consumption type: 

- Cooling; 

- Domestic Hot Water; 

- Electrical demand; 

- Gas/Fuel demand and 

- Heating  

Retaining the peak loads will store, for each simulated building, values in new attributes in the 

Simulation Results section: 

- Load peak date/time: it gives the time and date at which the peak load occurred in the 

building 

- Load peak value: it gives value of the peak load in the building (W/m2) 

 

Custom Weather files 

The Weather Data option gives the possibility to manually set the weather file to be used for the 

simulation. 



 

Clicking the Manually Selected Weather Data box opens the Weather File Selection dialog in which 

the end-user can select any weather file amongst the available files in the installation. 

 

 

The Weather File Selection dialog gives access to all the weather files available for the VE and the 

iCD. They are usually located in the following folder: C:\Program Files (x86)\IES\Shared 

Content\Weather.  

 

If the simulation is a multi-year simulation, it is possible to independently assign a weather file for 

each simulated year clicking on the “edit” icon on the right side to each year. 

 



 

 

Socio-economic indicators and custom calculation 

The Socio-economic Indicators dialogue allows the end-user to perform a series of bespoke 

calculations, over a number of years, based on specific inputs. The user can use these calculations to 

generate values for the default socio-economic indicators, or create their own custom indicators and 

calculations.  

Custom calculations (or Socio-Economic Indicators) are done at a boundary level. It is then necessary 

to have defined boundaries in the model prior to doing these calculations and the dialog can be 

accessed via the Boundary tool. 

 

Start Year and Number of years to simulate 

When running calculations for socio-economic  indicators the user must first select the ‘start year’, 

which is the first year that the indicators will be calculated for, and the ‘number of years to simulate’ 

which determines how many years indicators will be calculated for. For example, if the user selects a 

start year of 2022 and 10 years to simulate then indicators will be calculated for each year between 

2022 and 2032.   

 

 

Inputs 

Inputs are a set of yearly values that are used as inputs for the custom calculations.  

The only default input is yearly energy saving, which is determined from undertaking multi-year 

energy simulations of the model. All of the default socio-economic indicators can be calculated from 

this input.  



 

The user can create their own custom inputs by clicking on the ‘add model input’ button. The input 

can then be named and custom values for each year inserted. Custom inputs can either be used to 

calculate new custom indicators, or can be incorporated into the equations used to calculate the 

default socio-economic indicators.    

 

 

Indicators 

The indicators that will be calculated are then shown below the inputs. The default socio-economic 

indicators that are calculated from the yearly energy saving are: energy consumption, jobs created, 

disposable income, fuel poverty, property value and derelict development. The source column 

determines whether the initial value for the indicator used in the calculations comes from the model 

data or is a custom initial value, for some indicators only a custom initial value can be used. This 

value is set in the ‘initial value’ column. The equation used to calculate the indicator for each year is 

shown in the ‘terms’ columns. These equations are fully editable, allowing the user to add or remove 

terms based on inputs and other indicators, a full description of editing the equations is given below.  



 

 

The edit indicator dialog which allows the end-user to edit the formula used to calculate a specific 

indicator. This shows a list of all terms used to calculate that indicator, presented in a table.  

 

The dialog also allows the end-user to create and edit a new bespoke indicator clicking the +Add 

indicator button. 

 

Socio-Economic Indicators can be visualised in the SEI report accessible in the Sites reports 



 

 

Time dimension dialog 

The Time dialog now includes an option to render the change of geometry over time.  

Ticking the Render geometry changes will adjust the building geometry with the year in addition to 

showing not constructed and demolished buildings. It will for example, directly show on the model 

the addition or removal of floors. 

In the example below, a second floor was added to the building in the front in 2022. 

With the Render geometry changes, switching from 2021 to 2022, directly reflects this additional 

floor. 

 

 

IES iSCAN exports 

The user now has the possibility to select which data to export to iSCAN as channels: 

- Export energy, water and loads breakdowns 

- Export energy, water and loads totals 

- Export all 

The options are accessed on the Simulation Launcher prior to running simulations, 

 

Exporting the breakdowns will create the following channels in the iSCAN project:  

- DHW demand load (Domestic hot water loads) 

- Room units cooling loads 

- Room units heating loads 

- Sim auxiliary energy  

- Sim cooling energy 

- Sim equipment energy 

- Sim heating energy 

- Sim lighting energy 

- Sim Potable water demand 

- Sim waste water generated 



 

Exporting the totals will create the following channels in the iSCAN project:  

- Sim Potable water demand 

- Sim waste water generated 

- Sim total carbon (kg/h) 

- Sim total electricity 

- Sim total energy  

- Sim total Natural Gas (or Biomass or LPG or Coal etc… depending on the commodity set in 

the attribute Fuel Type) 

 

Visualisation of solar insolation / Selected area 

Using the visualisation tool to overlay the solar insolation over surfaces now gives a new output: the 

Area Selected. It gives the total area considered in the visualisation. 

For example: Adjusting the scope of the visualisation may exclude or include some area for the 

visualisation, the total considered area is now clearly reflected in the Area Selected output.  

 

  



 

Release 2020.0.0 – May 2020 

Highlights for intelligent Campus Design (iCD) Tool 

Validated ICL profiles 

Includes Validated ICL profiles based on measured data across UK and Europe. 

These ICL profiles provides a detailed set of attributes (different from the attributes available in the 

ASHRAE templates) allowing the user to define the necessary parameters to perform energy 

simulations on buildings. 

ICL profiles can be selected in the IES iCD extension under Preferences, Simulation Templates. 

Multi-year Energy simulation 

Energy simulation can now be performed over several years. The user can choose to run a multi-year 

simulation from the Simulation Launcher window and select the starting year and the end year of 

the simulation.  

 

 



 

Energy simulation results are independently saved for each year. Results for each year are easily 

accessible for all reports as user can scroll through the year or directly type in the desired year 

within the reports dialog. 

 

     

Similarly, when running energy or water simulation for multiple years across multiple scenarios, the 

scenario comparison tool allows the user to change the year the comparison is made of directly 

within the tool’s UI. 

It is now also possible to specify the year directly within any dialog window such as Room/Building 

Query Tool or Visualisation in order to view results or attributes for the desired year. 

         

 



 

When an attribute is modified for a specific year the value it holds automatically persists on the 

following years (as if it was considered as a building renovation). For example, if an attribute is 

edited in 2015, its value in 2015 is automatically applied for all the following years. 

 

     

 

Updated export to iSCAN 

The Total Energy and Total Carbon channels are now automatically exported when the “export to 

iSCAN” option is selected. 

Furthermore, two water channels are now automatically exported to iSCAN when the “export to 

iSCAN” option is selected: waterWaste (total waste water) and waterTotal (total potable water). 

 

Updates to reports 

Reports in iCD now include a Carbon emission report. The Annual Carbon Emissions report compares 

the non-electrical emissions, the electrical emissions and (if modelled) the share of GHG emissions 

offset by PV panels. 

 



 

 

 

 

Photovoltaic generation reports were updated and now highlight the excess of PV generation. 

 

 

 



 

Updated Carbon Emission Coefficient (aligned with VE 2019) 

The Carbon emission coefficients now automatically update based on the geolocation from the OSM 

import. 

If the imported location is not within one of the region with pre-set carbon emission coefficients, the 

UK values will be set as a default parameter.  

 

  



 

Release 2019.1.0 – October 2019  

Highlights for intelligent Campus Design (iCD) Tool 

Water Simulation 

A new feature has been added to undertake water analysis. Once we run the water simulation we 

can view the results of the annual water consumption and breakdown, annual waste water and 

breakdown and the annual rain and storm-water run off (at present for roofs and hardscape objects 

only).  

To do this we have to first assign flow and flush rate data to the building. Click on the building and 

open the room/building query tool. Next we set the Building Type, then click on “not set” in the 

water fixture text box. The word default will appear. The default values that the tool automatically 

populates is based on the selected building type.  

To view the data click on the three dot  next to the text, a pop up window opens. In here you can 

view the pre-populated data or edit it based on project specific data.  

 

 
 
Once you have added the data to all the buildings, open the simulation dialog to analyse water 
consumption. Select the objects in the ‘Object filter’, select Run VE Water Calculation. Update and 
click on Launch to start the simulation. 

 
You can view the individual building results of the water simulation as well as annual water run off in 
the room/building query tool.  



 

 
We can also view the report via the gallery or the ready-made reports. If you view the project level 
readymade reports, similar to the approach for energy use, they will show combined results for all of 
the buildings that have been simulated; as this is a ‘model’ level report rather than a building level 
one.  

 
 
Based on the size and type of building, this analysis provides us with an overview of the overall 
breakdown of water use within different types of buildings and identify areas where water efficiency 
measures can be targeted. You can also view the waste water breakdown, this can help in planning 
for a waste water recycling plant around the site.  

 



 

Export Data to iSCAN 

In the simulation launcher tool, a new feature, Export to SCAN has been added. The target year 

cannot be edited from this feature, it needs to be set in the Time tool.  

Before this tool can be used to export a model, the project needs to be first set up in SCAN with 

associated tag vocalbulary to match the building names. This way all the simulated channels 

generated will automatically be mapped onto the correct buildings within the iSCAN project.  

 

After checking the Export to SCAN box, click update and then launch.  

The export process to SCAN has been revised as follows: 

• All channels now include the relevant building names to make it easier to map in iVN 

• All channels are in on iSCAN ‘Building’ and so can be compared to each other in terms of 
performance 

• The iSCAN ‘building’ name will be the same as the iCD Model for ease of tracking 

• Channel data exported to iSCAN can be updated multiple times within 48 hours (previously 
gave an error) 

 

 

 
 

Better recognition of building types from OSM Import 

One new feature that has been added to OSM import is the ability of the tool to be able to 

automatically populate the Building Type attribute based on the available information in OSM. 

At the time of the import, if data is available it is added to two custom attributes called shop 

description and additional information, based on which the building type attribute is categorised.  



 

So for example, a bank has been categorised as an office while a mall has been categorised as a retail 

building.  

  
 

  
 

Updated Carbon Emissions Coefficient (aligned with VE 2019) 

In the preferences panel, end users can now see an additional setting for carbon emission coefficients 
for a variety of fuels based on region and territory, similar to the energy / carbon meters in the VE. 
These factors are based on location and default data is available only for locations in US, UK and 
Australia, in line with information in the VE.  
 
If end users do not specify a location, it defaults to the UK. These values are references, and if end 
users have more relevant or specific emissions coefficients available, the values in the iCD are editable 
and highlight when values are changed from the default.  The images below show the implementation 
in the iCD and the associated version in the VE. 
 

  



 

 

 
 
In addition to default electrical uses (cooling, lighting, equipment, auxiliary energy use), these 
emissions coefficients also include various fuels that can be specified for heating / hot water in 
individual buildings as shown in the image on the left.  
The overall CO2 emissions in kg/m2 is calculated per building post simulation based on the total 
emissions for electricity, heating and hot water end uses.  
 

   
 

CSV export for iPIM 

A new feature that has been added to directly create a CSV for importing data to iPIM.  

This can be accessed via Extensions -> IES iCD -> Import/Export -> Export CSV.  

To be able to use this feature you need to select the applicable options from the object filter and 

select the attributes that need to be exported to iPIM. Next click on Show, the buildings whose data 

is to be imported will be highlighted in Green. Next click on Export options and check the box against 

Export coordinates (Latitude, Longitude). Finally click Export to create a CSV.  



 

 

You can now use this CSV to create an iPIM project.  

Note the columns description in the CSV needs to be tagged appropriately prior to creating the iPIM 

project.  

  

Addition of Roof-lights/Sky Lights 

It is now possible to add roof-lights or sky lights to a building in iCD. Similar to the glazing ratio 

attribute for windows here too you will need to enter the percentage of roof glazing.  

Note at present, this is only applicable for flat roofs, however this feature is being revised to include 
all roof types in future releases.  
 

 

 
In case you are not able to view this attribute, go to Extensions -> IES iCD-> Attribute Visibility and 

make the attribute visible.  

Locate Entities 

In the toolbar, this feature has been added to search objects in the model based on the “Object 

Name”. 



 

 

When you click on the icon, a new window opens, in the Entity Type drop down menu you can select 

the object type or leave it as the default search option of “All entity types”.  

  

Next in the search term add key search words for an object. All the objects with the key work will 

appear in the window below, click on the name to zoom to the object.  

  



 

Release – December 2018 

Highlights  

Walkability 

A new feature has been added to undertake coverage analysis for walkability, bike-ability and other 

types of road and pedestrian access. It defines a free flowing boundary for realistic walkable access 

to a service along a road/pathway/pavement.  

It can be accessed via the boundary tool. Important to note that roads need to be imported for this 

feature to work. 

In the boundaries tool, when you select generate a walkability boundary, a new window opens. It is 

here that you need to first specify the walking distance, then select a point at any desired location 

on the model and run the tool.  

             

The  image below shows a potential end use of this type of analysis; a walkability study of the 

London Tube stations indicating that some locations are not adequately serviced by the tube 

network. Only the areas highlighted in orange (walkability boundaries) have walkable access to at 

least one station in London Tube network.  

 

Accessibility 

The Walkability and Accessibility tool are related and utilise the same road network. Where 

Walkability gives a service coverage analysis, Accessibility allows end users to measure distances to 

specific amenities/services.  

Similar to the walkability tool, roads need to be imported for this feature to work. This can be 

accessed via Tools -> IES Masterplanning -> Accessibility Assessment.  
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To use this feature, create a custom attribute of the amenities and assign the same to buildings in the 

model. Note, at present custom attributes assigned only to buildings can be analysed by this feature. 

The feature is under development and will represent other elements in future releases.  

 

Open the Accessibility Assessment dialogue box and pick the custom building attribute (will need to 

do this in case you have created more than one type of custom building attribute) and the amenity 

type. Now pick a point on the model (a green arrow will indicate the selected point) and click locate. 

It will highlight a path (in blue) and give the distance from the selected point to the amenity.  

       

Terrain and Map Tiles from OpenStreetMap 

iCD now has the option to import the terrain and map tiles (ground texture) directly from 

OpenStreetMap.  

Currently, the terrain feature works best for buildings. As a result, it is recommended that you exclude 

roads, pavements and landscaping from the OSM import as these features do not map well over the 

terrain.  

In case these options are selected together, a message will appears prior to proceeding with the 

import. Select “yes” to import.   

  

Note that while it is recommended not to import them together, it can still be done by selecting the 

“No” option above. In this case, it is recommended that you use the roads/pavements/landscaping 
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and terrain layers independently for a better visual and work experience. You can control the 

visibility from the “layers” tray in SketchUp.  

GeoJSON Import 

It is now possible to directly import GeoJSON files. This can be accessed via Tools -> IES 

Masterplanning -> Import/Export -> Import GeoJSON (with attribute mapping).  

In the attribute mapping dialogue box, you can customise the target attribute prior to importing in 

the following ways:  

• The user can chose to ignore the attribute, in this case the attributes will not be imported. 

• The user can leave the dialogue boxes as it is. In this case, all the attributes will appear as 

User Defined attributes.  

• The user can also chose the Target Attribute from an attribute in the drop down list in this 

case it will enter this data in the chosen existing attribute. 

 

Once the customisation is complete, click on Import.  

SHP Import 

Shape files can now be directly imported. This can be accessed via Tools -> IES Masterplanning -> 

Import/Export -> Import SHP.  

The attributes need to be manually mapped, as shown in the image below rather than automatically. 

After this is done you click on import. Please note that currently, objects can only be imported as 

adjacent buildings for now. They can be edited post import to represent other object types 

(buildings, boundaries etc.) the ability to map SHP objects to any object type in the iCD will be 

supported in future versions of the tool.  

 



 

Time Dimension 

A new feature has been added which has the ability to add time as a dimension. Currently allows 

end users to track and visualise construction and demolition of buildings and/or entire phases of 

development. Future versions will include energy results saved separately for each year and the 

ability to visualise all aspects of the development over time. 

This can be accessed via Tools -> IES Masterplanning -> Time.  

To be able to use this feature, first data needs to be entered in the Date Constructed and Date 

Demolished attributes. The demolished buildings and not constructed buildings will now appear in 

different layers and can be made visible/invisible as per the end user’s requirement.  

Once the attribute data is entered, open the time tool and set the transparency for the building 

types (range 0 to 225). The current year can be set in the tool. This is especially important for using 

the next new feature which is exporting data to SCAN.  

To view the time feature, move the cursor along the year bar. Note, at present the results are not 

stored.  

 

It is also possible to view the Demolished Entities and the Not Constructed Entities in different 

colours. You can also click on the colour to change it.  

 

Scenarios 

A new and interesting feature that has been introduced is comparison of multiple options. Once the 

model is created, click on the button highlighted below.  



 

 

This will open up the current/base option. You can create a new option by entering a name and 

clicking create. The option created, can now be modified by clicking on the Edit button. A new model 

will open with the same file name and the suffix of the name given to the option. All of the attributes 

can be edited and saved in this new model. The new file can be opened and edited as an 

independent file as well.  

                      

To compare both the options, select include, then pick the desired report from the drop down menu 

and click on compare reports. The reports will appear below each other.  

Note that each of the options can be created and edited in the same way as a normal model / 

option, however this feature allows us to compare multiple options in a more coherent way. 

 

Note, for the feature to work properly, it is recommended that all options created be located in the 

same folder. The feature is under development and will be refined further in future releases.  

You can also add model images against each of the scenarios that you have created.  

To do this go to Extensions -> IES iCD -> Model Image. Here you can either select a snapshot, in 

which case the current window will be added as an image or you could import an image by browsing 

through your computer.  

 



 

Release – June 2018  

Highlights 

Inclusion of Terrain 

A new feature has been added to show underlying terrain for models imported via OpenStreetMap. If 

you attempt to use this feature in a new, blank SketchUp file, it will prompt you to save the file first. 

Once the file is saved use the OSM import button highlighted below 

 

Select the location and radius which you intend to import. Currently, the terrain feature works best 

for buildings. As a results, it is recommended that you exclude roads, pavements and landscaping from 

the OSM import. The feature is being revised to appropriately represent these elements in future 

releases.  

 

Initially, you will see all buildings on the ground plane as with previous releases. If you click on the 

terrain button highlighted below, the program will prompt you to confirm that you want to import 

terrain into the model.  

 

When you select “Yes”, it will generate a dialog box outlining details of the map tiles to be imported. 

If you accept the default (recommended) settings, it will inform you of how many tiles are required to 

be imported ask if you want to continue. Click “Yes” and once the download is complete, click zoom 

extents in SketchUp to view the model with Terrain. Depending on the altitude of the location in 



 

relation to the local datum, you may notice the terrain ‘floating’ above the ground plane. If you click 

on the terrain button again, the model and all buildings involved go back to the ground plane. 

User Defined Colours 

This allows users to select colours by feature type / object type. This can be accessed via Tools -> IES 

Masterplanning -> Preferences. The Material colours section will have a list of objects / features and 

the colours associated with them. You can change it as desired.  

There are two sets of Materials Colour Sources, “User” and “Model”. All colour palettes associated 

with the “User” colour source with used for every new model created / opened by that end user.  

The “Model” colour source applies to a given model only. It will not be implemented in other models 

by default.   

 

Inclusion of PV’s as objects 

PV’s can now be added to an iCD model using the create dialog box and selecting freestanding PV. 

Step-1 

 

Step-2 



 

 

Step-3: you can specify the size of the panels (height, width), the rotation (orientation) and 

inclination. A default rotation of zero equates to facing north, 90 -> east, 180 -> south, 270 -> west. 

 

A brief description of each of the items is below to help you with the data entry: 

Non-building height in meters: This is the size of the PV panel. Let’s say 1 meters.  

PV conversion factor: Efficiency is the comparison of energy output to energy input of a given system. 

For solar photovoltaic (PV) cells, this means the ratio of useful electrical energy they produce to the 

amount of solar energy incident on the cell under standardized testing conditions. Most commercial 

cells are below 30%. For this case let’s consider that the efficiency is 15% or 0.15.  

Rotation:  Solar panels work best when they face directly into the sun. So for best results, your solar 

panels should face toward the equator. If you live in the Northern Hemisphere, face them south. If 

you live in the Southern Hemisphere, face them north. In our case here it will be 180 degrees so that 

the panels faces south.  



 

Inclination: The tilt angle of the photovoltaic (PV) array is the key to an optimum energy yield. The 

optimum tilt angle is calculated by adding 15 degrees to your latitude during winter, and subtracting 

15 degrees from your latitude during summer. For instance, for this model of Glasgow the latitude is 

55° and since it is summer the optimum tilt angle for your solar panels will be 55 - 15 = 40°.  

Width in meters: Let’s assume the width will be 1.5 meters.  

You will need to click at any point on the model to place these PV panels you can add as many panels 

as required for your project.  

These panels will now be included in any solar analysis you run via Tools -> IES Masterplanning -> 

Solar Assessment 

 

You can then view the report from Extension -> IES iCD -> Reports -> Ready-made reports ->Site 

Renewable Reports  

In the full site renewable report, we can view, the monthly PV radiation, the monthly PV electricity 

yield, the annual PV yield versus electricity and gas loads and the annual PV yield versus total energy 

loads.  

Import Data from iSCAN 

Building objects within iCD can now be linked to detailed simulated and measured time-series data 

from SCAN projects via Tools -> IES Masterplanning -> SCAN Client and these links can also be 

exported to CIM projects for visualisation. 

 

Please get in touch with IES support for more details. 

1
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Release – October 2017 

Highlights 

More data from OpenStreetMap 

iCD will now import the number of storeys for buildings in OpenStreetMap when this information is 

available. iCD will also handle intelligently weird cases where both building height and number of 

storeys seem to be inconsistent. 

Two-step simulation for the Virtual Environment 

When a VE simulation is launched, the user can choose to perform a two-step simulation. In the first 

step, the selected buildings are exported to the Virtual Environment. At this point the user is able to 

open the model locally, perform any required modification and finally perform the actual simulation. 

This new feature allows users to personalize even more the VE simulation and use more detailed 

results in their iCD models. 

Attribute visibility 

In this release we have added a new feature called Attribute Visibility. Attribute Visibility can be 

accessed via Tools -> IES Masterplanning -> Attribute Visibility. Users can now choose the attributes 

that they want to be shown in every panel of the plugin. At any given point the user can add or 

remove attributes. 

To use the feature one needs to select the attribute on the AVAILABLE ATTRIBUTES side and click on 

the arrow button. The attribute will now be visible on the VISIBLE ATTRIBUTES side. Click save and 

close.  

See example below 

 



 

New ground texture data source 

We have now have a new ground texture data source called Geofabrik. This new source is much 

faster and can download a larger area quickly.  

To enable the use of this new data source the user first needs to import the settings file.  

The import has to be done via Tools -> IES Masterplanning -> Ground Textures -> Import Settings -> 

(browse and select) tile-services.json.  

The ground texture will now appear in Tools -> IES Masterplanning -> Ground Textures -> Add image 

-> Tile service -> geofabrik 

Please get in touch with IES support for the settings file. 
 

New CIM synchronization 

A new synchronization button has been introduced to connect your iCD model to a central 

Community Information Model (subscription based). The new feature makes the synchronization 

with the central model very easy and robust. 

 

Any changes/edit made to the iCD model is now automatically and correctly synchronized with the 

centralized model at the click of a button.  

The list of changes is clearly listed in a pop up window so the user will always know what it is 

happening.  

Changes from multiple users are also possible and will be automatically kept in sync with the new 

synchronization features 

 
Please get in touch with IES support for more details and subscriptions. 
 

Attribute edit 

It is now possible to edit custom attributes. Click on the Edit button to view and edit the attribute.  

 
 



 

To edit, simply click the edit window, the user can now edit all the data except the type.  
 

 

 

Faster import 

We have now enabled a faster import method. This will help the user import a larger area in a much 

shorter time.  

For example for the city of Glasgow, to import a radius of 2500m it would ordinarily take eight 

minutes. However now with the new and faster import the same radius would take only two 

minutes. The difference will be more prominent as and when the user imports larger areas.  



 

Release – June 2017 

Highlights 

Simulation results in Boundaries Dynamic Report 

In this release we greatly expanded the list of attributes available in the Dynamic Report. This 

enhancement will allow users to perform even more detailed analysis of their masterplan. 

 

Search Tab in iCD 

A new search tab has been introduced in the iCD tool bar.  

 

Users can now easily search for any urban feature included in their model; iCD will automatically 

move the camera to the feature’ location. If multiple entries are found, users can simply move 

between them using the arrow keys.  

 



 

Import of lists from geoJSON and CSV 

 
It is now possible to import lists in iCD from geoJSON and CSV files. While importing, users can 

choose to map to existing core lists or previously created lists. 

 

 
It is also possible to edit the actual mapping and fix incorrect inputs. In this way users can easily 

import dirty data and iCD will take care of the correct mapping without any further user 

intervention. 

 
 
By clicking on the attribute being imported and then on Edit mapping, users can edit the specific 

mapping that will be applied during the import. It should be noted that, by design, it is not possible 

to change core lists such Building type, HVAC system, etc… 

 

 
 

  



 

Release – May 2017 

Highlights 

Improved User Interface 

We have made some small, but important changes to the UI (fonts, spacing, headers). There is now 

more space available and it is possible to visualize more information even on smaller screens. 

 

Figure 2: New iCD compact layout 

New automatic reports for site and boundaries 

We think our users will really enjoy this new features. Users can now generate summary site (and 

boundary) reports for three themes: site, energy and urban features. These reports are generated 

automatically and dynamically and give users aggregate site data, KPIs, useful info. 

The reports can be accessed from Tools -> IES Masterplanning -> Reports. 

 

Figure 3: Site summary reports 



 

Dynamic reports for boundaries update 

All the reports can now be saved in the model as template 

 

Figure 4: Dynamic boundary reports can now be saved as templates 

Under the hood 

• Fixed a minor bug with the iCD visualization tool not working with older graphic cards 

• Minor bug fix in geoJSON and CSV import 

• All windows now scale and resize as expected 

  



 

Release – March 2017 

Highlights 

• Improvements to boundary tool 

• CSV import into iCD (QGIS-like Spatial join) 

• Export model and object attributes to CSV 

• Peak values added to simulations results  

Under the hood 

• Fixed a few bugs 

Release – February 2017 

Highlights 

• Layers management for iCD objects. It is now possible to select, deselect and hide all the 

urban features imported from OpenStreetMap. Layers can be managed from SketchUp or 

from within the iCD plugin itself. 

• Improvement in geoJSON import. It is now possible to import geoJSON files with arbitrary 

attributes. iCD will do its best to guess the type of attribute and to clean up dirty data. 

• Ground textures from OpenStreetMap can now be added to the iCD model. 

• Faster Boundary tool 

Under the hood 

• We are working to create a seamless link between iCD and our 3D database. 

• Fixed a few minor bugs 

Release – January 2017 

Highlights 

• GeoJSON import with attributes. It is now possible to import a geoJSON file with all the 

associated attributes. The import tool can automatically parse the data and suggest the best 

type for each attribute. 

• Dynamic Reports for boundaries. 

• It is not possible to unset any attribute value. 

• Much clearer distinction between building level attribute and floor level attribute 

Under the hood 

• We are working to create a seamless link between iCD and our 3D database. 

• Fixed a few minor bugs 



 

Release – November 2016 

Highlights 

• Full compatibility with SketchUp 2017 

• In the Building Query Tool, it is now much easier to ‘unset’ values. 

• Clearer building hierarchy in Building Query Tool: 

o In the Building Query Tool, it is not possible to assign a space type to a building 

anymore. 

o To assign a space type, expand the floors view for the building and assign spaces as 

required 

 
• It is now much easier to deal with mixed-use buildings. 

• It is now possible, if required, to specify glazing ratio by eight orientations. 

Under the hood 

• We are working to create a seamless link between iCD and our 3D database. 

• Fixed a few minor bugs 

Release – October 2016 

Highlights 

• Full restyling of the plugin interface 

• It is now possible to specify Glazing Ratio by Orientation 

• General improvements in user experience such as faster menus, clearer inputs, etc… 

Known Issues 

• With new object colouring, glazing is not displayed for buildings that use texture glazing 

Release – September 2016 

Highlights 

• General restyling of the plugin interface 

• Improvements to OSM import tool. 

o Added filter to avoid import of geometries that are too small 

o Added option to let iCD to infer the number of storeys from the building height 

• Improvements to geo-location and search when importing from OSM 

• Added prototype dashboard for reporting on boundary properties 

• Added Import/Export of JSON format for boundaries 



 

Known Issues 

• With new object colouring, glazing is not displayed for buildings that use texture glazing 

Release – July 2016 

Highlights 

• Significant optimisation of object colouring (used in various tools) 

• Improvements to Boundary tool 

• Improvements to geo-location when importing from OSM 

• Added Import/Export of custom variables, boundaries and filters 

Known Issues 

• With new object colouring, glazing is not displayed for buildings that use texture glazing 

Release – April 2016 

Highlights 

• Added initial Boundary Tool 

• Added GeoJSON and CSV import/export 

• Improved filter editor 

• Added custom scale to visualisation tool 

• Added utilities to combine/split objects, save object selection and override building floor 

area 

• Added troubleshooting utilities 

Known Issues 

• Filters are now stored per-model rather than per-user, and cannot be imported/exported in 

this build 

 



 

 


