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Release – May 2020 

Highlights for intelligent Campus Design (iCD) Tool 

Validated ICL profiles 

Includes Validated ICL profiles based on measured data across UK and Europe. 

These ICL profiles provides a detailed set of attributes (different from the attributes available in the 

ASHRAE templates) allowing the user to define the necessary parameters to perform energy 

simulations on buildings. 

ICL profiles can be selected in the IES iCD extension under Preferences, Simulation Templates. 

Multi-year Energy simulation 

Energy simulation can now be performed over several years. The user can choose to run a multi-year 

simulation from the Simulation Launcher window and select the starting year and the end year of 

the simulation.  

 

 



 

Energy simulation results are independently saved for each year. Results for each year are easily 

accessible for all reports as user can scroll through the year or directly type in the desired year 

within the reports dialog. 

 

     

Similarly, when running energy or water simulation for multiple years across multiple scenarios, the 

scenario comparison tool allows the user to change the year the comparison is made of directly 

within the tool’s UI. 

It is now also possible to specify the year directly within any dialog window such as Room/Building 

Query Tool or Visualisation in order to view results or attributes for the desired year. 

         

 



 

When an attribute is modified for a specific year the value it holds automatically persists on the 

following years (as if it was considered as a building renovation). For example, if an attribute is 

edited in 2015, its value in 2015 is automatically applied for all the following years. 

 

     

 

Updated export to iSCAN 

The Total Energy and Total Carbon channels are now automatically exported when the “export to 

iSCAN” option is selected. 

Furthermore, two water channels are now automatically exported to iSCAN when the “export to 

iSCAN” option is selected: waterWaste (total waste water) and waterTotal (total potable water). 

 

Updates to reports 

Reports in iCD now include a Carbon emission report. The Annual Carbon Emissions report compares 

the non-electrical emissions, the electrical emissions and (if modelled) the share of GHG emissions 

offset by PV panels. 

 



 

 

 

 

Photovoltaic generation reports were updated and now highlight the excess of PV generation. 

 

 

 



 

Updated Carbon Emission Coefficient (aligned with VE 2019) 

The Carbon emission coefficients now automatically update based on the geolocation from the OSM 

import. 

If the imported location is not within one of the region with pre-set carbon emission coefficients, the 

UK values will be set as a default parameter.  

 

  



 

Release – October 2019  

Highlights for intelligent Campus Design (iCD) Tool 

Water Simulation 

A new feature has been added to undertake water analysis. Once we run the water simulation we 

can view the results of the annual water consumption and breakdown, annual waste water and 

breakdown and the annual rain and storm-water run off (at present for roofs and hardscape objects 

only).  

To do this we have to first assign flow and flush rate data to the building. Click on the building and 

open the room/building query tool. Next we set the Building Type, then click on “not set” in the 

water fixture text box. The word default will appear. The default values that the tool automatically 

populates is based on the selected building type.  

To view the data click on the three dot  next to the text, a pop up window opens. In here you can 

view the pre-populated data or edit it based on project specific data.  

 

 
 
Once you have added the data to all the buildings, open the simulation dialog to analyse water 
consumption. Select the objects in the ‘Object filter’, select Run VE Water Calculation. Update and 
click on Launch to start the simulation. 

 
You can view the individual building results of the water simulation as well as annual water run off in 
the room/building query tool.  



 

 
We can also view the report via the gallery or the ready-made reports. If you view the project level 
readymade reports, similar to the approach for energy use, they will show combined results for all of 
the buildings that have been simulated; as this is a ‘model’ level report rather than a building level 
one.  

 
 
Based on the size and type of building, this analysis provides us with an overview of the overall 
breakdown of water use within different types of buildings and identify areas where water efficiency 
measures can be targeted. You can also view the waste water breakdown, this can help in planning 
for a waste water recycling plant around the site.  

 



 

Export Data to iSCAN 

In the simulation launcher tool, a new feature, Export to SCAN has been added. The target year 

cannot be edited from this feature, it needs to be set in the Time tool.  

Before this tool can be used to export a model, the project needs to be first set up in SCAN with 

associated tag vocalbulary to match the building names. This way all the simulated channels 

generated will automatically be mapped onto the correct buildings within the iSCAN project.  

 

After checking the Export to SCAN box, click update and then launch.  

The export process to SCAN has been revised as follows: 

• All channels now include the relevant building names to make it easier to map in iVN 

• All channels are in on iSCAN ‘Building’ and so can be compared to each other in terms of 
performance 

• The iSCAN ‘building’ name will be the same as the iCD Model for ease of tracking 

• Channel data exported to iSCAN can be updated multiple times within 48 hours (previously 
gave an error) 

 

 

 
 

Better recognition of building types from OSM Import 

One new feature that has been added to OSM import is the ability of the tool to be able to 

automatically populate the Building Type attribute based on the available information in OSM. 

At the time of the import, if data is available it is added to two custom attributes called shop 

description and additional information, based on which the building type attribute is categorised.  



 

So for example, a bank has been categorised as an office while a mall has been categorised as a retail 

building.  

  
 

  
 

Updated Carbon Emissions Coefficient (aligned with VE 2019) 

In the preferences panel, end users can now see an additional setting for carbon emission coefficients 
for a variety of fuels based on region and territory, similar to the energy / carbon meters in the VE. 
These factors are based on location and default data is available only for locations in US, UK and 
Australia, in line with information in the VE.  
 
If end users do not specify a location, it defaults to the UK. These values are references, and if end 
users have more relevant or specific emissions coefficients available, the values in the iCD are editable 
and highlight when values are changed from the default.  The images below show the implementation 
in the iCD and the associated version in the VE. 
 

  



 

 

 
 
In addition to default electrical uses (cooling, lighting, equipment, auxiliary energy use), these 
emissions coefficients also include various fuels that can be specified for heating / hot water in 
individual buildings as shown in the image on the left.  
The overall CO2 emissions in kg/m2 is calculated per building post simulation based on the total 
emissions for electricity, heating and hot water end uses.  
 

   
 

CSV export for iPIM 

A new feature that has been added to directly create a CSV for importing data to iPIM.  

This can be accessed via Extensions -> IES iCD -> Import/Export -> Export CSV.  

To be able to use this feature you need to select the applicable options from the object filter and 

select the attributes that need to be exported to iPIM. Next click on Show, the buildings whose data 

is to be imported will be highlighted in Green. Next click on Export options and check the box against 

Export coordinates (Latitude, Longitude). Finally click Export to create a CSV.  



 

 

You can now use this CSV to create an iPIM project.  

Note the columns description in the CSV needs to be tagged appropriately prior to creating the iPIM 

project.  

  

Addition of Roof-lights/Sky Lights 

It is now possible to add roof-lights or sky lights to a building in iCD. Similar to the glazing ratio 

attribute for windows here too you will need to enter the percentage of roof glazing.  

Note at present, this is only applicable for flat roofs, however this feature is being revised to include 
all roof types in future releases.  
 

 

 
In case you are not able to view this attribute, go to Extensions -> IES iCD-> Attribute Visibility and 

make the attribute visible.  

Locate Entities 

In the toolbar, this feature has been added to search objects in the model based on the “Object 

Name”. 



 

 

When you click on the icon, a new window opens, in the Entity Type drop down menu you can select 

the object type or leave it as the default search option of “All entity types”.  

  

Next in the search term add key search words for an object. All the objects with the key work will 

appear in the window below, click on the name to zoom to the object.  

  



 

Release – December 2018 

Highlights  

Walkability 

A new feature has been added to undertake coverage analysis for walkability, bike-ability and other 

types of road and pedestrian access. It defines a free flowing boundary for realistic walkable access 

to a service along a road/pathway/pavement.  

It can be accessed via the boundary tool. Important to note that roads need to be imported for this 

feature to work. 

In the boundaries tool, when you select generate a walkability boundary, a new window opens. It is 

here that you need to first specify the walking distance, then select a point at any desired location 

on the model and run the tool.  

             

The  image below shows a potential end use of this type of analysis; a walkability study of the 

London Tube stations indicating that some locations are not adequately serviced by the tube 

network. Only the areas highlighted in orange (walkability boundaries) have walkable access to at 

least one station in London Tube network.  

 

Accessibility 

The Walkability and Accessibility tool are related and utilise the same road network. Where 

Walkability gives a service coverage analysis, Accessibility allows end users to measure distances to 

specific amenities/services.  

Similar to the walkability tool, roads need to be imported for this feature to work. This can be 

accessed via Tools -> IES Masterplanning -> Accessibility Assessment.  
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To use this feature, create a custom attribute of the amenities and assign the same to buildings in the 

model. Note, at present custom attributes assigned only to buildings can be analysed by this feature. 

The feature is under development and will represent other elements in future releases.  

 

Open the Accessibility Assessment dialogue box and pick the custom building attribute (will need to 

do this in case you have created more than one type of custom building attribute) and the amenity 

type. Now pick a point on the model (a green arrow will indicate the selected point) and click locate. 

It will highlight a path (in blue) and give the distance from the selected point to the amenity.  

       

Terrain and Map Tiles from OpenStreetMap 

iCD now has the option to import the terrain and map tiles (ground texture) directly from 

OpenStreetMap.  

Currently, the terrain feature works best for buildings. As a result, it is recommended that you exclude 

roads, pavements and landscaping from the OSM import as these features do not map well over the 

terrain.  

In case these options are selected together, a message will appears prior to proceeding with the 

import. Select “yes” to import.   

  

Note that while it is recommended not to import them together, it can still be done by selecting the 

“No” option above. In this case, it is recommended that you use the roads/pavements/landscaping 

1
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and terrain layers independently for a better visual and work experience. You can control the 

visibility from the “layers” tray in SketchUp.  

GeoJSON Import 

It is now possible to directly import GeoJSON files. This can be accessed via Tools -> IES 

Masterplanning -> Import/Export -> Import GeoJSON (with attribute mapping).  

In the attribute mapping dialogue box, you can customise the target attribute prior to importing in 

the following ways:  

• The user can chose to ignore the attribute, in this case the attributes will not be imported. 

• The user can leave the dialogue boxes as it is. In this case, all the attributes will appear as 

User Defined attributes.  

• The user can also chose the Target Attribute from an attribute in the drop down list in this 

case it will enter this data in the chosen existing attribute. 

 

Once the customisation is complete, click on Import.  

SHP Import 

Shape files can now be directly imported. This can be accessed via Tools -> IES Masterplanning -> 

Import/Export -> Import SHP.  

The attributes need to be manually mapped, as shown in the image below rather than automatically. 

After this is done you click on import. Please note that currently, objects can only be imported as 

adjacent buildings for now. They can be edited post import to represent other object types 

(buildings, boundaries etc.) the ability to map SHP objects to any object type in the iCD will be 

supported in future versions of the tool.  

 



 

Time Dimension 

A new feature has been added which has the ability to add time as a dimension. Currently allows 

end users to track and visualise construction and demolition of buildings and/or entire phases of 

development. Future versions will include energy results saved separately for each year and the 

ability to visualise all aspects of the development over time. 

This can be accessed via Tools -> IES Masterplanning -> Time.  

To be able to use this feature, first data needs to be entered in the Date Constructed and Date 

Demolished attributes. The demolished buildings and not constructed buildings will now appear in 

different layers and can be made visible/invisible as per the end user’s requirement.  

Once the attribute data is entered, open the time tool and set the transparency for the building 

types (range 0 to 225). The current year can be set in the tool. This is especially important for using 

the next new feature which is exporting data to SCAN.  

To view the time feature, move the cursor along the year bar. Note, at present the results are not 

stored.  

 

 

It is also possible to view the Demolished Entities and the Not Constructed Entities in different 

colours. You can also click on the colour to change it.  



 

 

Scenarios 

A new and interesting feature that has been introduced is comparison of multiple options. Once the 

model is created, click on the button highlighted below.  

 

This will open up the current/base option. You can create a new option by entering a name and 

clicking create. The option created, can now be modified by clicking on the Edit button. A new model 

will open with the same file name and the suffix of the name given to the option. All of the attributes 

can be edited and saved in this new model. The new file can be opened and edited as an 

independent file as well.  

                      

To compare both the options, select include, then pick the desired report from the drop down menu 

and click on compare reports. The reports will appear below each other.  

Note that each of the options can be created and edited in the same way as a normal model / 

option, however this feature allows us to compare multiple options in a more coherent way. 



 

 

Note, for the feature to work properly, it is recommended that all options created be located in the 

same folder. The feature is under development and will be refined further in future releases.  

You can also add model images against each of the scenarios that you have created.  

To do this go to Extensions -> IES iCD -> Model Image. Here you can either select a snapshot, in 

which case the current window will be added as an image or you could import an image by browsing 

through your computer.  

 

Release – June 2018  

Highlights 

Inclusion of Terrain 

A new feature has been added to show underlying terrain for models imported via OpenStreetMap. If 

you attempt to use this feature in a new, blank SketchUp file, it will prompt you to save the file first. 

Once the file is saved use the OSM import button highlighted below 

 

Select the location and radius which you intend to import. Currently, the terrain feature works best 

for buildings. As a results, it is recommended that you exclude roads, pavements and landscaping from 

the OSM import. The feature is being revised to appropriately represent these elements in future 

releases.  



 

 

Initially, you will see all buildings on the ground plane as with previous releases. If you click on the 

terrain button highlighted below, the program will prompt you to confirm that you want to import 

terrain into the model.  

 

When you select “Yes”, it will generate a dialog box outlining details of the map tiles to be imported. 

If you accept the default (recommended) settings, it will inform you of how many tiles are required to 

be imported ask if you want to continue. Click “Yes” and once the download is complete, click zoom 

extents in SketchUp to view the model with Terrain. Depending on the altitude of the location in 

relation to the local datum, you may notice the terrain ‘floating’ above the ground plane. If you click 

on the terrain button again, the model and all buildings involved go back to the ground plane. 

User Defined Colours 

This allows users to select colours by feature type / object type. This can be accessed via Tools -> IES 

Masterplanning -> Preferences. The Material colours section will have a list of objects / features and 

the colours associated with them. You can change it as desired.  

There are two sets of Materials Colour Sources, “User” and “Model”. All colour palettes associated 

with the “User” colour source with used for every new model created / opened by that end user.  

The “Model” colour source applies to a given model only. It will not be implemented in other models 

by default.   



 

 

Inclusion of PV’s as objects 

PV’s can now be added to an iCD model using the create dialog box and selecting freestanding PV. 

Step-1 

 

Step-2 



 

 

Step-3: you can specify the size of the panels (height, width), the rotation (orientation) and 

inclination. A default rotation of zero equates to facing north, 90 -> east, 180 -> south, 270 -> west. 

 

A brief description of each of the items is below to help you with the data entry: 

Non-building height in meters: This is the size of the PV panel. Let’s say 1 meters.  

PV conversion factor: Efficiency is the comparison of energy output to energy input of a given system. 

For solar photovoltaic (PV) cells, this means the ratio of useful electrical energy they produce to the 

amount of solar energy incident on the cell under standardized testing conditions. Most commercial 

cells are below 30%. For this case let’s consider that the efficiency is 15% or 0.15.  

Rotation:  Solar panels work best when they face directly into the sun. So for best results, your solar 

panels should face toward the equator. If you live in the Northern Hemisphere, face them south. If 

you live in the Southern Hemisphere, face them north. In our case here it will be 180 degrees so that 

the panels faces south.  



 

Inclination: The tilt angle of the photovoltaic (PV) array is the key to an optimum energy yield. The 

optimum tilt angle is calculated by adding 15 degrees to your latitude during winter, and subtracting 

15 degrees from your latitude during summer. For instance, for this model of Glasgow the latitude is 

55° and since it is summer the optimum tilt angle for your solar panels will be 55 - 15 = 40°.  

Width in meters: Let’s assume the width will be 1.5 meters.  

You will need to click at any point on the model to place these PV panels you can add as many panels 

as required for your project.  

These panels will now be included in any solar analysis you run via Tools -> IES Masterplanning -> 

Solar Assessment 

 

You can then view the report from Extension -> IES iCD -> Reports -> Ready-made reports ->Site 

Renewable Reports  

In the full site renewable report, we can view, the monthly PV radiation, the monthly PV electricity 

yield, the annual PV yield versus electricity and gas loads and the annual PV yield versus total energy 

loads.  

Import Data from iSCAN 

Building objects within iCD can now be linked to detailed simulated and measured time-series data 

from SCAN projects via Tools -> IES Masterplanning -> SCAN Client and these links can also be 

exported to CIM projects for visualisation. 

 

Please get in touch with IES support for more details. 
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Release – October 2017 

Highlights 

More data from OpenStreetMap 

iCD will now import the number of storeys for buildings in OpenStreetMap when this information is 

available. iCD will also handle intelligently weird cases where both building height and number of 

storeys seem to be inconsistent. 

Two-step simulation for the Virtual Environment 

When a VE simulation is launched, the user can choose to perform a two-step simulation. In the first 

step, the selected buildings are exported to the Virtual Environment. At this point the user is able to 

open the model locally, perform any required modification and finally perform the actual simulation. 

This new feature allows users to personalize even more the VE simulation and use more detailed 

results in their iCD models. 

Attribute visibility 

In this release we have added a new feature called Attribute Visibility. Attribute Visibility can be 

accessed via Tools -> IES Masterplanning -> Attribute Visibility. Users can now choose the attributes 

that they want to be shown in every panel of the plugin. At any given point the user can add or 

remove attributes. 

To use the feature one needs to select the attribute on the AVAILABLE ATTRIBUTES side and click on 

the arrow button. The attribute will now be visible on the VISIBLE ATTRIBUTES side. Click save and 

close.  

See example below 

 



 

New ground texture data source 

We have now have a new ground texture data source called Geofabrik. This new source is much 

faster and can download a larger area quickly.  

To enable the use of this new data source the user first needs to import the settings file.  

The import has to be done via Tools -> IES Masterplanning -> Ground Textures -> Import Settings -> 

(browse and select) tile-services.json.  

The ground texture will now appear in Tools -> IES Masterplanning -> Ground Textures -> Add image 

-> Tile service -> geofabrik 

Please get in touch with IES support for the settings file. 
 

New CIM synchronization 

A new synchronization button has been introduced to connect your iCD model to a central 

Community Information Model (subscription based). The new feature makes the synchronization 

with the central model very easy and robust. 

 

Any changes/edit made to the iCD model is now automatically and correctly synchronized with the 

centralized model at the click of a button.  

The list of changes is clearly listed in a pop up window so the user will always know what it is 

happening.  

Changes from multiple users are also possible and will be automatically kept in sync with the new 

synchronization features 

 
Please get in touch with IES support for more details and subscriptions. 
 

Attribute edit 

It is now possible to edit custom attributes. Click on the Edit button to view and edit the attribute.  

 
 



 

To edit, simply click the edit window, the user can now edit all the data except the type.  
 

 

 

Faster import 

We have now enabled a faster import method. This will help the user import a larger area in a much 

shorter time.  

For example for the city of Glasgow, to import a radius of 2500m it would ordinarily take eight 

minutes. However now with the new and faster import the same radius would take only two 

minutes. The difference will be more prominent as and when the user imports larger areas.  



 

Release – June 2017 

Highlights 

Simulation results in Boundaries Dynamic Report 

In this release we greatly expanded the list of attributes available in the Dynamic Report. This 

enhancement will allow users to perform even more detailed analysis of their masterplan. 

 

Search Tab in iCD 

A new search tab has been introduced in the iCD tool bar.  

 

Users can now easily search for any urban feature included in their model; iCD will automatically 

move the camera to the feature’ location. If multiple entries are found, users can simply move 

between them using the arrow keys.  

 



 

Import of lists from geoJSON and CSV 

 
It is now possible to import lists in iCD from geoJSON and CSV files. While importing, users can 

choose to map to existing core lists or previously created lists. 

 

 
It is also possible to edit the actual mapping and fix incorrect inputs. In this way users can easily 

import dirty data and iCD will take care of the correct mapping without any further user 

intervention. 

 
 
By clicking on the attribute being imported and then on Edit mapping, users can edit the specific 

mapping that will be applied during the import. It should be noted that, by design, it is not possible 

to change core lists such Building type, HVAC system, etc… 

 

 
 

  



 

Release – May 2017 

Highlights 

Improved User Interface 

We have made some small, but important changes to the UI (fonts, spacing, headers). There is now 

more space available and it is possible to visualize more information even on smaller screens. 

 

Figure 1: New iCD compact layout 

New automatic reports for site and boundaries 

We think our users will really enjoy this new features. Users can now generate summary site (and 

boundary) reports for three themes: site, energy and urban features. These reports are generated 

automatically and dynamically and give users aggregate site data, KPIs, useful info. 

The reports can be accessed from Tools -> IES Masterplanning -> Reports. 

 

Figure 2: Site summary reports 



 

Dynamic reports for boundaries update 

All the reports can now be saved in the model as template 

 

Figure 3: Dynamic boundary reports can now be saved as templates 

Under the hood 

• Fixed a minor bug with the iCD visualization tool not working with older graphic cards 

• Minor bug fix in geoJSON and CSV import 

• All windows now scale and resize as expected 

  



 

Release – March 2017 

Highlights 

• Improvements to boundary tool 

• CSV import into iCD (QGIS-like Spatial join) 

• Export model and object attributes to CSV 

• Peak values added to simulations results  

Under the hood 

• Fixed a few bugs 

Release – February 2017 

Highlights 

• Layers management for iCD objects. It is now possible to select, deselect and hide all the 

urban features imported from OpenStreetMap. Layers can be managed from SketchUp or 

from within the iCD plugin itself. 

• Improvement in geoJSON import. It is now possible to import geoJSON files with arbitrary 

attributes. iCD will do its best to guess the type of attribute and to clean up dirty data. 

• Ground textures from OpenStreetMap can now be added to the iCD model. 

• Faster Boundary tool 

Under the hood 

• We are working to create a seamless link between iCD and our 3D database. 

• Fixed a few minor bugs 

Release – January 2017 

Highlights 

• GeoJSON import with attributes. It is now possible to import a geoJSON file with all the 

associated attributes. The import tool can automatically parse the data and suggest the best 

type for each attribute. 

• Dynamic Reports for boundaries. 

• It is not possible to unset any attribute value. 

• Much clearer distinction between building level attribute and floor level attribute 

Under the hood 

• We are working to create a seamless link between iCD and our 3D database. 

• Fixed a few minor bugs 



 

Release – November 2016 

Highlights 

• Full compatibility with SketchUp 2017 

• In the Building Query Tool, it is now much easier to ‘unset’ values. 

• Clearer building hierarchy in Building Query Tool: 

o In the Building Query Tool, it is not possible to assign a space type to a building 

anymore. 

o To assign a space type, expand the floors view for the building and assign spaces as 

required 

 
• It is now much easier to deal with mixed-use buildings. 

• It is now possible, if required, to specify glazing ratio by eight orientations. 

Under the hood 

• We are working to create a seamless link between iCD and our 3D database. 

• Fixed a few minor bugs 

Release – October 2016 

Highlights 

• Full restyling of the plugin interface 

• It is now possible to specify Glazing Ratio by Orientation 

• General improvements in user experience such as faster menus, clearer inputs, etc… 

Known Issues 

• With new object colouring, glazing is not displayed for buildings that use texture glazing 

Release – September 2016 

Highlights 

• General restyling of the plugin interface 

• Improvements to OSM import tool. 

o Added filter to avoid import of geometries that are too small 

o Added option to let iCD to infer the number of storeys from the building height 

• Improvements to geo-location and search when importing from OSM 

• Added prototype dashboard for reporting on boundary properties 

• Added Import/Export of JSON format for boundaries 



 

Known Issues 

• With new object colouring, glazing is not displayed for buildings that use texture glazing 

Release – July 2016 

Highlights 

• Significant optimisation of object colouring (used in various tools) 

• Improvements to Boundary tool 

• Improvements to geo-location when importing from OSM 

• Added Import/Export of custom variables, boundaries and filters 

Known Issues 

• With new object colouring, glazing is not displayed for buildings that use texture glazing 

Release – April 2016 

Highlights 

• Added initial Boundary Tool 

• Added GeoJSON and CSV import/export 

• Improved filter editor 

• Added custom scale to visualisation tool 

• Added utilities to combine/split objects, save object selection and override building floor 

area 

• Added troubleshooting utilities 

Known Issues 

• Filters are now stored per-model rather than per-user, and cannot be imported/exported in 

this build 

 



 

 


