
 

 

 

 

  
iSCAN Demo Project 

Overview 
05/12/2019 



 

2 
confidential 

Contents 
1. Introduction .................................................................................................................................... 3 

2. Project Setup ................................................................................................................................... 3 

2.1. Building Details ....................................................................................................................... 3 

2.2. Weather .................................................................................................................................. 3 

2.3. Data Import ............................................................................................................................. 3 

3. Channel Settings ............................................................................................................................. 4 

3.1. Tagging Channels .................................................................................................................... 4 

3.2. Expressions .............................................................................................................................. 5 

4. Visualise Tool .................................................................................................................................. 6 

5. Insights Tool .................................................................................................................................... 7 

6. Rules & Alerts .................................................................................................................................. 8 

6.1. Creating Rules ......................................................................................................................... 8 

6.2. Creating Alerts ........................................................................................................................ 8 

 

  



 

3 
confidential 

1. Introduction 
 

The IES Demo project is an example project, populated with real-life data, to act as a useful reference 

and exploration of a typical iSCAN project.  This document is an overview of the demo project to 

demonstrate some of the features of iSCAN.  

You should be able to see the Project in your project’s list when you login to iSCAN 

(https://iscan.iesve.com/building-details/IscanDemoTrial/IesHelixDemo). If not please contact your 

Business Development Manager or keys@iesve.com. 

For more detail on how to creating an iSCAN project and for more information on it’s features, please 

refer to the Training Videos and User Guide. 

2. Project Setup 
 

2.1. Building Details 
 

The Building > Building Details page is used to edit information about the project, such as name, 

sample period, time zone, etc.  This is also where the location and altitude of the site is added. This 

information may be used to obtain weather data for the site location. 

Please refer the Training Videos for more details.  

2.2. Weather 
 

Once the site location and altitude are entered to the Building > Building Details page, the weather 

data may be obtained. This is done from the Data > Weather page.  

Highlight the dates for the required year(s) and select Populate Historical Data. Once populated, this 

data will be available in the iSCAN project.  

To enable automatic updates of weather data select the checkbox for Enable automatic weather 

updates. Weather forecasts may also be enabled here for a maximum of 5 days by entering the 

number of days to forecast by. 

2.3. Data Import 
 

Data may be imported via the Data > Import tab for a range of formats including; 

 Manual imports (CSV, XML) 

 Automated Imports ((SCAN Robot, web service connections, dedicated IoT connections e.g. 

MQTT, LoraWAN etc.) 

For more information on how to import data, please refer to the Training Videos and User Guide for 

further detail. 

https://iscan.iesve.com/building-details/IscanDemoTrial/IesHelixDemo
https://iscan.iesve.com/building-details/IscanDemoTrial/IesHelixDemo
https://distance-learning.iesve.com/p/iscan
https://help.iesve.com/iscan2019/1__introduction.htm?ms=AAA%3D&st=MA%3D%3D&sct=MA%3D%3D&mw=MjQw
https://distance-learning.iesve.com/p/iscan
https://distance-learning.iesve.com/p/iscan
https://help.iesve.com/iscan2019/1__introduction.htm?ms=AAA%3D&st=MA%3D%3D&sct=MA%3D%3D&mw=MjQw
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3. Channel Settings 
 

Once data has been imported to iSCAN, it will be available as Channels, and is displayed on the Data 

> Channel List page. Each channel represents a dataset containing timeseries data.   

Channels will always be visible on the left-hand side of the screen. When a channel is selected, 

information about that channel will be available on the right. 

On the “Channel Setting” tab, information may be added to each channel to give more meaning to the 

channel data. This includes; the channel name, units, sample type, min and max values and export 

options. Notes may also be added to channels to share information with other project users.  

For more detail on each of the Channel Settings, please refer to the Training Videos and User Guide. 

 

3.1. Tagging Channels 
 

Tagging channels allows the user to give more meaning to Channel data and organise the iSCAN 

project as desired. 

Tags can be added from the Project > Tag Vocabularies page.  

Once a tag vocabulary is created, tags can be added to the vocabulary. 

In the demo project a tag vocabulary called “Helix Tags” has already been created. Selecting this will 

open the vocabulary to show which tags have been created. Once tags are created within the 

vocabulary, they may be applied to channels. 

Tags may be applied to channels from the Data > Channel List page, from the Tags tab.  

As tags have already been applied in the Demo Project, try changing the filter options to “Vocabulary: 

Helix Tags” to demonstrate how tagging can be used to organise channels in a project.  

  

https://distance-learning.iesve.com/p/iscan
https://help.iesve.com/iscan2019/1__introduction.htm?ms=AAA%3D&st=MA%3D%3D&sct=MA%3D%3D&mw=MjQw
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3.2. Expressions 
 

Expressions allows the use of mathematical functions to derive virtual channels from measured data 

channels within the iSCAN project.  iSCAN expressions use their own syntax, which more detail is 

available within iSCAN, from the Syntax link on the Channels Settings tab. 

In the Demo Project there are already some example Channels setup with the use of expressions. 

These are; 

 Total Electricity: 

This channel uses a simple expression, summing up the electricity metered from the three 

electricity sub-meters within the building.  

 

`Electricity Meter 1`+`Electricity Meter 2`+`Electricity Meter 3` 

 

This is useful in cases where some areas of a building are metered, but not all. Instead of 

installing additional meters, expressions may be used to derive “virtual meters” from existing 

data within the building. 

 

 Window Opening: 

This channel uses an expression to calculate a profile for window openings based on the 

outdoor air temperature and hours of occupancy. 

 

Building.`Occupied Hours` == 1 and Mean(Weather.`Dry Bulb Temperature`, 2 hr)>14? 1 : 0.01 

 

This means, when the building is occupied and when the outdoor dry bulb temperature is 

greater than 14℃ for more than a 2 hour period, the window is open. Outside of occupied 

periods it takes a value of 0.01 to account for leakage when windows are closed. 

 

This is an example of a channel which may be used as a free form profile in an IESVE model. 

 

More information on expressions can be found in the Training Videos and User Guide. 

 

  

https://iscan.iesve.com/expression-syntax/IscanDemoTrial/IesHelixDemo
https://distance-learning.iesve.com/p/iscan
https://help.iesve.com/iscan2019/1__introduction.htm?ms=AAA%3D&st=MA%3D%3D&sct=MA%3D%3D&mw=MjQw


 

6 
confidential 

4. Visualise Tool 
The visualisation tool can be accessed from the Investigate > Visualise page, and offers a range of 

plot types for different type of analysis. Some examples to try using the demo project include; 

 Calendar Tool 

Select a channel measuring temperature from the channels list. On the calendar beneath the 

plot, select Quality. Days within the calendar will be color coded to show days with high vs. 

low data quality. 

 
 

This is a useful feature for identifying issues with existing meters. Similar can be done to 

view other properties of the dataset, such as minimum and maximum values observed, etc. 

 

 Heat Maps 

Plots types can be changes via the “Setting” tab on the Visualise page. Multiple channels can 

be selected at once using the CTRL key for each of the available plot types. 

 

An example plot which may be used to analyze data is the heat map. Select channels 

`Electricity Meter 1`, `Electricity Meter 2` and `Electricity Meter 3`, and select a data range of 

approximately 1 month from the calendar.  

 

In the settings tab, add a “Max Value” of 30 to update the heatmap plot  

 
 

The heat map shows electricity consumption typically from Mon-Fri between 8am-6pm. Note 

that for Electricity Meter 3, there is some operation on weekends and evenings. 

This is a useful feature to quickly identify when systems are operation outside of schedules. 

Use the existing data to try out other calendar filters and plot types to analyze the data and gain an 

understanding for the building operation. 
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5. Insights Tool 
 

The insights tool can be accessed from the Investigate > Visualise page.  Insights was create to 

automate analysis of the imported channel data and check for common data and building 

performance issues.  

Insight rules can be applied from the Insights Tools tab. Some examples to try out in the demo 

project include; 

 Times of high room temperature 

From the channel list, select 10 channels representing indoor room  temperature. The filter 

may be used to show only channels with “temperature” in the name.  

 

On the “Insight Tools” tab, select the “Value greater  than” from the Tool’s dropdown menu, 

and enter a value of 25 ℃.  

 

Select a date range using the calendar. This tool will highlight the times room temperature 

exceeds 25℃. 

 

 Times systems are on while building is unoccupied 

Select “Meter 4 Lighting” from the channel list.  

 

On the insights tool tab, select “On while unoccupied” from the Tools dropdown menu.  

 

Enter 8 as the on Values (i.e. the baseline value), and select “Occupancy” as the Channel 

representing occupied hours. 

 

Select a date range using the calendar, and this tool will highlight all time where the systems 

are on outside of occupied hours. 

 

 Calibration check of meters 

Select all meters from the channel list (use filter). 

 

On the “Insight Tools” tab, select the “Value lower than” from the Tool’s dropdown menu, 

and enter a value of 0.  

 

Select a date range using the calendar and this tool will highlight all the times where the meter 

reads a negative value. As these meters are for electricity consumption, we know that any 

instances are do to a calibration issue. 

 

The insights tool helps to identify common issues in the building. Once these are known, the Rules and 

Alerts feature may be used to automatically alert when such issues occur. 
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6. Rules & Alerts 
 

6.1. Creating Rules 
 

Automated rules can be created from the Project > Rule Libraries page.  

There are two rule types which may be created; Alarms and Analysis. 

In the Demo Project, some example Alarms Rules have been created. These can be viewed by selecting 

“Alarm Rules”, which will display the Rule Classifiers created. New rules can be created by selecting 

the “Create” button on this page. The rules existing in the demo project are; 

 Energy Increased 

Rules are setup in the Categories tab with the use of expressions. The expression used to 

create this rule is; 

 

Date.DayOfWeek >1 and (Sum(Channel, pluprevious 1dy) -Sum(Channel, previous 1dy)) > 

(Sum(Channel, pluprevious 1dy)*0.1) 

 

Which means, alert when electricity consumption exceeds 10% of the previous days value. 

Similar could be done in comparison to benchmark channel from an IESVE energy model 

instead of using the values from the previous day. 

 

A preview of times when this rule was broken may be viewed from the “Preview Period” tab, 

and by selecting a date range. 

 

 Space Temperature Monitor 

This rule has been setup to give two levels of alerts; a warning, and a danger. The rules are; 

 

Warning of “High Temperature” if Channel > 25 

Warning of “Very High Temperature” if Channel > 28 

  

6.2. Creating Alerts 
 

Alerts may be created from the Project > Rule Scheduling page. The “Add Ruleset” button creates 

new rules to be evaluated. 

In the demo, Rulesets have been created for “Energy Increased” and “Space Temperature”.  

Once a Ruleset is selected, the notification type and people to notify may be changed under the 

“Notification” tab, and the frequency of the notifications may be edited under “Scheduling”. 

Once a notification is created, rules may be applied from the Rule Libraries page for the selected 

Alarm. When previewing the rules as shown in section 6.1, the rule may be applied to a notification 

by selecting the “Save all previews” button, and applying to the desired Ruleset.   
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